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About this Document 
This document is for Cisco Engineers and customers deploying Cisco Stealthwatch 6.9 with Cisco Identity Service 
Engine (ISE 2.2 using Cisco platform Exchange Grid (pxGrid).   The reader should have some similarity with ISE and 
Cisco Stealthwatch and pxGrid. 

Cisco Stealthwatch 6.9 no longer requires syslog information for obtaining contextual information, instead pxGrid is 
used.  The Cisco Stealthwatch Management Console will register as a pxGrid client and subscribe the ISE pxGrid node 
Session Directory topic to obtain the contextual information. 

ISE 2.2 features an internal Certificate Authority (CA) for deploying pxGrid certificates. These pxGrid client 
certificates can be generated from ISE in either PEM or PKCS12 formats and imported into the Stealthwatch SSL 
Client store and ISE internal CA root certificate imported into the Stealthwatch CA store.  Additionally, certificates 
can be generated based on the Certificate Signing Requests (CSR).  These scenarios will be covered in this document.  

This document starts using the preferred method of using the ISE 2.2 Internal CA for deploying pxGrid and 
Stealthwatch 6.9 using PKCS12 certificate format and then covers an external CA server deployment. 

Self-signed certificate deployments and other ISE 2.2 internal CA configurations are covered under the Other 
Configurations Section. 
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Technical Details 
Cisco Stealthwatch 6.9 uses Cisco platform exchange Grid (pxGrid) for obtaining user session information for 
populating tables, and for taking Adaptive Network Control (ANC) mitigation actions on the endpoint such as 
quarantine and quarantining the endpoint. 
 
Stealthwatch Management Console (SMC) will successfully connect and register with the ISE pxGrid node and 
subscribe to the ISE pxGrid node Session Directory Topic to obtain the: macaddress, ipAddress, lastActiveTime, 
username, securityGroup, vlan, domainName, interfaceDeviceip, interfaceDevicePortId.  These attributes are mapped 
to the: MacAddress, Endpoint IP Address, Start Active Time, UserName, Security Group ID, vlan, AD Domain Name, 
NAS IPC Address, NAS Port ID in Stealthwatch. 
 
SMC will also subscribe the ISE pxGrid node EndpointProtectionService Topic to perform legacy EPS functions such 
as quarantining and unquarantining by the IPAddress. 
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Using ISE 2.2 Internal CA Authority (Preferred Method) 

Generating Certificate Signing Request (CSR) using PKCS12 format 

Creating Stealthwatch certificate 
Step  1 Select Administration->pxGrid Services->Certificates, and enter the information below: 

Note: You can only generate a key size of 2096 due to a bug in the pxGrid template 

 

               
 
Step  2 Select Create 
Step  3 Save the zipped file locally 
 

                  
 
Step  4 You should see the following 
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Step  5 Download the root certificate chain 
Select Administration->pxGrid Services->Certificates->select the ISE pxGrid hostname and PEM 
format 
 

 
 
Step  6 Select Create 
Step  7 Save the zipped file locally, you should see the following files: 
 

            
 

Importing ISE CertificateServicesRootCA into Stealthwatch CA store 
Step  1 Upload the CertificatesServicesRootCA certificate to the Stealthwatch CA Authority 

Select Gear    ->Administer Appliance->Configuration->Certificate Authority Certificates-
>Browse and upload the ISE certificate and provide a friendly name 
 

 
 

Step  2 Select Add Certificate and confirm 
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Step  3 You should see the following: 
 

                     
 
 

Uploading Stealthwatch PKCS12 file 
Step  1 Select Configuration->SSL Certificate->SSL Certificates->SSL Client Identities->Upload a PKCS12 

file 
 

                    
Step  2 Select Upload Bundle and confirm 
Step  3 You should see the following under SSL Client Identities 
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Configuring Stealthwatch pxGrid Operation 
Step  1 From the Stealthwatch Management Center Dashboard, select Deploy->Cisco ISE Configuration 
 

                    
 
Step  2 Select Save and OK, you should see a successful connection 
 

                    
 
Step  3 On ISE, select Administration->pxGrid Services 
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Using an External Certificate Authority (CA) Server 
Using an external CA server to generate pxGrid certificate, a customized template with an EKU of both client and 
server authentication must be configured.  In this example, Microsoft 2008 Enterprise CA R2 Server was used. 

Customized Template 
Step  1 Select Administrative Tools->Certificate Authority-> “+” dropdown next to CA server->Right-Click 

on Certificate Templates->Manage
 

  
 

Step  2 Right-Click and Duplicate User template->Select Windows 2003 Enterprise->OK 
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Step  3 Enter name of certificate template, uncheck “Publish certificate in Active Directory”, and provide validity 
period and renewal period. 
 

 
 

Step  4 Click Extensions->Add->Server Authentication->Ok->Apply 

                 
 
 

 
 
 
 
 
 
 
 
 
 
 



   

 

 

 

 

Cisco Systems © 2017 Page 12  

SECURE ACCESS HOW-TO GUIDES 

Step  5 Click Subject Name, Enable Supply in the request 
 

 
 
Step  6 Click Extensions->Issuance Policies->Edit->All Issuance Policies 
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Step  7 Leave the defaults for request handling 
 

 
 

Step  8 Right-click on Certificate Templates � 
Step  9 Select New Template to issue and select pxGrid 
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Step  10 You should see the pxGrid template 

                   
 

Configuring ISE 2.2 ISE pxGrid node 

Generating Certificate Signing Request (CSR) 
 
Step  1 Select Administration->System->Certificates->Certificate Management->Certificate Signing 

Requests->Generate Certificate Signing Request (CSR) 
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Step  2 Select Generate 
Step  3 Select Export and open the PEM file copy 

-----BEGIN CERTIFICATE REQUEST----- 
MIIC7jCCAdYCAQAwGzEZMBcGA1UEAxMQaXNlNDcwLmxhYjEwLmNvbTCCASIwDQYJ 
KoZIhvcNAQEBBQADggEPADCCAQoCggEBAJSM1PM6t1crlvZxEe584Y/dnrrEdE7j 
qKiS0RWLXmbEDHXl5F0rIhcn7rAR0e9h8V1oeA4v9+Sj1I0slsfTETUoWbWpqgyo 
J5DEj5YxS2vH+cAhKj5Xp4ls7ziqBaUyw9OnaRTjUp40gyOY3O2/8NCWWXvt4r0w 
gFYuIbi8emMRuNPn+448f3Rx3mHs2cdARosjtUC/OmAfysl7uPDCahjGqapy/l0E 
TuW0MAjdvUaibimDl+WmsWnFvmiSVuoFh5/JYGh3pXdw5MK9tt5hltP0dZMkbANJ 
1jwyYmOeVz9Zal51nuWpJJ5bZJjZE88/dA8pQJFOXE/jqTmfZzwhztsCAwEAAaCB 
jTCBigYJKoZIhvcNAQkOMX0wezAbBgNVHREEFDASghBpc2U0NzAubGFiMTAuY29t 
MAsGA1UdDwQEAwIF4DAdBgNVHQ4EFgQU2jmj7l5rSw0yVb/vlWAYkK/YBwkwHQYD 
VR0lBBYwFAYIKwYBBQUHAwEGCCsGAQUFBwMCMBEGCWCGSAGG+EIBAQQEAwIGQDAN 
BgkqhkiG9w0BAQsFAAOCAQEAADS9KUeb8wvLZbkxYFB/ecsfGM2kIGhPDtn9/0de 
rzZCEx3BzE9hi3ILXibjIZA4FsuvLowSTE2mTB32/uTr1R+JEobS0foc9oLUOTgW 
uoPtrHAXqdIPO+jUl+fDz+Ib3dbSaSqGY5fvsm7YvEo8OMvlbM23mTWzHoYgjk3G 
vtxxvNmRGLL53ijSH+PE476a0eKgD+iLyG6oM2KJOWbDrBEwHUPDhmiIWal1uP0Y 
iizVXBrupn5Y4E4iYTSy1p38hh0eiTSelgvcF6xdWDM2tESKaK6jJRDJNS6QJTR0 
CGuoV7JiBMTLVD+iM+5/Q/kEV/TOORIZaLZrlYHIA3sZyw== 
-----END CERTIFICATE REQUEST----- 

Step  4 Paste into CSR request 
 

                
 
Step  5 Select Submit 
Step  6 Select Base64 encoded 
Step  7 Select Download certificate and save file locally. This file was renamed to ise470.cer 
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Step  8 Download the CA root certificate 
Select Download Certificate->Base 64->Download CA certificate 
 

 
 

Step  9 Rename the certificate to caroot.cer 
 

Importing CA root certificate into ISE Trusted Certificate Store 
Step  1 Select Administration->System->Certificates->Certificate Management->Trusted Certificates-

>Import->Certificate file and import the root certificate 
 

                  
 
Step  2 Select Submit 
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Bind ISE certificate to Certificate Signing Request (CSR) 
Step  1 Select Administration->System->Certificates->Certificate management->Certificate Signing 

Requests->select ISE node->Bind Certificate 
 

                            
Step  2 Select ISE certificate file and upload the root certificate 
 

                   
 
 
Step  3 Select Submit 
Step  4 Select Yes for an application restart 
Step  5 Select Yes to replace the existing certificate. The system will restart 
Step  6 Select Administration->System->Certificates->System Certificates 

You should see the default pxGrid certificate signed by the internal ISE CA 
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Step  7 Edit the admin certificate 
 

                 
Step  8 Select pxGrid 
 



   

 

 

 

 

Cisco Systems © 2017 Page 19  

SECURE ACCESS HOW-TO GUIDES 

                  
 
Step  9 Select Save 

You should see the pxGrid purpose assigned to the admin certificate 
 

 
 
 
 
 
 
 
 
 
 
 



   

 

 

 

 

Cisco Systems © 2017 Page 20  

SECURE ACCESS HOW-TO GUIDES 

Enabling pxGrid 
 

Step  1 Select Administration->System->Deployment->edit ISE node->enable pxGrid 
 

                
 
Step  2 Select Save 
Step  3 Run “sh application status ise” to verify the pxGrid services are running 
Step  4 Select Administration->pxGrid Services, you should see the published nodes appear and pxGrid node 

connectivity 
Step  5 Select Administration->pxGrid Services->Settings->pxGrid Settings->Automatically approve new 

certificate-based accounts 
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Generating Stealthwatch certificate 
 
Step  1 Generate private key from the  Stealthwatch Management Center 

openssl genrsa -out smc69.key 2048 
Generating RSA private key, 2048 bit long modulus 
......+++ 
........................................+++ 
e is 65537 (0x10001) 

Step  2 Generate certificate signing request (CSR) request 

openssl req -new -key smc69.key -out smc69.csr 
You are about to be asked to enter information that will be incorporated 
into your certificate request. 
What you are about to enter is what is called a Distinguished Name or a DN. 
There are quite a few fields but you can leave some blank 
For some fields there will be a default value, 
If you enter '.', the field will be left blank. 
----- 
Country Name (2 letter code) [AU]:US 
State or Province Name (full name) [Some-State]:Maryland 
Locality Name (eg, city) []:Germantown 
Organization Name (eg, company) [Internet Widgits Pty Ltd]:Cisco 
Organizational Unit Name (eg, section) []:Engineering 
Common Name (e.g. server FQDN or YOUR name) []:smc69.lab10.com 
Email Address []:j@lab10.com 
 
Please enter the following 'extra' attributes 
to be sent with your certificate request 
A challenge password []: 
An optional company name []: 

Step  3 Copy the CSR request  

-----BEGIN CERTIFICATE REQUEST----- 
MIIC1TCCAb0CAQAwgY8xCzAJBgNVBAYTAlVTMREwDwYDVQQIDAhNYXJ5bGFuZDET 
MBEGA1UEBwwKR2VybWFudG93bjEOMAwGA1UECgwFQ2lzY28xFDASBgNVBAsMC0Vu 
Z2luZWVyaW5nMRYwFAYDVQQDDA1zbWMubGFiMTAuY29tMRowGAYJKoZIhvcNAQkB 
FgtqQGNpc2NvLmNvbTCCASIwDQYJKoZIhvcNAQEBBQADggEPADCCAQoCggEBAK8Q 
HHiQnLJVTmKOR1W/h/LqgUJlJIMiQZMh6EeO/ZorSFnG6Ge5bB8KCNdoFgTLoORL 
W//WWl+mAZ1oxBzZ+dXItC8GyxJonSkhnxx44yvgDYtwuGMBLUKLV+b/efSAm/ev 
2c7MKxse6rw/yGJkoUpVKrjsKLXaJKPecogU1o25aEu2S3JrA3+dUdQUV4V8JmtY 
C5qb4C4iSmg3eBcENz66ZnGarPKHghY5W5swC07z/H6pes5AW2w869hbygXKnMMv 
LY1uun6AocdtMubzFLKwaCSZXsgBvBfde7qjPJUIVMKtGZKMQSERQSE5UcE87KnU 
Oa4iNZHL3HbokU/36XUCAwEAAaAAMA0GCSqGSIb3DQEBCwUAA4IBAQAPrFwocuW1 
p9dnext60zBYe3AWU5HwPiRcYv+ZQ3YxF+naC2rKXLKJ/TDW+Woep1/51x0YpC21 
Mo4fF8AGmzQYzgLZa71p8RZQGOoj0x23h+NWvCUlZ8iwEqbtgNUGhYF9NEdNbjJR 
Xu7SJDVGwMG96qsrEkUuyaXlFoZmOurjAN3Epifa+wpJfThhfs6L8rL3RRV+oXdy 
O0QStp/Xs7UfpCd7tm8m6XHozkPXAbqJC4d98tASTfSRjxB5TC3PXiA8fM/EVBW+ 
v9SVl0dkJ+Z2OHkFEpclX3LD72z4VWsn16iuTtR4dwdAgASU4f0bK3CCX+exjlTA 
zlpRJY7ixh3P 
-----END CERTIFICATE REQUEST----- 
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Step  4 Paste into request 
 

                   
 
Step  5 Select Submit 
Step  6 Download certificate in base 64 encoded format and rename to smc69.cer 
Step  7 Download the CA root certificate 

Select Download Certificate->Base 64->Download CA certificate 
 

 
 

Step  8 Rename the certificate to caroot.cer 
Step  9 Upload the root certificate into the Stealthwatch CA Authority Store 
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Importing CA root certificate into Stealthwatch Certificate Authority Store 
 
Step  1 On the SMC, upload the CertificateServcicesRootCA-ise470.cer to the SMC CA Authority 

Step  2 Select Gear    ->Administer Appliance->Configuration->Certificate Authority Certificates-
>Browse and upload the ISE certificate and provide a friendly name 

 

                   
 
 
Step  1 Select Add Certificate and confirm 
Step  2 You should see the following 
 
 

                
 
 

 

 

 

 



   

 

 

 

 

Cisco Systems © 2017 Page 24  

SECURE ACCESS HOW-TO GUIDES 

Importing Stealthwatch certificate into Stealthwatch SSL Client Identities Store 
 
Step  1 Select Configuration->SSL Certificate->SSL Client Identities->Upload Stealthwatch public private-

key pair 
 

                  
 
Step  2 Select Upload Certificate and confirm 
Step  3 You should see the following under Client Identities 
 

                  
                     

Configuring Stealthwatch pxGrid Operation 
Step  1 From the Stealthwatch Management Center Dashboard, select Deploy->Cisco ISE Configuration 
 

                   
                
Step  2 Select Save 
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Step  3 On ISE, select Administration->pxGrid services, you should see SMC has successfully registered and 
subscribed to the pxGrid topics 
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Other Configurations 

Using Self-Signed Certificates for SMC & ISE pxGrid node 

Enabling ISE pxGrid node for Self-Signed Certificates 
Enable pxGrid on the designated ISE node. 

Note: With ISE 2.0 and above you no longer have to import the ISE identity certificate into the Trusted System Certificate Store, as you had to do 
with ISE 1.3 and 1.4 

Step  1 Select Administration->System->Deployment->select node->Edit->enable pxGrid 
 

                    
 
Step  2 Select Save 
Step  3 Verify that the published node appear and that there is connectivity to the ISE pxGrid node 

Administration pxGrid Services 
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Exporting ISE Identity Certificate in Stealthwatch Certificate Authority (CA) Store 
Step  1 Export the ISE self-signed identity certificate into the Stealthwatch Management Center’s CA trusted store 

Select Administration->System->Certificates->Certificate Management->System Certificates-
>Default self signed server certificate->Export 
 

 
 

Step  2 Export the public certificate only 
 
 

                   
Step  3 Select Export 

Step  4 Select Gear    ->Administer Appliance->Configuration->Certificate Authority Certificates-
>Browse and upload the ISE certificate and provide a friendly name 
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Step  5 Select Add Certificate and confirm the certificate 
 
 

Creating and Generating Stealthwatch Certificates 
Step  1 Generate private key from the Stealthwatch Management Center 

openssl genrsa -des3 -out smc69.key 2048 
Generating RSA private key, 2048 bit long modulus 
......+++ 
........................................+++ 
e is 65537 (0x10001) 
Enter pass phrase for smc69.key: cisco123 
Verifying - Enter pass phrase for smc69.key: Cisco123 

Step  2 Generate certificate signing request (CSR) request from the Stealthwatch Management Center 

openssl req -new -key smc69.key -out smc69.csr 
Enter pass phrase for smc69.key: cisco123 
You are about to be asked to enter information that will be incorporated 
into your certificate request. 
What you are about to enter is what is called a Distinguished Name or a DN. 
There are quite a few fields but you can leave some blank 
For some fields there will be a default value, 
If you enter '.', the field will be left blank. 
----- 
Country Name (2 letter code) [AU]:US 
State or Province Name (full name) [Some-State]:Maryland 
Locality Name (eg, city) []:Germantown 
Organization Name (eg, company) [Internet Widgits Pty Ltd]:Cisco 
Organizational Unit Name (eg, section) []:Engineering 
Common Name (e.g. server FQDN or YOUR name) []:smc69.lab10.com 
Email Address []:j@lab10.com 
 
Please enter the following 'extra' attributes 
to be sent with your certificate request 
A challenge password []: 
An optional company name []: 

Step  3 Generate self-signed certificate from the Stealthwatch Management Console 

openssl x509 -req -days 365 -in smc69.csr -signkey smc69.key -out smc69.crt 
Signature ok 
subject=/C=US/ST=Maryland/L=Germantown/O=Cisco/OU=Engineering/CN=smc69.lab10.com/emailAddress=j@lab10.com 
Getting Private key 
Enter pass phrase for smc69.key: cisco123 

Step  4 Decrypt passphrase 

cp smc69.key smc69.key.org  
openssl rsa -in smc69.key.org -out smc69.key 
Enter pass phrase for smc69.key.org: cisco123 
writing RSA key 
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Step  5 Copy the smc public and smc private key from the Stealthwatch Management Console locally 

scp smc69.crt jeppich@192.168.1.8:/Applications/smc69/ 
RSA key fingerprint is 10:ce:54:b6:20:8b:3f:86:b1:5f:29:bb:d0:6a:a8:ab. 
Are you sure you want to continue connecting (yes/no)? yes 
Warning: Permanently added '192.168.1.8' (RSA) to the list of known hosts. 
Password: cisco123 
smc69.crt                                     100% 1318     1.3KB/s   00:00     
 
scp smc69.key jeppich@192.168.1.8:/Applications/smc69/ 
Password: cisco123 
smc69.key                                     100% 1675     1.6KB/s   00:00   

Importing Stealthwatch Certificates into SSL Client Store 
 
Step  1 Select Configuration->SSL Certificates->SSL Certificates->SSL Client Identities->Enter Friendly 

Name->Upload a Certificate, Optional Certificate Chain and Decrypted Private Key 
 

                     
 
Step  2 Select Upload Certificate 
Step  3 You should see that the client certificate was successfully uploaded 
 

                    
 



   

 

 

 

 

Cisco Systems © 2017 Page 30  

SECURE ACCESS HOW-TO GUIDES 

Exporting Stealthwatch Certificates into ISE Trusted Certificate Store 
Step  1 Import SMC certificate into ISE trusted system certificate store 

Select Administration->System->Certificates->Certificate Management->Trusted Certificates-
>Import the smc public certificate 
 

 
 

Step  2 Enable Trust for Authentication within ISE 
Step  3 Select Submit 
 

Configuring Stealthwatch pxGrid operation 
 
Step  1 On SMC, select Deploy->Cisco ISE Configuration-> 
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Step  2 Select Save 
Step  3 You should see a Success message select OK 
Step  4 If you see the following message, this means that perhaps the certificate chain was not imported. 
 

 
 
Step  5 If using ISE 2.2, export the pxGrid certificate as well. 
 

 
 
Step  6 Select Certificate Authority Certificate page and import the ISE pxGrid certificate add a friendly name 
 

                    
 
Step  7 Select Add Certificate and confirm 
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Step  8 You should see the updated certificates 
 

                    
 
Step  9 Go back and refresh 
 

               
 
Step  10 You should see this now green 
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Step  11 On ISE, select Administration->pxGrid Services, you should see Stealthwatch Management Center has 
successfully registered and subscribed to the session topics. 

 

 
 
 

Generating Single Certificate (without CSR) in PEM format 

Create and Generate Stealthwatch certificate 
Step  1 Select Administration->pxGrid Services->Certificates, and enter the information below: 

Note:  You can only generate a key size of 2096 due to a bug in the pxGrid certificate template 
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Step  2 Select Create 
Step  3 Download the zipped file locally, select OK 
 

                  
 
 
Step  4 You should see the following files 

 

 
 

Exporting ISE CertificateServicesRootCA into SMC Certificate Authority (CA) Store 
Step  1 On the SMC, upload the CertificateServcicesRootCA-ise470.cer to the SMC CA Authority 

Step  2 Select Gear    ->Administer Appliance->Configuration->Certificate Authority Certificates-
>Browse and upload the ISE certificate and provide a friendly name 
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Step  3 Select Add Certificate and confirm 
Step  4 You should see that the ISE CA root certificate was successfully uploaded. 
 

                   
 

Adding Stealthwatch certificate to SSL Client Identities Store 
Step  1 Decrypt passphrase 

cp smc69.lab10.com_192.168.1.244.key smc69.lab10.com_192.168.1.244.key.org 
openssl rsa -in smc69.lab10.com_192.168.1.244.key.org -out smc69.lab10.com_192.168.1.244.key 
Enter pass phrase for smc69.lab10.com_192.168.1.244.key.org: Cisco123 
writing RSA key 
 

Step  2 Under Configuration->SSL Certificate->SSL Client Identities, Upload a certificate, Optional 
certificate chain, and decrypted private key 

 
 

                   
 
Step  3 Select Upload Certificate and confirm 

Note:  You may get an error message after you confirm, re-enter the values.  This was tested on RC2 and may not be there in the productional 
release. 
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Step  4 You should see the following under SSL Client Identities 
 

                 
 

Configuring Stealthwatch for pxGrid operation 
Step  1 On the SMC Dashboard, select Deploy->Cisco ISE Configuration, and enter the following: 
 

                   
 
Step  2 Select Save 
Step  3 You should see the configuration saved successfully and the status updated successfully by the green dot 
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Step  4 In ISE, select Administration->pxGrid Services 
 

 

Generating Certificate Signing Request CSR (with certificate signing request) using 
ISE 2.2 Internal CA 

Creating Stealthwatch Certificate 
Step  1 Generate the private key from the Stealthwatch Management Console 

Note: The –des3 argument provides the pass phrase password.  Here Cisco123 is entered as the passphrase. 

openssl genrsa -des3 -out smc69.key 2048 
Generating RSA private key, 2048 bit long modulus 
.....................................................+++ 
.............................................................................................................
......................+++ 
e is 65537 (0x10001) 
Enter pass phrase for smc69.key: Cisco123 
Verifying - Enter pass phrase for smc69.key: 

Step  2 Generate the Certificate Signing Request (CSR) from the Stealthwatch Management Console 

openssl req -new -key smc69.key -out smc69.csr 
Enter pass phrase for smc69.key: Cisco123 
You are about to be asked to enter information that will be incorporated 
into your certificate request. 
What you are about to enter is what is called a Distinguished Name or a DN. 
There are quite a few fields but you can leave some blank 
For some fields there will be a default value, 
If you enter '.', the field will be left blank. 
----- 
Country Name (2 letter code) [AU]:US 
State or Province Name (full name) [Some-State]:Maryland 
Locality Name (eg, city) []:Germantown 
Organization Name (eg, company) [Internet Widgits Pty Ltd]:Cisco 
Organizational Unit Name (eg, section) []:Engineering 
Common Name (e.g. server FQDN or YOUR name) []:smc.lab10.com 
Email Address []:j@cisco.com 
 
Please enter the following 'extra' attributes 
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to be sent with your certificate request 
A challenge password []: 
An optional company name []: 

Step  3 Copy files locally 

scp smc69.key jeppich@192.168.1.13:/Applications/smc69/smc1 
RSA key fingerprint is 10:ce:54:b6:20:8b:3f:86:b1:5f:29:bb:d0:6a:a8:ab. 
Are you sure you want to continue connecting (yes/no)? yes 
Warning: Permanently added '192.168.1.13' (RSA) to the list of known hosts. 
Password: 
smc69.key                                     100% 1751     1.7KB/s   00:00     
scp smc69.csr jeppich@192.168.1.13:/Applications/smc69/smc1 
Password:yes 
smc69.csr                                     100% 1058     1.0KB/s   00:00 

ISE Generating Certificate based on CSR request in PEM format 
Step  1 On ISE, select Administration->pxGrid services, and enter the following: 

Note: You can only generate a key size of 2096; there is a bug in the pxGrid template.  Enter the same pass phrase as you entered using the –des3 
argument.  In this example, Cisco123 was used. 

 

                   
 
 
Step  2 Select Create 
Step  3 Download the zipped file locally, you should see the following files 
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Import ISE CAServicesRoot certificate into Stealthwatch CA store 
Step  1 On SMC, add root to CA authority 
 

               
 
Step  2 Select Add Certificate and confirm 
Step  3 You should see the following: 
 

                 
 

Import Stealthwatch certificates into SSL Client Store 
Step  1 Decrypt password 

cp smc69.key smc69.key.org  
openssl rsa -in smc69.key.org -out smc69.key 
Enter pass phrase for smc69.key.org: Cisco123 
writing RSA key 
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Step  2 Select Configuration->SSL Certificate->SSL Client Identities->Upload the Stealthwatch public 
private-key pair 

 

                  
 
 
Step  3 Select Upload Certificate and confirm 
Step  4 You should see the following under SSL Client Identities 

 

                
 

Configuring Stealthwatch for pxGrid Operation 
 
Step  1 On the SMC Dashboard, select Deploy->Cisco ISE Configuration and configure pxGrid 
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Step  2 Select Save and OK, you should see a successful connection 
 

                 
 
 
Step  3 In ISE, select Administration->pxGrid services, you should see the SMC successfully registered and 

subscribed to the ISE pxGrid node 
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Configuring ISE Authorization Policy 
In this section, we configure ISE authorization policies to quarantine endpoints once the Stealthwatch Management 
Console, issues an ANC request to quarantine/unquarantine endpoints and also to assign an Employee Security Group 
Tag (SGT) to end-users who successfully authenticate and belong to the Microsoft /users/domain group. 

Stealthwatch subscribes to the ISE pxGrid node EndpointProtection Service to perform these mitigation actions and 
thus uses legacy EPS functionality, where the Sessison:EPSTATUS:quarantine policy is used instead of the newer 
Adaptive Network Control (ANC) Policies which were introduced in ISE 2.0. 

Configuring ISE Quarantine Rule 
Step  1 Select Policy->Authorization->Exceptions->Create New->for the rule name, type: EPS 
Step  2 Select “+” next to Conditions, and Create New Condition->Session:EPSTATUS:Quarantine 
Step  3 Select “+” next to Authz Policy, select Security Group->Quarantined Systems->Done 
Step  4 You should see the following: 
 

 
 
Step  5 Select Save 
 

Configuring Employee Access Rule 
Step  1 Select Insert New Rule Above->for the Rule Name type Employee 
Step  2 Select “+” next to Conditions, and Create New Condition->pxGrid_Users:External 

Groups:lab10.com/domain users 

Note: Please note that you have your own External identity source configured in ISE, and pxGrid_Users, will reflect the Joint Point Name 

 
Step  3 Select “+” next to Authz Policy, select Security Group->Employees->Done 
Step  4 You should see the following: 

 
Step  5 Select Save 
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Step  6 You should see: 
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Testing 
In this section, we authenticate an end-user via 802.1X.  Using the Stealthwatch Management Console, the endpoint is 
quarantined and unquarantined.  The results are seen in ISE under the RADIUS Live logs.  In addition, the endpoint 
can also be unquarantined via the ISE GUI. 

Step  1       User successfully authenticates via 802.1X 

       

Step  2        On ISE, select Operations->RADIUS->Live Logs 
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Step  3            On the Stealthwatch Management Console, select Monitor->Users 

 

 

Step  4         Select user1@lab10.com , you should see: 
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Step  5       Select IP Address, you should see host information 

 

 

Step  6 Select Quarantine 

 

 

Step  7 You should see that the endpoint has been successful quarantined. 
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Step  8 On ISE, select Operations->RADIUS->Live Logs 

 

 

Step  9        To unquarantine the endpoint, select Unquarantine 

        

Step  10 You should see that the endpoint has been successfully unquarantined 
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Step  11 On ISE, select Operations->RADIUS->Live Logs 

 

Unquarantine using ISE GUI 
Step  1 Select Operations->RADIUS->Live Logs, you see the endpoint as quarantined 
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Step  2         Select Operations->Adaptive Network Control->Endpoint Assignment->EPS Unquarantine and  
         enter the MAC address of the endpoint to unquarantine 

 

 

Step  3     Select Unquarantine, the endpoint should be unquarantined 
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Troubleshooting 

Stealthwatch pxGrid configuration errors 
Ensure that you have the ISE internal 2.2 certificate root services in the Stealthwatch Certificate Authority (CA) store, 
the external CA root certificate and intermediate certificates (if applicable),  or ISE self-signed identity certificate + 
pxGrid certificate, pending your ISE configuration. 

 

 

 

 

 

 


