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About this Document 
This document is for Cisco System Engineers, partners and customers deploying Cisco Platform Exchange Grid 
(pxGrid) across all versions of Cisco Identity Service Engine (ISE) in productional environments.  An external 
Certificate Authority) Server is used for all ISE deployments.  Starting with ISE 2.1 and above, there is an internal ISE 
CA server that can be used for pxGrid operation and pxGrid client certificate generation. In ISE 2.1 this optional, for 
ISE 2.2 releases and above the ISE internal CA is enabled for pxGrid operation and pxGrid client certificate generation 
by default.  All ISE nodes are dedicated nodes, including the pxGrid primary and pxGrid secondary nodes.  pxGrid 
failover is also covered in some of the examples,  however all configurations encompass pxGrid failover. 

This guide also addresses early ISE 1.3 and ISE 1.4 deployments. 

The pxGrid client examples are covered mainly Cisco Stealthwatch 6.9+, Cisco Firepower 6.2, Cisco Web Security 
(WSA) Appliance (IOS 9.0+) and pxGrid clients using java keystores, which is mainly used by pxGrid ecosystem 
partners. 

This document does not cover self-signed certificates, it also does not cover configurations using the ISE internal and 
ISE identity certificate only.  If providing proof of concept for these configurations, please consult the appropriate 
How-to guides in the References section. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



   

 

 

 

 

Cisco Systems © 2017 Page 5  

SECURE ACCESS HOW-TO GUIDES 

Deploy pxGrid using ISE 2.2+ 
This section describes the details for deploying pxGrid using the ISE Internal Certificate Authority (CA) and using an 
external CA server for ISE node deployments. This covers ISE versions 2.2 and above. 

The pxGrid certificate is signed by the ISE internal CA by default.  

In the following example, dedicates nodes were used for the primary and secondary pxGrid nodes.  In addition, 
dedicated nodes were used for the primary admin node, secondary admin node, primary MNT, secondary MNT and 
PSN node. 

Note:  If you upgraded from an earlier of ISE 1.3 or later to ISE 2.2. The ISE 2.2 Internal CA will not sign the pxGrid certificates; the pxGrid certificate 
will be signed by the external CA. 

Generating CSR requests for ISE nodes 
The desired ISE nodes: Primary Admin, Secondary Admin, Primary MNT, Secondary MNT, Policy Services Node(s) 
and the primary pxGrid and secondary pxGrid nodes will be signed by the External CA server using the Web Server 
template if using Microsoft 2008 Enterprise CA server. The Certificate Signing Request (CSR) request will use the 
“admin” usage for creating the certificate request. 

Note: A customized pxGrid template is no longer required for the pxGrid nodes if the ISE internal CA is used in ISE 2.2+.  

 

Step  1 Generate the Certificate Signing Request (CSR) for the desired ISE nodes.  Below is an example for 
generating the CSR request for the desired ISE admin node. 
Select Administration->System->Certificate->Generate Certificate Signing Requests (CSR)->admin 
for usage 
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Step  2 Enter the Fully Qualified Domain Name (FQDN) for DNS or enter the IP address 
 

             
 
 
Step  3 Select Generate 
Step  4 Save the file locally, export and open the PEM file using text editor copy the text from the “-----BEGIN” to 

the end of “REQUEST-----“ 
 

                  
 
Step  5 Paste into Advanced Request 

Select Request a Certificate->Advanced Certificate Request 
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Step  6 Select Submit and download in 64-base encoded format 
Step  7 Select Download CA root certificate in 64-base encoded format 
 

                   
 
Step  8 Upload the CA root certificate into the ISE trusted certificate store 

Select Administration->System->Certificates->Certificate Management->Trusted Certificates and 
import the trusted CA root certificate 

Note: Ensure trust for authentication within ISE is selected 

 

                        
 



   

 

 

 

 

Cisco Systems © 2017 Page 8  

SECURE ACCESS HOW-TO GUIDES 

Step  9 Select Submit 
Step  10 Select Yes 
 

                   
 
Step  11 Select Yes 
 

                    
 

 
Step  12 The system will restart 
Step  13 You should see the uploaded root certificate 

Select Administration->System->Certificates->Certificate Management->Trusted Certificates 
 

 
 
Step  14 Repeat steps 1-14 for all the ISE nodes including the pxGrid primary and pxGrid secondary nodes. 
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Registering ISE nodes 
Step  1 Select the desired node designated for the primary admin node and promote to primary 

Select Administration->System->Deployment->select the node->Make primary 

 
 

 
 

Step  2 Uncheck all the nodes, except for Administration and Monitoring (primary Role).  This will become the 
primary admin node 

 
Step  3 Select Save.   

The node will be updated.  

Note: Use “application status ise” from the ISE VM CLI to see the status of Application Server. 

 
Step  4 Register the rest of the ISE nodes, and enable the appropriate personas.   
Step  5 Below is an example of registering the primary MNT node. 

Select Administration->System->Deployment->Register->Register an ISE node, select Next 
 

                    
 
Step  6 Enable the Monitoring Persona and select the Primary Role 

Note: When the Primary role is selected, the monitoring persona on the primary admin role will automatically change to the Secondary role. 
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Step  7 Select Save 
Step  8 Below is an example of registering the primary pxGrid node. 

Select Administration->System->Deployment->Register->Register an ISE node, select Next 
 

 
 

Step  9 Enable the pxGrid Persona  
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Step  10 Select Save 

Note: Verify that the published pxGrid nodes appear and there is pxGrid node connectivity. Select Administration->pxGrid Services 

 
Step  11 Below is an example of registering the Policy Service Node (PSN) node. 

Select Administration->System->Deployment->Register->Register an ISE node, select Next 
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Step  12 Select Police Service persona 
 

                   
 
Step  13 Select Save 
Step  14 Below is an example of registering the secondary admin node. 

Select Administration->System->Deployment->Register->Register an ISE node, select Next 
 

 
 

Step  15 Select Administration persona and the Secondary Role 
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Step  16 Select Save 
Step  17 Disable the Secondary Monitoring role on the primary admin role 

Select Administration->System->Deployment->edit the primary admin role->uncheck Monitoring 
 

 
 

 
Step  18 Select Save.   

The primary admin role will restart. 
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Step  19 Below is an example of registering the secondary MNT node. 
Select Administration->System->Deployment->Register->Register an ISE node, select Next 
 

 
 
 

Step  20 Select Monitoring Persona and Secondary role 
 

                 
 
Step  21 Select Save 
Step  22 Below is an example of registering the secondary admin node. 

Select Administration->System->Deployment->Register->Register an ISE node, select Next 
 

 
 

 



   

 

 

 

 

Cisco Systems © 2017 Page 15  

SECURE ACCESS HOW-TO GUIDES 

Step  23 Enable the Administration Persona and ensure that the role is secondary. 
 

                  
 
Step  24 Select Save 
 
Step  25 Below is an example of registering the secondary pxGrid node. 

Select Administration->System->Deployment->Register->Register an ISE node, select Next 
 

 
 
Step  26 Enable pxGrid persona 
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Step  27 Select Save 
Step  28 Select Administration->System->Deployment, you should the following: 
 

 
 
 
Step  29 Select Administration->pxGrid services 
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Step  30 To view the certificates 
Select Administration->System->Certificates->Certificate Management->System Certificates 
 
The below screenshot represents the primary admin node (ise22lab4) and the secondary admin node 
(ise22a). Note the admin certificates (ise22lab4..) and (ise22a..) have been signed by the external CA 
server.  The pxGrid certificates have been signed by the ISE internal CA server. 
 
You will also see this on the Primary and Secondary nodes, the dedicated primary pxGrid and secondary 
pxGrid nodes, and the PSN node. 

 

                    
 

Testing pxGrid Integration with Firepower Management Center 6.2+ 
This section details the procedure for configuring the Cisco Firepower Management Center (FMC) 6.2 with ISE 2.2 
with pxGrid using the Internal CA for pxGrid operation.  The Firepower certificates will be generated by the ISE 
internal CA. 

Step  1 Select Administration->pxGrid Services->Certificates 
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Step  2 Select Generate and save the file locally. You should see the following: 
 

                  
 
Step  3 Select System->Integration->Identity Sources->Identity Services Engine-> 
 

Enter the primary pxGrid host name or IP address for the Primary Host Name/IP Address field 
Enter the secondary pxGrid host name or IP address for the Secondary Host Name/IP Address field 

     Upload the CertificateServicesRootCA certificate for the pxGrid Server CA 
 Upload the CA root certificate, in this case, lab10-WIN-N3OR1A7H9KL, for the MNT Server CA  
 Upload the FMC Server Certificate (public private key-pair) for FMC Server Certificate 
 

                 
 
Step  4 Select Test, you should see a Primary host: Success message 
Step  5 Select Administration->pxGrid service to verify Firepower has successfully registered as the pxGrid 

client. 
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Testing pxGrid Integration with Java-based pxGrid Client 
This section details the procedure for configuring java-based pxGrid solution vendors with ISE 2.2+ with pxGrid using 
the Internal CA for pxGrid operation.  The solution vendor certificates will be generated by the ISE internal CA. In this 
example, a MAC Pro Laptop was used as the pxGrid client. 

We will create the trust file keystore filename macpro1.jks and trust root store filename macpro1_root.jks, password 
for both Cisco123. 

If the ecosystem security solution does not support certificate encryption, the private key must be decrypted, below is 
the procedure: 

cp Johns-Macbook-Pro.lab10.com_192.168.1.136.key Johns-Macbook-Pro.lab10.com_192.168.1.136.key.org   
openssl rsa -in Johns-Macbook-Pro.lab10.com_192.168.1.136.key.org -out Johns-Macbook-
Pro.lab10.com_192.168.1.136.key  

Step  1 Select Administration->pxGrid Services->Certificates 

                   

Step  2 Select Create 
Step  3 Download the file locally, and unzip the files, you should see: 

 

Step  4 Concatenate files into one certificate 

cat CertificateServicesEndpointSubCA-ise22lab4_.cer CertificateServicesRootCA-ise22lab4_.cer 
CertificateServicesNodeCA-ise22lab4_.cer lab10-WIN-N3OR1A7H9KL-CA_.cer > CA1.cer 
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Step  5 Create PKCS12 file 

Note: The passphrase is the password that was typed when generating the certificates from the ISE internal CA 

openssl pkcs12 -export -out macpro1.p12 -inkey Johns-Macbook-Pro.lab10.com_192.168.1.136.key -in Johns-
Macbook-Pro.lab10.com_192.168.1.136.cer -chain -CAfile CA1.cer 
 
Enter pass phrase for Johns-Macbook-Pro.lab10.com_192.168.1.136.key: Cisco123 
Enter Export Password: Cisco123 
Verifying - Enter Export Password: Cisco123 

Step  6 Import PKCS file into keystore 

keytool -importkeystore -srckeystore macpro1.p12 -destkeystore macpro1.jks -srcstoretype PKCS12 
 
Enter destination keystore password:  Cisco123 
Re-enter new password: Cisco123 
Enter source keystore password:  Cisco123 
Entry for alias 1 successfully imported. 
Import command completed:  1 entries successfully imported, 0 entries failed or cancelled 

Step  7 Export CA root certificate from the ISE trusted certificate store PEM file converted to DER format 

openssl x509 -outform der -in CA1.cer -out CA1.der 

Step  8 Import the converted CA root certificate in DER format to trusted keystore 

keytool -import -alias macpro1 -keystore macpro1_root.jks -file CA1.der 
Enter keystore password:  Cisco123 
Re-enter new password: Cisco123 
Owner: CN=Certificate Services Endpoint Sub CA - ise22lab4 
Issuer: CN=Certificate Services Node CA - ise22lab4 
Serial number: 109b2c4872244d9694707f48079b1446 
Valid from: Sun Jul 30 20:10:30 EDT 2017 until: Sun Jul 31 20:10:26 EDT 2022 
Certificate fingerprints: 
  MD5:  3E:76:5C:6D:8C:26:3B:8F:5B:C4:C0:40:A4:3F:D4:B6 
  SHA1: 1B:BC:2A:65:44:1D:D3:D8:97:97:90:9B:25:27:23:16:C2:8D:62:5D 
  SHA256: 
45:3C:E9:F7:83:25:A9:11:B9:AB:00:A8:BA:0E:B3:DC:0E:3E:40:28:C2:7C:8D:C8:78:54:8A:03:97:B9:01:74 
  Signature algorithm name: SHA256withRSA 
  Version: 3 
 
Extensions:  
 
#1: ObjectId: 2.5.29.35 Criticality=false 
AuthorityKeyIdentifier [ 
KeyIdentifier [ 
0000: F4 7F 2E 7B D4 DB 5C 1A   74 09 51 EB 25 24 4E 0F  ......\.t.Q.%$N. 
0010: 74 7E 50 54                                        t.PT 
] 
[CN=Certificate Services Root CA - ise22lab4] 
SerialNumber: [    46c64293 c0d94c8c ba9d37f3 6830037d] 
] 
 
#2: ObjectId: 2.5.29.19 Criticality=true 
BasicConstraints:[ 
  CA:true 
  PathLen:2147483647 
] 
 
#3: ObjectId: 2.5.29.15 Criticality=true 



   

 

 

 

 

Cisco Systems © 2017 Page 21  

SECURE ACCESS HOW-TO GUIDES 

KeyUsage [ 
  Key_CertSign 
] 
 
#4: ObjectId: 2.5.29.14 Criticality=false 
SubjectKeyIdentifier [ 
KeyIdentifier [ 
0000: 0C 67 46 A2 FA A1 90 35   0E 51 02 A5 9F 46 13 36  .gF....5.Q...F.6 
0010: 1E D0 26 7F                                        ..&. 
] 
] 
 
Trust this certificate? [no]:  yes 
Certificate was added to keystore 

 
Step  9 Import the pxGrid client certificate into the trusted file keystore 

keytool -import -alias macpro2 -keystore macpro1.jks -file Johns-Macbook-Pro.lab10.com_192.168.1.136.cer 
Enter keystore password:  Cisco123 
Certificate already exists in keystore under alias <1> 
Do you still want to add it? [no]:  yes 
Certificate was added to keystore 

Step  10 Import the CA root certificate to trusted root keystore 

keytool -import -alias macpro3 -keystore macpro1_root.jks -file CA1.cer 
Enter keystore password:  Cisco123 
Certificate already exists in keystore under alias <macpro1> 
Do you still want to add it? [no]:  yes 
Certificate was added to keystore 

Step  11 Import the ISE CertificateServicesRoot certificate into trusted root keystore 

keytool -import -alias macpro5 -keystore macpro1_root.jks -file CertificateServicesRootCA-ise22lab4_.cer 
Enter keystore password: Cisco123  
Owner: CN=Certificate Services Root CA - ise22lab4 
Issuer: CN=Certificate Services Root CA - ise22lab4 
Serial number: 655ffcd9c3cd4fce8462fdc6062c0ea9 
Valid from: Sun Jul 30 20:10:13 EDT 2017 until: Sat Jul 31 20:10:13 EDT 2027 
Certificate fingerprints: 
  MD5:  E6:78:C1:87:BA:47:FE:FB:81:00:A6:40:81:28:57:1F 
  SHA1: 07:6B:0D:C7:C3:4F:39:9F:42:E7:2B:9F:33:0A:0D:55:3B:2E:D5:50 
  SHA256: 
6F:1D:F6:81:D5:AB:CE:EB:72:A4:89:AD:70:BA:11:BD:49:48:57:16:F1:53:A5:1E:E2:34:2E:8D:FD:A5:2D:5B 
  Signature algorithm name: SHA256withRSA 
  Version: 3 
 
Extensions:  
 
#1: ObjectId: 2.5.29.19 Criticality=true 
BasicConstraints:[ 
  CA:true 
  PathLen:2147483647 
] 
 
#2: ObjectId: 2.5.29.15 Criticality=true 
KeyUsage [ 
  Key_CertSign 
] 
 
#3: ObjectId: 2.5.29.14 Criticality=false 
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SubjectKeyIdentifier [ 
KeyIdentifier [ 
0000: 33 9E 4A 44 BB 04 1B B9   13 C8 F4 00 F8 DC F9 78  3.JD...........x 
0010: 6C 17 6F 00                                        l.o. 
] 
] 
 
Trust this certificate? [no]:  yes 
Certificate was added to keystore 

 
Step  12 Run Session_download script. 
 

Note:  The session_download sample script is not required for testing.  The security vendor should be able to download active session information if 
supported in their configuration. 

         The session_download sample script is part of the pxGrid SDK(pxGrid 1.0) which can be downloaded from 
https://developer.cisco.com/site/pxgrid/. You will need to register which is no cost.  For script reference, please see: 
https://communities.cisco.com/docs/DOC-68291  

./session_download.sh -a 192.168.1.187,192.168.1.65 -u macpro1 -k macpro1.jks -p Cisco123 -t macpro1_root.jks 
-q Cisco123 
------- properties ------- 
  version=1.0.4.19 
  hostnames=192.168.1.187,192.168.1.65 
  username=macpro1 
  password= 
  group=Session 
  description=null 
  keystoreFilename=macpro1.jks 
  keystorePassword=Cisco123 
  truststoreFilename=macpro1_root.jks 
  truststorePassword=Cisco123 
-------------------------- 
Connecting... 
15:51:30.419 [main] INFO  com.cisco.pxgrid.Configuration - Connecting to host 192.168.1.187 
15:51:30.722 [main] INFO  com.cisco.pxgrid.Configuration - Connected OK to host 192.168.1.187 
15:51:30.722 [main] INFO  com.cisco.pxgrid.Configuration - Client Login to host 192.168.1.187 
15:51:30.754 [main] INFO  com.cisco.pxgrid.Configuration - Client Login OK to host 192.168.1.187 
Connected 
Filters (ex. '1.0.0.0/255.0.0.0,1234::/16...' or <enter> for no filter):  
Start time (ex. '2015-01-31 13:00:00' or <enter> for no start time):  
End time (ex. '2015-01-31 13:00:00' or <enter> for no end time):  
pxGrid controller version=1.0.4.18 
Going to url:https://ise22f.lab10.com:8910/pxgrid/mnt/sd/getSessionListByTime 
Session={ip=[192.168.1.187], Audit Session Id=0A000001000000280077C9BC, UserName=00:0C:29:1D:1A:5A, 
MacAddresses=[00:0C:29:1D:1A:5A], State=STARTED, EndpointProfile=ISE-Appliance, NAS IP=192.168.1.3, NAS 
Port=GigabitEthernet1/0/15, RADIUSAVPairs=[ Acct-Session-Id=00000029], Posture Status=null, Posture 
Timestamp=, LastUpdateTime=Mon Aug 07 15:45:12 EDT 2017, Session attributeName=Authorization_Profiles, 
Session attributeValue=PermitAccess, Providers=[None], EndpointCheckResult=none, IdentitySourceFirstPort=0, 
IdentitySourcePortStart=0, IdentitySourcePortEnd=0} 
Session={ip=[192.168.1.186], Audit Session Id=0A000001000000270077B549, UserName=00:0C:29:21:DF:BF, 
MacAddresses=[00:0C:29:21:DF:BF], State=STARTED, EndpointProfile=ISE-Appliance, NAS IP=192.168.1.3, NAS 
Port=GigabitEthernet1/0/15, RADIUSAVPairs=[ Acct-Session-Id=00000028], Posture Status=null, Posture 
Timestamp=, LastUpdateTime=Mon Aug 07 15:45:30 EDT 2017, Session attributeName=Authorization_Profiles, 
Session attributeValue=PermitAccess, Providers=[None], EndpointCheckResult=none, IdentitySourceFirstPort=0, 
IdentitySourcePortStart=0, IdentitySourcePortEnd=0} 
Session={ip=[192.168.1.30], Audit Session Id=0A0000010000003700ABD28D, UserName=00:0C:29:7C:79:39, 
MacAddresses=[00:0C:29:7C:79:39], State=STARTED, EndpointProfile=VMWare-Device, NAS IP=192.168.1.3, NAS 
Port=GigabitEthernet1/0/15, RADIUSAVPairs=[ Acct-Session-Id=00000038], Posture Status=null, Posture 
Timestamp=, LastUpdateTime=Mon Aug 07 15:45:21 EDT 2017, Session attributeName=Authorization_Profiles, 
Session attributeValue=PermitAccess, Providers=[None], EndpointCheckResult=none, IdentitySourceFirstPort=0, 
IdentitySourcePortStart=0, IdentitySourcePortEnd=0} 
Session={ip=[192.168.1.183], Audit Session Id=0A000001000000160002C975, UserName=00:0C:29:AB:23:FF, 
MacAddresses=[00:0C:29:AB:23:FF], State=STARTED, EndpointProfile=ISE-Appliance, NAS IP=192.168.1.3, NAS 
Port=GigabitEthernet1/0/10, RADIUSAVPairs=[ Acct-Session-Id=00000017], Posture Status=null, Posture 
Timestamp=, LastUpdateTime=Mon Aug 07 15:45:30 EDT 2017, Session attributeName=Authorization_Profiles, 
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Session attributeValue=PermitAccess, Providers=[None], EndpointCheckResult=none, IdentitySourceFirstPort=0, 
IdentitySourcePortStart=0, IdentitySourcePortEnd=0} 
Session={ip=[192.168.1.10], Audit Session Id=0A0000010000003E016FBD40, UserName=00:0C:29:C1:7B:2C, 
MacAddresses=[00:0C:29:C1:7B:2C], State=STARTED, EndpointProfile=VMWare-Device, NAS IP=192.168.1.3, NAS 
Port=GigabitEthernet1/0/11, RADIUSAVPairs=[ Acct-Session-Id=00000040], Posture Status=null, Posture 
Timestamp=, LastUpdateTime=Mon Aug 07 15:49:02 EDT 2017, Session attributeName=Authorization_Profiles, 
Session attributeValue=PermitAccess, Providers=[None], EndpointCheckResult=none, IdentitySourceFirstPort=0, 
IdentitySourcePortStart=0, IdentitySourcePortEnd=0} 
Session={ip=[192.168.1.185], Audit Session Id=0A000001000000260077A376, UserName=00:0C:29:E1:AD:B7, 
MacAddresses=[00:0C:29:E1:AD:B7], State=STARTED, EndpointProfile=ISE-Appliance, NAS IP=192.168.1.3, NAS 
Port=GigabitEthernet1/0/15, RADIUSAVPairs=[ Acct-Session-Id=00000027], Posture Status=null, Posture 
Timestamp=, LastUpdateTime=Mon Aug 07 15:48:43 EDT 2017, Session attributeName=Authorization_Profiles, 
Session attributeValue=PermitAccess, Providers=[None], EndpointCheckResult=none, IdentitySourceFirstPort=0, 
IdentitySourcePortStart=0, IdentitySourcePortEnd=0} 
Session={ip=[192.168.1.159], Audit Session Id=0A000001000000290077E32A, UserName=00:50:56:86:08:19, 
MacAddresses=[00:50:56:86:08:19], State=STARTED, EndpointProfile=ISE-Appliance, NAS IP=192.168.1.3, NAS 
Port=GigabitEthernet1/0/10, RADIUSAVPairs=[ Acct-Session-Id=0000002A], Posture Status=null, Posture 
Timestamp=, LastUpdateTime=Mon Aug 07 15:48:33 EDT 2017, Session attributeName=Authorization_Profiles, 
Session attributeValue=PermitAccess, Providers=[None], EndpointCheckResult=none, IdentitySourceFirstPort=0, 
IdentitySourcePortStart=0, IdentitySourcePortEnd=0} 
Session={ip=[192.168.1.9], Audit Session Id=0A0000010000003800ACA782, UserName=10:DD:B1:C9:3C:39, 
MacAddresses=[10:DD:B1:C9:3C:39], State=STARTED, EndpointProfile=Workstation, NAS IP=192.168.1.3, NAS 
Port=GigabitEthernet1/0/12, RADIUSAVPairs=[ Acct-Session-Id=00000039], Posture Status=null, Posture 
Timestamp=, LastUpdateTime=Mon Aug 07 15:44:54 EDT 2017, Session attributeName=Authorization_Profiles, 
Session attributeValue=PermitAccess, Providers=[None], EndpointCheckResult=none, IdentitySourceFirstPort=0, 
IdentitySourcePortStart=0, IdentitySourcePortEnd=0} 
Session={ip=[192.168.1.7], Audit Session Id=0A000001000000170002C9C0, UserName=18:E7:28:2E:29:CC, 
MacAddresses=[18:E7:28:2E:29:CC], State=STARTED, EndpointProfile=Cisco-Device, NAS IP=192.168.1.3, NAS 
Port=GigabitEthernet1/0/15, RADIUSAVPairs=[ Acct-Session-Id=00000018], Posture Status=null, Posture 
Timestamp=, LastUpdateTime=Mon Aug 07 15:48:33 EDT 2017, Session attributeName=Authorization_Profiles, 
Session attributeValue=PermitAccess, Providers=[None], EndpointCheckResult=none, IdentitySourceFirstPort=0, 
IdentitySourcePortStart=0, IdentitySourcePortEnd=0} 
Session={ip=[192.168.1.6], Audit Session Id=0A000001000000310094786C, UserName=74:26:AC:5A:82:24, 
MacAddresses=[74:26:AC:5A:82:24], State=STARTED, EndpointProfile=Cisco-Device, NAS IP=192.168.1.3, NAS 
Port=GigabitEthernet1/0/17, RADIUSAVPairs=[ Acct-Session-Id=00000032], Posture Status=null, Posture 
Timestamp=, LastUpdateTime=Mon Aug 07 15:45:30 EDT 2017, Session attributeName=Authorization_Profiles, 
Session attributeValue=PermitAccess, Providers=[None], EndpointCheckResult=none, IdentitySourceFirstPort=0, 
IdentitySourcePortStart=0, IdentitySourcePortEnd=0} 
Session={ip=[192.168.1.43], Audit Session Id=0A0000010000003000946FC5, UserName=74:26:AC:5A:82:26, 
MacAddresses=[74:26:AC:5A:82:26], State=STARTED, EndpointProfile=Cisco-Device, NAS IP=192.168.1.3, NAS 
Port=GigabitEthernet1/0/17, RADIUSAVPairs=[ Acct-Session-Id=00000031], Posture Status=null, Posture 
Timestamp=, LastUpdateTime=Mon Aug 07 15:45:45 EDT 2017, Session attributeName=Authorization_Profiles, 
Session attributeValue=PermitAccess, Providers=[None], EndpointCheckResult=none, IdentitySourceFirstPort=0, 
IdentitySourcePortStart=0, IdentitySourcePortEnd=0} 
Session count=11 
Connection closed 
Johns-MacBook-Pro: 
 

 
Step  13 Select Administration->pxGrid Services to verify the pxGrid client appears 
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Testing pxGrid Integration with Cisco Stealthwatch 6.9+ 
This section details the procedure for configuring Cisco Stealthwatch 6.9+ with ISE 2.2 with pxGrid using the Internal 
CA for pxGrid operation.  The Stealthwatch pxGrid client certificates will be generated by the ISE internal CA.  

Note:  Please install all the Cisco Stealthwatch patches before configuring for pxGrid and certificate generation. 

Step  1 Select Administration->pxGrid services->Certificates 

                  

Step  2 Select Create, download and unzip the files locally. 
Step  3 Select Administer Appliance->Configuration->Certificate Authority Certificates->Browse and upload 

CA root certificate and ISE CertificateServicesRootCA certificate and provide the Name. 
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Step  4 Also upload the external Root CA, in this case, lab10-WIN-N3OR1A7H9KL-CA 
 

                  
 
Step  5 Select Configuration->SSL Certificates->SSL Client Identities->upload the PKCS12 bundle file 

Provide the password used for the SMC certificate generation in ISE 
Provide a friendly name 

 

                  
 
Step  6 Select Deploy->Cisco ISE Configuration and provide the following information: 
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Step  7 You should see a successful connection indicated by the green circle 
Step  8 Select Administration->pxGrid services 

 

 

Testing pxGrid Integration with Cisco Security Web Security Appliance  (WSA) 
This section details the procedure for configuring the Cisco WSA with ISE 2.2 with pxGrid using the Internal CA for 
pxGrid operation.  The Cisco WSA certificates will be generated by the ISE internal CA.  

Step  1 Select Administration->pxGrid Services->Certificates 
 

           
 
 
 
 
 
 



   

 

 

 

 

Cisco Systems © 2017 Page 27  

SECURE ACCESS HOW-TO GUIDES 

Step  2 Select Create, download and unzip the files locally 
 

                
Step  3 Select Network->Certificate Management->Managed Trusted Root Certificates->Import and upload 

the ISE CertificateServicesRootCA and the external root CA, in this case, lab10-WIN-
N3OR1A7H9KL-CA 
 

                 
 
Step  4 Select Commit Changes twice 
Step  5 Select Network->Identification Services->Identity Services Engine and Enable 
Step  6 For Primary pxGrid node, enter the IP address of the primary pxGrid node and upload the ISE Certificate 

Root Services certificate 
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Step  7 For Secondary pxGrid node, enter the IP address of the secondary pxGrid node and upload the ISE 
Certificate Root Services certificate 

 

                  
 
 
Step  8 For the ISE Monitoring Node Admin Certificate and for the primary and secondary admin node certificates, 

upload the CA root certificate, in this case, lab10-WIN-N3OR1AH9KL-CA 
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Step  9 For the WSA Client Certificate, upload the WSA public private-key pair, and enter the password that 
was entered when generating the WSA certificate from the ISE Internal CA. 

 

 
 
 
Step  10 Select Test 

You should see: 

 
Checking DNS resolution of ISE pxGrid Node hostname(s) ... 
Success: Resolved '192.168.1.187' address: 192.168.1.187 
Success: Resolved '192.168.1.65' address: 192.168.1.65 
 
Validating WSA client certificate ... 
Success: Certificate validation successful 
 
Validating ISE pxGrid Node certificate(s) ... 
Success: Certificate validation successful 
Success: Certificate validation successful 
 
Validating ISE Monitorting Node Admin certificate(s) ... 
Success: Certificate validation successful 
Success: Certificate validation successful 
 
Checking connection to ISE pxGrid Node(s) ... 
Success: Connection to ISE pxGrid Node was successful. 
Retrieved 17 SGTs from: 192.168.1.187 
 
Checking connection to ISE Monitorting Node (REST server(s)) ... 
Success: Connection to ISE Monitorting Node was successful. 
REST Host contacted: ise22lab1.lab10.com 
 
Test completed successfully. 
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Step  11 To verify in ISE, select Administration->pxGrid services 
 

 
 

pxGrid Fail-Over 
There can be only 2 pxGrid nodes per ISE deployment There is a heartbeat timer between the 2 pxGrid nodes, when 
the primary pxGrid node goes down, the secondary pxGrid node will come up.  

The primary and secondary pxGrid node contain the external CA root certificate from the initial ISE node setup.  The 
external root certificate is required for active bulk downloads from the MNT node. In this ISE deployment all the 
nodes were signed by the external CA.   

The ISE internal CA signs the pxGrid certificate by default, and will also sign the generated pxGrid client certificate.  
The ISE internal CA is trusted for all  the ISE nodes. 
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Both the external CA root certificate and internal ISE root certificate will be uploaded or imported into the trusted 
store. 

The pxGrid client certificate public private key-pair will be uploaded or imported into the pxGrid client’s trusted file 
store. 

This can be implemented differently for each vendor but the basics still remain. 

Both are in the trusted certificate store of these ISE nodes and also the rest of the ISE nodes.   The external CA root 
certificate will be used in the MNT configuration setting for bulk active user downloads. 

The ISE internal root CA certificate will be trusted for both the primary pxGrid node and the secondary pxGrid node. 

 

 

Cisco Firepower Management Center (FMC) 6.2 was configured for pxGrid failover. 

Note the IP addresses of the primary and secondary ISE pxGrid nodes.  The pxGrid Server CA contains the ISE 
internal root certificate.  The MNT Server CA contains the external CA root certificate.  The FMC Server Certificate 
contains the pxGrid certificate public private key-pair that was generated by the ISE internal CA. 



   

 

 

 

 

Cisco Systems © 2017 Page 32  

SECURE ACCESS HOW-TO GUIDES 

 

Below you can see the FMC pxGrid client has successfully connected and registered to the ISE primary pxGrid node. 

 

 

The ISE primary pxGrid service was disabled, and the secondary pxGrid node came up. 

In the FMC configuration we select Test to test the connection to the secondary pxGrid node. 
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As we see in the in pxGrid services, this looks good. 
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Deploying pxGrid using ISE 2.1 with Internal CA and External 
CA certificates for ISE nodes 
This section describes the details for deploying pxGrid using the ISE Internal CA and using external CA server for the 
ISE deployment.  The pxGrid certificate is not signed by the default ISE internal CA and needs to be provisioned by 
the Certificate Portal.  The ISE nodes will also require provisioned pxGrid certificates. 

Note:  If you upgraded from a previous version of ISE, the original certificates will be maintained. 

 
Note:  If you are not using the ISE internal CA for pxGrid operation, you need to use a customized pxGrid template. 

Generating CSR requests for ISE nodes 
Step  1 Follow steps 1-14 for generating CSR requests for the ISE nodes for in the section Generating CSR 

Requests with ISE 2.2/2.3.  This is for generating the initial ISE node CSR requests and getting them 
signed by the external CA server. 

 

Registering ISE nodes 
Step  1 Follow steps 1-30 for registering the ISE nodes in the section Registering ISE Nodes in ISE 2.2/2.3.  For 

the pxGrid primary and secondary pxGrid nodes, register them initially as PSN nodes.   We will enable 
them as dedicated pxGrid nodes later on, once they are provisioned from the Certificate Portal. 

 

Certificate Provisioning 
This section details the procedure for provisioning the certificate portal if the Internal CA will be used for pxGrid 
operation. 

Step  1 Select Administration->Identity Management->Identities 
 

 
 
Step  2 Select Add 
Step  3 Enter Username and password 
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Step  4 Select Employee Group 
 

 
 
Step  5 Select Submit 

You should see: 
 

 
 
 

Step  6 Select Administration->System->Admin Access->Administrators->Admin Users->Add->Select from 
Network Users->certops->Admin Groups->Super Admin->Save 
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Step  7 Select Administration->Device Portal Management->Certificate Provisioning->Certificate 
Provisioning Portal(Default)->Select Portal Settings->Configure Authorized Groups->Employee-
>move to Chosen 

 

                     
 
 
Step  8 Select Acceptable Usage Policy (AUP) Page Settings, uncheck “Include an AUP page” 
 

 
 
 
Step  9 Select Post Login Banner Page Settings, uncheck “Include Post-Login Banner Page Settings” 
 

 
 
 
Step  10 Select Certificate Provisioning Portal Settings, under Certificate Template, select pxGrid certificate 

template 
 

 
 
 
Step  11 Select Save 
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Generate pxGrid certificate for ISE nodes 
Step  1 Configure OU field for Engineering pxGrid template 

Select Administration->System->Certificates->Certificate Authority->Certificate Templates->pxGrid 
template->edit->add “Engineering” to OU field 
 

 
 

Note:  It is important to enter Engineering or populate the OU field so it does not contain the same parameters in the OU field of the ISE admin 
certificates.  You do not want to overwrite the admin certificate 

 
Step  2 Select Save 
Step  3 Select Administration->Device Portal Management->Certificate Provisioning->Certificate 

Provisioning Portal (default)-Portal Test URL->login “certops 
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Step  4 Select Certificate Provisioning and enter the Fully Qualified Domain Names (FQDN) for the Common 
Name (CN) field details for the ISE node.  Also select Certificate in PEM format, key in PKCS8 PEM 
format for certificate download format.  
 

                    
 
Step  5 Select Generate, and save the file locally 

You should see 
 

  
 
Step  6 Import the pxGrid public private key-pair, for the desired ISE pxGrid node, that will become the primary 

pxGrid dedicated node 
Select Administration->System->Certificates->Certificate Management->System Certificates-
>Import->select the desired pxGrid node 
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Step  7 For the secondary pxGrid node, generate another certificate 
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Step  8 Download and unzip the file 

You should see 
 

 
 

Step  9 Import the pxGrid public private key-pair, for the desired ISE secondary pxGrid node, that will become the 
pxGrid dedicated node 
Select Administration->System->Certificates->Certificate Management->System Certificates-
>Import->select the desired pxGrid node 
 

 
 

Step  10 Select Submit 
Step  11 Follow steps 2-10 to generate the certificates and import the public private-key pair for the ISE primary 

pxGrid node.   
Step  12 Enable pxGrid on the desired PSN node that will be used for the primary pxGrid node, and remove the PSN 

persona. 
Select Administration->System->Deployment-edit the node, remove PSN and enable pxGrid 
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Step  13 Select Save 
Step  14 Follow steps 2-10 to generate the certificates and import the public private-key pair for the ISE secondary 

pxGrid node. 
Step  15 Enable pxGrid on the desired PSN node that will be used for the secondary pxGrid node, and remove the 

PSN persona. 
Select Administration->System->Deployment-edit the node, remove PSN and enable pxGrid 

 

                   
 
Step  16 Select Save 
Step  17 Follow steps 2-10 to generate the certificates and import the public private-key pair for the ISE primary 

admin node, secondary admin, primary MNT and secondary MNT nodes. 
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Testing pxGrid Integration with FMC 6.2 
Step  1 Select Administration->Device Portal Management->Certificate Provisioning-

>CertificateProvisioning Portal (default)-Portal Test URL->login “certops” 
 

                  
 
 
 
Step  2 Select Certificate Provisioning and enter the Fully Qualified Domain Names (FQDN) for the Common 

Name (CN) field details for the FMC 
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Step  3 Select Generate 
Step  4 You should see: 
 

 
 
 
Step  5 Select System->Integration->Identity Sources 

Enter the primary and secondary pxGrid host IP address 
The pxGrid Server CA is the CertificateServicesRootCA-ise21ab3_.cer  
The MNT Server CA is the external root certificate 

 

 
 
 
Step  6 Select Administration->pxGrid Services 
 



   

 

 

 

 

Cisco Systems © 2017 Page 44  

SECURE ACCESS HOW-TO GUIDES 

 
 
Step  7 Disable the primary pxGrid node 

Select Administration->System->Deployments->edit the primary pxGrid node, disable pxGrid 
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Step  8 Select Save 
Step  9 The secondary pxGrid node will come up.  Run “sh application status ise” to see the ISE pxGrid services 

come up. 
 

 
 
 
Step  10 You should see the pxGrid published nodes 

Select Administration->pxGrid Services 
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Testing pxGrid Integration with Java-based pxGrid Client 
This section details the procedure for configuring java-based pxGrid solution vendors with ISE 2.1 with pxGrid using 
the Internal CA for pxGrid operation.  The solution vendor certificates will be generated by the ISE internal CA.  

We will create the trust file keystore filename test008.jks and trust root store filename test008_root.jks, password for 
both Cisco123 

If the ecosystem security solution does not support certificate encryption, the private key must be decrypted, below is 
the procedure and use firepower certificate public private key-pair as example 

Note:  Firepower supports certificate encryption, we just use it here as a CLI example. 

cp firepower.lab10.com_00-0c-29-80-27-8a.key firepower.lab10.com_00-0c-29-80-27-8a.key.org   
openssl rsa -in firepower.lab10.com_00-0c-29-80-27-8a.key.org -out firepower.lab10.com_00-0c-29-80-27-8a.key  

 
Step  1 Generate the pxGrid client certificate, here we use the certificate we created for Firepower.  

 

 
 

Step  2 Download the certificate you should see: 
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Step  3 Concatenate files into one certificate 

cat CertificateServicesEndpointSubCA-ise21lab3_.cer CertificateServicesRootCA- 
ise21lab3_.cer CertificateServicesNodeCA-ise21lab3_.cer lab10-WIN-N3OR1A7H9KL-CA_.cer > CA1.cer 

Step  4 Create PKCS12 file 

Note: The passphrase is the password that was typed when generating the certificates from the ISE internal CA 

openssl pkcs12 -export -out pxGrid.p12 -inkey johns-macbook-pro.lab10.com_00-0c-29-7a-34-b9.key –in johns-
macbook-pro.lab10.com_00-0c-29-7a-34-b9.cer -chain -CAfile CA1.cer 
 
Enter pass phrase for firepower.lab10.com_00-0c-29-80-27-8a.key: Cisco123 
Enter Export Password: Cisco123 
Verifying - Enter Export Password: Cisco123 

Step  5 Import PKCS file into keystore 

keytool -importkeystore -srckeystore pxGrid.p12 -destkeystore test008.jks -srcstoretype PKCS12 
 
Enter destination keystore password:  Cisco123 
Re-enter new password: Cisco123 
Enter source keystore password:  Cisco123 
Entry for alias 1 successfully imported. 
Import command completed:  1 entries successfully imported, 0 entries failed or cancelled 

Step  6 Export CA root certificate from the ISE trusted certificate store PEM file converted to DER format 

openssl x509 -outform der -in CA1.cer -out CA1.der 

Step  7 Import the converted CA root certificate in DER format to trusted keystore 

keytool -import -alias pxGrid1 -keystore test008_root.jks -file CA1.der 
Enter keystore password:  Cisco123 
Re-enter new password: Cisco123 
Owner: CN=Certificate Services Endpoint Sub CA - ise21lab3 
Issuer: CN=Certificate Services Node CA - ise21lab3 
Serial number: 109b2c4872244d9694707f48079b1446 
Valid from: Sun Jul 30 20:10:30 EDT 2017 until: Sun Jul 31 20:10:26 EDT 2022 
Certificate fingerprints: 
  MD5:  3E:76:5C:6D:8C:26:3B:8F:5B:C4:C0:40:A4:3F:D4:B6 
  SHA1: 1B:BC:2A:65:44:1D:D3:D8:97:97:90:9B:25:27:23:16:C2:8D:62:5D 
  SHA256: 
45:3C:E9:F7:83:25:A9:11:B9:AB:00:A8:BA:0E:B3:DC:0E:3E:40:28:C2:7C:8D:C8:78:54:8A:03:97:B9:01:74 
  Signature algorithm name: SHA256withRSA 
  Version: 3 
 
Extensions:  
 
#1: ObjectId: 2.5.29.35 Criticality=false 
AuthorityKeyIdentifier [ 
KeyIdentifier [ 
0000: F4 7F 2E 7B D4 DB 5C 1A   74 09 51 EB 25 24 4E 0F  ......\.t.Q.%$N. 
0010: 74 7E 50 54                                        t.PT 
] 
[CN=Certificate Services Root CA - ise21lab1] 
SerialNumber: [    46c64293 c0d94c8c ba9d37f3 6830037d] 
] 
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#2: ObjectId: 2.5.29.19 Criticality=true 
BasicConstraints:[ 
  CA:true 
  PathLen:2147483647 
] 
 
#3: ObjectId: 2.5.29.15 Criticality=true 
KeyUsage [ 
  Key_CertSign 
] 
 
#4: ObjectId: 2.5.29.14 Criticality=false 
SubjectKeyIdentifier [ 
KeyIdentifier [ 
0000: 0C 67 46 A2 FA A1 90 35   0E 51 02 A5 9F 46 13 36  .gF....5.Q...F.6 
0010: 1E D0 26 7F                                        ..&. 
] 
] 
 
Trust this certificate? [no]:  yes 
Certificate was added to keystore 

Step  8 Import the pxGrid client certificate into the trusted file keystore 

keytool -import -alias pxGrid2 -keystore test008.jks -file johns-macbook-pro.lab10.com_00-0c-29-7a-34-b9.cer 
Enter keystore password:  Cisco123 
Certificate already exists in keystore under alias <1> 
Do you still want to add it? [no]:  yes 
Certificate was added to keystore 

Step  9 Import the CA root certificate to trusted root keystore 

keytool -import -alias pxGrid3 -keystore test008_root.jks -file CA1.cer 
Enter keystore password:  Cisco123 
Certificate already exists in keystore under alias <macpro1> 
Do you still want to add it? [no]:  yes 
Certificate was added to keystore 

Step  10 Import the CertificateServicesRoot certificate into trusted root keystore 

keytool -import -alias pxGrid4 -keystore test008_root.jks -file CertificateServicesRootCA-ise21lab3_.cer 
Enter keystore password: Cisco123  
Owner: CN=Certificate Services Root CA - ise21lab3 
Issuer: CN=Certificate Services Root CA - ise21lab3 
Serial number: 655ffcd9c3cd4fce8462fdc6062c0ea9 
Valid from: Sun Jul 30 20:10:13 EDT 2017 until: Sat Jul 31 20:10:13 EDT 2027 
Certificate fingerprints: 
  MD5:  E6:78:C1:87:BA:47:FE:FB:81:00:A6:40:81:28:57:1F 
  SHA1: 07:6B:0D:C7:C3:4F:39:9F:42:E7:2B:9F:33:0A:0D:55:3B:2E:D5:50 
  SHA256: 
6F:1D:F6:81:D5:AB:CE:EB:72:A4:89:AD:70:BA:11:BD:49:48:57:16:F1:53:A5:1E:E2:34:2E:8D:FD:A5:2D:5B 
  Signature algorithm name: SHA256withRSA 
  Version: 3 
 
Extensions:  
 
#1: ObjectId: 2.5.29.19 Criticality=true 
BasicConstraints:[ 
  CA:true 
  PathLen:2147483647 
] 
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#2: ObjectId: 2.5.29.15 Criticality=true 
KeyUsage [ 
  Key_CertSign 
] 
 
#3: ObjectId: 2.5.29.14 Criticality=false 
SubjectKeyIdentifier [ 
KeyIdentifier [ 
0000: 33 9E 4A 44 BB 04 1B B9   13 C8 F4 00 F8 DC F9 78  3.JD...........x 
0010: 6C 17 6F 00                                        l.o. 
] 
] 
 
Trust this certificate? [no]:  yes 
Certificate was added to keystore 

 
Step  11 Import the external CA root certificate into trusted root keystore 

keytool -import -alias pxGrid5 -keystore test008_root.jks -file lab10-WIN-N3OR1A7H9KL-CA_.cer 
Enter keystore password:  Cisco123 
Owner: CN=lab10-WIN-N3OR1A7H9KL-CA, DC=lab10, DC=com 
Issuer: CN=lab10-WIN-N3OR1A7H9KL-CA, DC=lab10, DC=com 
Serial number: 6f0fce547462b29a4e866b88536b829d 
Valid from: Mon Mar 28 20:33:59 EDT 2016 until: Sun Mar 28 20:43:58 EDT 2021 
Certificate fingerprints: 
  MD5:  7E:6E:B2:3A:8F:00:17:19:F1:A9:23:C9:F5:C8:B8:25 
  SHA1: EA:01:AB:89:F4:A7:77:75:23:0A:29:81:10:D8:AA:F9:02:79:3B:CB 
  SHA256: 
6A:4C:8E:76:FF:E8:8C:C5:1D:22:5B:ED:4C:E2:7E:8F:A3:55:C4:16:DA:D6:A4:4A:EA:27:47:A4:87:77:25:42 
  Signature algorithm name: SHA256withRSA 
  Version: 3 
 
Extensions:  
 
#1: ObjectId: 1.3.6.1.4.1.311.21.1 Criticality=false 
0000: 02 01 00                                           ... 
 
 
#2: ObjectId: 2.5.29.19 Criticality=true 
BasicConstraints:[ 
  CA:true 
  PathLen:2147483647 
] 
 
#3: ObjectId: 2.5.29.15 Criticality=false 
KeyUsage [ 
  DigitalSignature 
  Key_CertSign 
  Crl_Sign 
] 
 
#4: ObjectId: 2.5.29.14 Criticality=false 
SubjectKeyIdentifier [ 
KeyIdentifier [ 
0000: 16 EB 8F 72 43 0F 41 9B   68 16 F9 12 10 7E 86 73  ...rC.A.h......s 
0010: 3F 01 1B E1                                        ?... 
] 
] 
 
Trust this certificate? [no]:  yes 
Certificate was added to keystore 
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Step  12 Run Session_download script or the ecosystem partner solution 
 

Note:  The session_download sample script is not required for testing.  The security vendor should be able to download active session information if 
supported in their configuration. 

         The session_download sample script is part of the pxGrid SDK(pxGrid 1.0) which can be downloaded from 
https://developer.cisco.com/site/pxgrid/. You will need to register which is no cost.  For script reference, please see: 
https://communities.cisco.com/docs/DOC-68291  

 

./session_download.sh -a 192.168.1.174,192.168.1.176 -u pxGridClient -k test008.jks -p Cisco123 -t 
test008_root.jks -q Cisco123 
------- properties ------- 
  version=1.0.4.19 
  hostnames=192.168.1.174,192.168.1.176 
  username=pxGridClient 
  password= 
  group=Session 
  description=null 
  keystoreFilename=test008.jks 
  keystorePassword=Richard08 
  truststoreFilename=test008_root.jks 
  truststorePassword=Richard08 
-------------------------- 
Connecting... 
13:21:36.347 [main] INFO  com.cisco.pxgrid.Configuration - Connecting to host 192.168.1.174 
13:21:37.443 [main] INFO  com.cisco.pxgrid.Configuration - Connected OK to host 192.168.1.174 
13:21:37.444 [main] INFO  com.cisco.pxgrid.Configuration - Client Login to host 192.168.1.174 
13:21:37.814 [main] INFO  com.cisco.pxgrid.Configuration - Client Login OK to host 192.168.1.174 
Connected 
Filters (ex. '1.0.0.0/255.0.0.0,1234::/16...' or <enter> for no filter):  
Start time (ex. '2015-01-31 13:00:00' or <enter> for no start time):  
End time (ex. '2015-01-31 13:00:00' or <enter> for no end time):  
pxGrid controller version=1.0.3.32 
Going to url:https://ise21lab3.lab10.com:8910/pxgrid/mnt/sd/getSessionListByTime 
Session={ip=[192.168.1.232], Audit Session Id=0A0000010000002E0105D9DB, UserName=00:50:56:86:61:7F, 
MacAddresses=[00:50:56:86:61:7F], State=STARTED, EndpointProfile=VMWare-Device, NAS IP=192.168.1.3, NAS 
Port=GigabitEthernet1/0/10, RADIUSAVPairs=[ Acct-Session-Id=00000032], Posture Status=null, Posture 
Timestamp=, LastUpdateTime=Fri Oct 20 13:22:20 EDT 2017, Session attributeName=Authorization_Profiles, 
Session attributeValue=PermitAccess, Providers=[]} 
Session={ip=[192.168.1.222], Audit Session Id=0A0000010000001300025A0B, UserName=00:50:56:86:DE:2E, 
MacAddresses=[00:50:56:86:DE:2E], State=STARTED, EndpointProfile=VMWare-Device, NAS IP=192.168.1.3, NAS 
Port=GigabitEthernet1/0/10, RADIUSAVPairs=[ Acct-Session-Id=00000016], Posture Status=null, Posture 
Timestamp=, LastUpdateTime=Fri Oct 20 13:22:18 EDT 2017, Session attributeName=Authorization_Profiles, 
Session attributeValue=PermitAccess, Providers=[]} 
 

Step  13 Disable pxGrid primary, pxGrid secondary will come up. 

./session_download.sh -a 192.168.1.174,192.168.1.176 -u pxGridClient -k test008.jks -p Richard08 -t 
test008_root.jks -q Richard08 
 
------- properties ------- 
  version=1.0.4.19 
  hostnames=192.168.1.174,192.168.1.176 
  username=pxGridClient 
  password= 
  group=Session 
  description=null 
  keystoreFilename=test008.jks 
  keystorePassword=Richard08 
  truststoreFilename=test008_root.jks 
  truststorePassword=Richard08 
-------------------------- 
Connecting... 
13:39:14.427 [main] INFO  com.cisco.pxgrid.Configuration - Connecting to host 192.168.1.174 
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13:39:40.691 [main] ERROR com.cisco.pxgrid.Configuration - Failed to connect to host The following addresses 
failed: '192.168.1.174:5222' failed because java.net.ConnectException: Operation timed out192.168.1.174 
13:39:40.691 [main] INFO  com.cisco.pxgrid.Configuration - Connecting to host 192.168.1.176 
13:39:41.985 [main] INFO  com.cisco.pxgrid.Configuration - Connected OK to host 192.168.1.176 
13:39:41.985 [main] INFO  com.cisco.pxgrid.Configuration - Client Login to host 192.168.1.176 
13:39:42.264 [main] INFO  com.cisco.pxgrid.Configuration - Client Login OK to host 192.168.1.176 
Connected 
Filters (ex. '1.0.0.0/255.0.0.0,1234::/16...' or <enter> for no filter):  
Start time (ex. '2015-01-31 13:00:00' or <enter> for no start time):  
End time (ex. '2015-01-31 13:00:00' or <enter> for no end time):  
pxGrid controller version=1.0.3.32 
Going to url:https://ise21lab4.lab10.com:8910/pxgrid/mnt/sd/getSessionListByTime 
Session={ip=[192.168.1.232], Audit Session Id=0A0000010000002E0105D9DB, UserName=00:50:56:86:61:7F, 
MacAddresses=[00:50:56:86:61:7F], State=STARTED, EndpointProfile=VMWare-Device, NAS IP=192.168.1.3, NAS 
Port=GigabitEthernet1/0/10, RADIUSAVPairs=[ Acct-Session-Id=00000032], Posture Status=null, Posture 
Timestamp=, LastUpdateTime=Fri Oct 20 13:22:20 EDT 2017, Session attributeName=Authorization_Profiles, 
Session attributeValue=PermitAccess, Providers=[]} 
Session={ip=[192.168.1.222], Audit Session Id=0A0000010000001300025A0B, UserName=00:50:56:86:DE:2E, 
MacAddresses=[00:50:56:86:DE:2E], State=STARTED, EndpointProfile=VMWare-Device, NAS IP=192.168.1.3, NAS 
Port=GigabitEthernet1/0/10, RADIUSAVPairs=[ Acct-Session-Id=00000016], Posture Status=null, Posture 
Timestamp=, LastUpdateTime=Fri Oct 20 13:22:18 EDT 2017, Session attributeName=Authorization_Profiles, 
Session attributeValue=PermitAccess, Providers=[]} 

 
Step  14 Select Administration->pxGrid Services to verify the pxGrid client appears 
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Deploying pxGrid ISE 2.0/2.1 with External CA Certificates 
This section describes the details for deploying pxGrid with ISE 2.0 using an external CA Server.   The ISE pxGrid 
nodes will need to be signed by the extern al CA Server using a customized template with an EKU of both client and 
server certificates. 

Generating CSR requests for ISE nodes 
You can generate CSR request for the ISE nodes using the “admin” purpose and getting them signed by the external 
CA using the “web server” template.  You would also need to create an additional certificate for the Primary Admin, 
Secondary Admin, Primary MNT and secondary MNT nodes to support pxGrid operation.  This also goes for the 
primary and secondary pxGrid nodes. 
 
As an alternative you can create one certificate using the “admin” purpose and getting them signed by the external CA 
using the customized pxGrid template. By selecting “admin” purpose this will include pxGrid.   
 

Generating CSR requests using admin node and pxGrid certificate 
 
Step  1 Select Administration->System->Certificates->Certificate Signing Requests->Generate Certificate 

Signing Request->Usage “admin”-> select Node 
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Step  1 Select Generate 
Step  2 Export the PEM File into Advanced User’s Request window and specify the customized pxGrid template  
 

                   
Step  3 Select Submit 
Step  4 Download in Base 64 encoded format 
Step  5 Download the CA root certificate 
 

                   
 
Step  6 Select Download CA Certificate 
Step  7 Import CA root certificate into ISE trusted certificate store 

Select Administration->System->Certificates->Certificate Management->Trusted Certificates-
>Import->CAroot certificate-> 
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Step  8 Select Submit 
Step  9 You should see: 
 

 
 
 
 
Step  10 Bind the Identity Certificate to the CSR request 

Select->Administration->System->Certificates->Certificate Management->Certificate Signing 
Request (CSR)->Select the node 
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Step  11 Upload the identity certificate 
 

                  
 
 
Step  12 Select Submit 
Step  13 When you see the following message, select Yes 
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Step  14 You should see following 
 

 
 
 
Step  15 The system will restart 
Step  16 When the system comes up, login 
Step  17 Select administration->System->Certificates->Certificate management->System Certificates 
Step  18 You should see: 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



   

 

 

 

 

Cisco Systems © 2017 Page 57  

SECURE ACCESS HOW-TO GUIDES 

Generating CSR requests for admin node certificate for pxGrid operation 
 
Step  1 Select Administration->System->Certificates->Certificate Signing Requests->Generate Certificate 

Signing Request->Usage “admin”-> select Node 
 

 

 
 
Step  2 Select Generate 
Step  3 Export the PEM File into Advanced User’s Request window and specify the customized pxGrid template  
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Step  4 Select Submit 
Step  5 Download in Base 64 encoded format 
Step  6 Download the CA root certificate 
 

                   
 
Step  7 Select Download CA Certificate 
Step  8 Import CA root certificate into ISE trusted certificate store 

Select Administration->System->Certificates->Certificate Management->Trusted Certificates-
>Import->CAroot certificate-> 
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Step  9 Select Submit 
Step  10 You should see: 
 

 
 
 
 
Step  11 Bind the Identity Certificate to the CSR request 

Select->Administration->System->Certificates->Certificate Management->Certificate Signing 
Request (CSR)->Select the node 
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Step  12 Upload the identity certificate 
 

                  
 
 
Step  13 Select Submit 
Step  14 When you see the following message, select Yes 

 

 
 
 
 
 
 
 
Step  15 You should see following 
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Step  16 The system will restart 
Step  17 When the system comes up, login 
Step  18 Select administration->System->Certificates->Certificate management->System Certificates 
Step  19 You should see 
 
 

 
 
 
Step  20 Select Administration->System->Certificates->Certificate Management->CSR, select pxGrid, and 

OU field 
 

                 
 
 
Step  21 Select Generate 
Step  22 Export the PEM File into Advanced User’s Request window and specify the customized pxGrid template  
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Step  23 Select Submit 
Step  24 Download in Base 64 encoded format 
 
 
Step  25 Bind the Identity Certificate to the CSR request 

Select->Administration->System->Certificates->Certificate Management->Certificate Signing 
Request (CSR)->Select the node 
 

 
 
Step  26 Upload the identity certificate 
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Step  27 Select Submit 
Step  28 You should see the ISE identity certificate signed by the external CA server and the pxGrid certificate 

signed by the external CA server 
 

 
 
 
Step  29 Verify that the published nodes appear and there is connectivity to the pxGrid node 

Select Administration->pxGrid Services 
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Step  30 Based on either method you choose, complete the same steps for all of the ISE nodes 
 

Note:  In your deployment scenario, there needs to be an additional certificate for pxGrid for the ISE Primary Admin, Secondary Admin, Primary 
MNT and secondary MNT nodes to support pxGrid operations in addition to the pxGrid certificates on the ISE pxGrid nodes. 

         You can create a customized template for supporting pxGrid Certificate Signing Requests (CSR) using “admin” purpose, this way no additional 
pxGrid certificate is necessary or you can follow step 1 and create an additional pxGrid certificate 

 

Registering ISE pxGrid Nodes. 
 
Step  1 You would need to create customized templates for the ISE admin, ISE MNT nodes and pxGrid nodes CSR 

request.  This customized template must contain an EKU of both client and server authentication. Please 
Customized pxGrid Template under References 

 

Note:  You also create a certificate specifically for pxGrid.  If you go down this route, you would need to change the OU field in the CSR request and 
ensure that is not the same name if the admin Certificate Signing Requests (CSR). 

 

Generating pxGrid Client Certificates 
 
Step  1 Generate private key using –des3.  The –des3 argument provides the encryption password. 

openssl genrsa -des3 -out client.key 4096 
Generating RSA private key, 4096 bit long modulus 
......... 
........................ 
e is 65537 (0x10001) 
Enter pass phrase for client.key: Cisco123 
Verifying - Enter pass phrase for client.key: Cisco123 

Step  2 Generate CSR request 

openssl req -new -key client.key -out client.csr 
Enter pass phrase for client.key: Cisco123 
You are about to be asked to enter information that will be incorporated 
into your certificate request. 
What you are about to enter is what is called a Distinguished Name or a DN. 
There are quite a few fields but you can leave some blank 
For some fields there will be a default value, 
If you enter '.', the field will be left blank. 
----- 
Country Code []:US 
State or Province Name []:Maryland 
Locality Name []:Germantown 
Organization Name []:Cisco 
Organizational Unit Name []:Engineering 
Common Name []:fmc62.lab10.com 
Email Address []:j@c.com 
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Testing using Cisco Firepower Management Center 6.1 
Step  1 Copy CSR request into pxGrid template 

cat client.csr 
-----BEGIN CERTIFICATE REQUEST----- 
MIIE0zCCArsCAQAwgY0xCzAJBgNVBAYTAlVTMREwDwYDVQQIEwhNYXJ5bGFuZDET 
MBEGA1UEBxMKR2VybWFudG93bjEOMAwGA1UEChMFQ2lzY28xFDASBgNVBAsTC0Vu 
Z2luZWVyaW5nMRgwFgYDVQQDEw9mbWM2Mi5sYWIxMC5jb20xFjAUBgkqhkiG9w0B 
CQEWB2pAYy5jb20wggIiMA0GCSqGSIb3DQEBAQUAA4ICDwAwggIKAoICAQC6gXkN 
wGLdzv3P5IApJIRePWAKd+2uab6ikZX+HfIsAdg8sMxw/VVqCiJ7eu1zoeApZn2L 
7JJ4tq4iHjyI9N0kTMrBlqHsoKPrvQZUMAKWs8LLK5jgElhShNpidClmWW9kZtE+ 
6179ig21j7V0BFo+pmx0cLNoOA/rTXhAJKbuKsLpyEnALDjgDXYpIHuRKJOSps6C 
6geiK7jJ4lzoG4lxvRuudDiauUxLDKh2L/ga44STTAeahXWBkF0u43zkmrPFR0Ck 
7vo3yQf0ha/5Kl/41Q0oULe1rkmE5/ApNsQ90r8wpm961biog3GnRg0uEww2ODIp 
dPI5bJSgup8y+gsS0CilFCUDXgywRdt/DRTxJjiPX/YQiPvwS+rcxeDg/PqlmtwA 
uVhcGdCEMRqYY08yPhIomDuGpVL0vu1iNo3CDjYH/r5W2tAEPOLWx8nArJjsCkfC 
Z8ld/BBdfHoh4X9xcfteLr48zxSoh0RgD9wCjkbF7N0m+313weARnOBkKWAIpOFu 
G60ceERm8rf6xDQdgBtLWRhfBPKNuS5Ljsb0m5QeD/340KwGCKxMem7hUPCxLNxC 
XUhmszqhppBhKymw0iw/f7th0XkBPuw4amXlgsi3tMgaK5DG17D105XDb4ssChZf 
4iym5WZ0Inxo1g+27tQGnMgYePqG58YCMaHegQIDAQABoAAwDQYJKoZIhvcNAQEL 
BQADggIBAEEJKjsEak/ud/mFJrjz5GaedsnIxF1tXZDjQyqZH1HS7+TUuaHrQGOn 
tYpVoiT60Js8o516T0eAbXTnTh3mP9yHpHbRKBWpNNB1H/+FcSI9uSzrzJymyb8a 
URLAJKcw0in6weVC/52F7DYeVTrEZfwHJFKaxS0033KEi+4fphPde+cHZsmB0aQG 
Aa2jdn7zuaY6ZxE8YfZsvwRMkEwVu/ZGKRuBAsX6RFokH5OUAH1A6wG7jaRFrcUf 
3UAGaD3DFN5c5NsFItTX/5YaUjqFHD4KA8KOuXhw7i8sui0EBJAKVZIGTipJ2qFR 
Um/VfNDztwb7TsBkhbSSMuEBJwtst9czHCvz+YeJ3nACn8e4otNborqYCLmKTnIr 
WMW8Exe/QhW1mn6CFbUsve+C75TLLoEGfuSRalavE+Bermd0ouqwcszsrZHXXdlN 
IJXfwd6E9Ll4og3JQGu6/E8dJpUSuynOW3vyzqRbiNjw6yl/cwLRU56QDpPVn53s 
y3+Z11YS73mxlbLxAeGqYiGVJPsIUF78oVe6DDBlg0hTa7omhrhOup4QkdxOk+7R 
rW9qT74x53lE+0oSMlFfqmVHaONbe/VSSWZsVd+SXppF0u91XQ2gRLxnR2VD1u2m 
hopyrupUaY8z7kjvgw+4o5Eiwxuny5SUWbbNPsLLe35NfO0Jdyyd 
-----END CERTIFICATE REQUEST----- 

Step  2 Get FMC CSR request, client.csr, signed by CA server using the pxGrid customized template. 
Step  3 Enter the IP address of the pxGrid node 
Step  4 Upload the external root CA certificate for both the pxGrid Server CA and the MNT Server CA, in this 

case, MSCARoot1 
Step  5 Upload the FMC public certificate and private key, and enter the encryption password, Save 
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Note:  You can also use “cat client.key” to copy/paste into the FMC private key window. 

 
Step  6 You should see: 
 

                   
 
 

Testing pxGrid Integration with Java-based pxGrid Client 
Most ecosystem security solution vendors will use the java keystore method instead of working with certificates 
directly.  In this example, pxGridclient.jks is the trusted file keystore and root3.jks is the trusted root keystore.  For 
more references please see: https://communities.cisco.com/docs/DOC-68285  

We will create the trust file keystore filename pxGridClient.jks and trust root store filename root3.jks, password for 
both Cisco123 

If the ecosystem security solution does not support certificate encryption, the private key must be decrypted, below is 
the procedure: 

cp pxGridClient.key pxGridClient.key.org   
openssl rsa -in pxGridClient.key.org -out pxGridClient.key  

Step  1 Generate a private key 

openssl genrsa –out pxGridClient.key 4096 

Step  2 Generate a Certificate Signing Request (CSR) 

openssl req –new –key pxGridClient.key out pxGridClient.csr 

Step  3 Import CA root certificate into PKCS12 file 
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openssl pkcs12 –export –out pxGridClient.p12 –inkey pxGridClient.key –in pxGridClient.cer –chain –CAfile 
ca_root.cer 

Step  4 Create the trusted file keystore 

keytool –import –srckeystore pxGridClient.p12 –destkeystore pxGridClient.jks –srcstoretype PKCS12 

Step  5 Convert the .cer file to .der format 

openssl x509 –outform der –in ca_oot.cer –out ca_root.der 

Step  6 Import the CA root certificate into the trusted root keystore 

keytool –import –alias isemnt –keystore root3.jks –file ca_root.der 

Step  7 Import the client certificate into trusted root keystore 

keytool –import –alias pxGridMAC –keystore pxGridCient.jks –file pxGridClient.cer 

Step  8 Import root certificate into trusted root keystore 

keytool –import –alias ca_root1 –keystore root3.jks –file ca_root.cer 
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Deploying Cisco ISE 1.3/1.4 with External CA Certificates 
This section discusses pxGrid deployment for ISE I.3/1.4 in productional environments using and external Certificate 
Authority (CA) for certificate deployment.   A pxGrid certificate is required for the ISE Primary Admin, ISE 
Secondary Admin, ISE Primary MNT, ISE Secondary, Primary and Secondary pxGrid nodes.  The external CA server 
requires a customized “pxGrid” template to services this request.  This customized template must contain an EKU of 
both client authentication and server authentication.  If you are not familiar with creating this template, please see 
Customized pxGrid Template under References section.   

Generating CSR Requests for ISE nodes 
Step  1 Generate the Certificate Signing Requests (CSR) for all the ISE nodes.  Below is a sample for the ISE 

admin node. 
Select Administration->System->Certificates->Certificate Management->Certificate Signing 
Requests 

 

                     
 
 
Step  2 Select  Generate and Export, copy/paste the CSR request into CA authority Advanced Server request and 

get the certificate signed by the CA using the “web server” template 

Note: For admin and MNT nodes, you can use the “customized” pxGrid template, by default the ‘usage” for pxGrid will be enabled.  If you have the 
“web server” template” for the certificate, you will need to generate an additional certificate for pxGrid as demonstrated in the following steps 
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Step  3 Select Submit 
Step  4 Download the certificate in base 64 encoded format.  
Step  5 Also download the CA root certificate in based 64 encoded format. 
Step  6 Import the CA root certificate into the ISE trusted certificate store.  

Select Administration->System->Certificates->Certificate Management->Trusted Certificates and 
upload the root certificate 

 
 

                   
 
 
Step  7 Select Submit, you should see: 
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Step  8 Bind the certificates to their associated Binding request.  

Select Administration->System->Certificates->Certificate Management->Certificate Signing 
Requests->edit the node->Bind Certificate 

 

 
 
 
Step  9 Upload the ISE admin node certificate select Submit 
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Step  10 Select Submit 
Step  11 You will see the following message 
 

 
 
 
Step  12 Select Yes 
Step  13 System will restart 
 
 
Step  14 Generate another certificate for pxGrid communication 

Select Administration->System->Certificates>Certificate Management->Certificate Signing 
Requests->Select “pxGrid” usage 
Enter “Engineering” in the OU field or some other description.  This must not match the OU field in the 
admin certificate. 
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Step  15 Select Generate and Export 
Step  16 Copy/Paste the CSR request into the Advanced user request and select the customized pxGrid template 
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Step  17 Select Submit and download the certificate in base 64 encoded format 
Step  18 Bind certificate to the CSR request 

Select Administration->System->Certificates->Certificate Management->Certificate Signing 
Requests (CSR)-edit node->Bind Certificate 

 

 
 
 
Step  19 Upload the pxGrid certificate for the admin node 
 

 
 
 
Step  20 Select submit 
Step  21 Perform the steps 1-21 for all the ISE nodes. 
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Registering ISE Nodes 
 

Step  1 Register the desired ISE pxGrid node via the Primary Admin node and enable for pxGrid operation ONLY. 
Select Administration->System->Deployment->Deployment Nodes->Register and enter the HOST 
FQDN name of the ISE pxGrid node 

 

                  
 
 
Step  2 Select Next 
Step  3 Enable pxGrid 
 

                        
 
Step  4 Select Save 
Step  5 You should see that the dedicated pxGrid node sync process has begun 
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Step  6 After a couple of minutes you should see that the ISE pxGrid node has successfully synced 
 

                  
 
 
Step  7 Register all the ISE nodes through the ISE Primary admin node 
Step  8 Verify the published ISE nodes appear and there is connectivity 

Select Administration->pxGrid Services 
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Generating pxGrid Client Certificates 
 
Step  1 Generate private key using –des3.  The –des3 argument provides the encryption password. 

openssl genrsa -des3 -out client.key 4096 
Generating RSA private key, 4096 bit long modulus 
......... 
........................ 
e is 65537 (0x10001) 
Enter pass phrase for client.key: Cisco123 
Verifying - Enter pass phrase for client.key: Cisco123 

Step  2 Generate CSR request 

openssl req -new -key client.key -out client.csr 
Enter pass phrase for client.key: Cisco123 
You are about to be asked to enter information that will be incorporated 
into your certificate request. 
What you are about to enter is what is called a Distinguished Name or a DN. 
There are quite a few fields but you can leave some blank 
For some fields there will be a default value, 
If you enter '.', the field will be left blank. 
----- 
Country Code []:US 
State or Province Name []:Maryland 
Locality Name []:Germantown 
Organization Name []:Cisco 
Organizational Unit Name []:Engineering 
Common Name []:fmc62.lab10.com 
Email Address []:j@c.com 

 

Testing using Cisco Firepower Management Center 6.1 
In this example, Firepower Management Center 6.1 was used for testing.  For other Cisco Security Solutions and 
Ecosystem partner integrations, please see: https://communities.cisco.com/docs/DOC-
64012#/jive_content_id_Cisco_Platform_Exchange_Grid_pxGrid 

 

Step  1 Copy CSR request into pxGrid template 

cat client.csr 
-----BEGIN CERTIFICATE REQUEST----- 
MIIE0zCCArsCAQAwgY0xCzAJBgNVBAYTAlVTMREwDwYDVQQIEwhNYXJ5bGFuZDET 
MBEGA1UEBxMKR2VybWFudG93bjEOMAwGA1UEChMFQ2lzY28xFDASBgNVBAsTC0Vu 
Z2luZWVyaW5nMRgwFgYDVQQDEw9mbWM2Mi5sYWIxMC5jb20xFjAUBgkqhkiG9w0B 
CQEWB2pAYy5jb20wggIiMA0GCSqGSIb3DQEBAQUAA4ICDwAwggIKAoICAQC6gXkN 
wGLdzv3P5IApJIRePWAKd+2uab6ikZX+HfIsAdg8sMxw/VVqCiJ7eu1zoeApZn2L 
7JJ4tq4iHjyI9N0kTMrBlqHsoKPrvQZUMAKWs8LLK5jgElhShNpidClmWW9kZtE+ 
6179ig21j7V0BFo+pmx0cLNoOA/rTXhAJKbuKsLpyEnALDjgDXYpIHuRKJOSps6C 
6geiK7jJ4lzoG4lxvRuudDiauUxLDKh2L/ga44STTAeahXWBkF0u43zkmrPFR0Ck 
7vo3yQf0ha/5Kl/41Q0oULe1rkmE5/ApNsQ90r8wpm961biog3GnRg0uEww2ODIp 
dPI5bJSgup8y+gsS0CilFCUDXgywRdt/DRTxJjiPX/YQiPvwS+rcxeDg/PqlmtwA 
uVhcGdCEMRqYY08yPhIomDuGpVL0vu1iNo3CDjYH/r5W2tAEPOLWx8nArJjsCkfC 
Z8ld/BBdfHoh4X9xcfteLr48zxSoh0RgD9wCjkbF7N0m+313weARnOBkKWAIpOFu 
G60ceERm8rf6xDQdgBtLWRhfBPKNuS5Ljsb0m5QeD/340KwGCKxMem7hUPCxLNxC 
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XUhmszqhppBhKymw0iw/f7th0XkBPuw4amXlgsi3tMgaK5DG17D105XDb4ssChZf 
4iym5WZ0Inxo1g+27tQGnMgYePqG58YCMaHegQIDAQABoAAwDQYJKoZIhvcNAQEL 
BQADggIBAEEJKjsEak/ud/mFJrjz5GaedsnIxF1tXZDjQyqZH1HS7+TUuaHrQGOn 
tYpVoiT60Js8o516T0eAbXTnTh3mP9yHpHbRKBWpNNB1H/+FcSI9uSzrzJymyb8a 
URLAJKcw0in6weVC/52F7DYeVTrEZfwHJFKaxS0033KEi+4fphPde+cHZsmB0aQG 
Aa2jdn7zuaY6ZxE8YfZsvwRMkEwVu/ZGKRuBAsX6RFokH5OUAH1A6wG7jaRFrcUf 
3UAGaD3DFN5c5NsFItTX/5YaUjqFHD4KA8KOuXhw7i8sui0EBJAKVZIGTipJ2qFR 
Um/VfNDztwb7TsBkhbSSMuEBJwtst9czHCvz+YeJ3nACn8e4otNborqYCLmKTnIr 
WMW8Exe/QhW1mn6CFbUsve+C75TLLoEGfuSRalavE+Bermd0ouqwcszsrZHXXdlN 
IJXfwd6E9Ll4og3JQGu6/E8dJpUSuynOW3vyzqRbiNjw6yl/cwLRU56QDpPVn53s 
y3+Z11YS73mxlbLxAeGqYiGVJPsIUF78oVe6DDBlg0hTa7omhrhOup4QkdxOk+7R 
rW9qT74x53lE+0oSMlFfqmVHaONbe/VSSWZsVd+SXppF0u91XQ2gRLxnR2VD1u2m 
hopyrupUaY8z7kjvgw+4o5Eiwxuny5SUWbbNPsLLe35NfO0Jdyyd 
-----END CERTIFICATE REQUEST----- 

Step  2 Get FMC CSR request, client.csr, signed by CA server using the pxGrid customized template. 
Step  3 Enter the IP address of the pxGrid node 
Step  4 Upload the external root CA certificate for both the pxGrid Server CA and the MNT Server CA, in this 

case, MSCARoot1 
Step  5 Upload the FMC public certificate and private key, and enter the encryption password, Save 
 

                  
 

Note:  You can also use “cat client.key” to copy/paste into the FMC private key window. 

 
Step  6 You should see: 
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Step  7 Select Administration->pxGrid Services 
 

 
 

Testing pxGrid Integration with Java-based pxGrid Client 
Most ecosystem security solution vendors will use the java keystore method instead of working with certificates 
directly.  In this example, pxGridclient.jks is the trusted file keystore and root3.jks is the trusted root keystore and the 
password for both is Cisco123.  For more references please see: https://communities.cisco.com/docs/DOC-68285 

If the ecosystem security solution does not support certificate encryption, the private key must be decrypted, below is 
the procedure: 

cp firepower.lab10.com_00-0c-29-80-27-8a.key firepower.lab10.com_00-0c-29-80-27-8a.key.org   
openssl rsa -in firepower.lab10.com_00-0c-29-80-27-8a.key.org -out firepower.lab10.com_00-0c-29-80-27-8a.key  
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Step  1 Generate a private key 

openssl genrsa –out pxGridClient.key 4096 

Step  2 Generate a Certificate Signing Request (CSR) 

openssl req –new –key pxGridClient.key out pxGridClient.csr 

Step  3 Import CA root certificate into PKCS12 file 

openssl pkcs12 –export –out pxGridClient.p12 –inkey pxGridClient.key –in pxGridClient.cer –chain –CAfile 
ca_root.cer 

Step  4 Create the trusted file keystore 

keytool –import –srckeystore pxGridClient.p12 –destkeystore pxGridClient.jks –srcstoretype PKCS12 

Step  5 Convert the .cer file to .der format 

openssl x509 –outform der –in ca_oot.cer –out ca_root.der 

Step  6 Import the CA root certificate into the trusted root keystore 

keytool –import –alias isemnt –keystore root3.jks –file ca_root.der 

Step  7 Import the client certificate into trusted root keystore 

keytool –import –alias pxGridMAC –keystore pxGridCient.jks –file pxGridClient.cer 

Step  8 Import root certificate into trusted root keystore 

keytool –import –alias ca_root1 –keystore root3.jks –file ca_root.cer 
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Troubleshooting 

ISE 1.3/14 

Self-Signed Certificates 
• For Proof of Concept (POV) environments, you can use self-signed certificates.  For self-signed certificates 

you would need to import the ISE Identity certificate into the ISE trusted system store. 

Bulk-Download Active Hosts not working 
• Promote the ISE-stand-alone to primary node.  There was an issue with the Fully Qualified Domain Name 

(FQDN).  This was resolved in ISE 2.0+ 

• Ensure the CA root certificate is used for MNT certificate selection if this is applicable to the pxGrid client 

• Ensure the CA root certificate is in the trusted root keystore if the JAVA keystores are used. 

ISE 1.3/1.4/2.0/2.1/2.2+ 

pxGrid clients not connecting 
• Can be stuck waiting for admin approval-  Ensure Auto Registration is enabled and Client settings set for Auto 

Approval. 

• Ensure that the external root certificate is in the in the application’s trusted root keystore if java or in the 
trusted Certificate Authority (CA) store if using certificates directly. 

• Ensure that times are synced between the ecosystem or Cisco Security Solution and ISE pxGrid nodes or ISE 
in general 

• The pxGrid client and ISE should be Fully Qualified Domain Name (FQDN) name resolvable 

• Certificate downloads should be in based 64 encoded format 

• If using an external CA server directly, please make you are using the customized pxGrid template for ISE 1.3-
1SE 2.1 (if not using ISE internal CA) 

• For pxGrid client certificate configuration settings in the pxGrid clients, if this is ISE 2.1 (internal ISE CA), or 
ISE 2.2+, this should be set to the ISE root CA certificate, otherwise should be the external root CA. 

• For bulk download settings or MNT configuration settings in the pxGrid clients, if this is ISE 2.1 (internal 
CA), or ISE 2.2+,  this should be set to the external CA root certificate. 

Bulk Download or REST failures 
• For bulk download settings or MNT configuration settings in the pxGrid clients, if this is ISE 2.1 (internal 

CA), or ISE 2.2+,  this should be set to the external CA root certificate. 
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References 

Using an External Certificate Authority (CA) Server 
Using an external CA server to generate pxGrid certificate, a customized template with an EKU of both client and 
server authentication must be configured.  In this example, Microsoft 2008 Enterprise CA R2 Server was used. 

Customized pxGrid Template 
Step  1 Select Administrative Tools->Certificate Authority-> “+” dropdown next to CA server->Right-Click 

on Certificate Templates->Manage
 

  
 

Step  2 Right-Click and Duplicate User template->Select Windows 2003 Enterprise->OK 
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Step  3 Enter name of certificate template, uncheck “Publish certificate in Active Directory”, and provide validity 
period and renewal period. 
 

 
 

Step  4 Click Extensions->Add->Server Authentication->Ok->Apply 
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Step  5 Click Subject Name, Enable Supply in the request 
 

 
 
Step  6 Click Extensions->Issuance Policies->Edit->All Issuance Policies 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 



   

 

 

 

 

Cisco Systems © 2017 Page 86  

SECURE ACCESS HOW-TO GUIDES 

Step  7 Leave the defaults for request handling 

 
 
 

Step  9 Select New Template to issue and select pxGrid 
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Step  10 You should see the pxGrid template 
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References 
https://communities.cisco.com/docs/DOC-71927  Using ISE 2.1 Internal Certificate Authority (CA) to Deploy 
Certificates to Cisco pxGrid clients (not using external CA Server) 

https://communities.cisco.com/docs/DOC-71928  Using ISE 2.2 Internal Certificate Authority (CA) to Deploy 
Certificates to Cisco pxGrid clients (not using external CA Server) 

https://communities.cisco.com/docs/DOC-71926  Deploying Certificates with Cisco pxGrid- Using an external 
Certificate Authority (CA) with updates to Cisco ISE 2.0/2.1/2.2 

https://communities.cisco.com/docs/DOC-71925  Deploying Certificates with pxGrid- Using Self-Signed Certificates 
Updates to Cisco ISE 2.0/2.1/2.2 

https://communities.cisco.com/docs/DOC-68285  Using an External CA Server for ISE 1.3/1.4 Deployments 

https://communities.cisco.com/docs/DOC-68286  Using Self Signed certificates for ISE 1.3/1.4 Deployments 

 

 

 

 

 

 

 

 

 

 

 


