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About This Document 
This document is intended for Cisco field engineers, technical marketing engineers, partners, and customers deploying 
Cisco StealthWatch 6.7.1 with Cisco platform exchange Grid (pxGrid) using Cisco Identity Service Engine (ISE) 1.3 
or higher. 

This document assumes that StealthWatch and ISE are already installed and provides the following: 

• Customized pxGrid template creation for both the ISE pxGrid node and the SMC (StealthWatch Management 
Center) 

• Configuring ISE for pxGrid node operation using either Certificate Authority (CA)-signed certificates or self-
signed certificates 

• Configuring the StealthWatch Management Console (SMC) as a pxGrid client using either Certificate 
Authority (CA)-signed certificates or self-signed certificates. 

• Configuring the StealthWatch Management Center (SMC) for Cisco (Adaptive Network Control) ANC pxGrid 
mitigation action. 

Please note that ISE was deployed in a Stand-alone environment with pxGrid enabled. 

If deploying pxGrid in a production environment using CA-signed certificates please see: Configuring pxGrid in an 
ISE Distributed Environment: http://www.cisco.com/c/en/us/support/security/identity-services-engine/products-
implementation-design-guides-list.html 

 

 

 

 

http://www.cisco.com/c/en/us/support/security/identity-services-engine/products-implementation-design-guides-list.html
http://www.cisco.com/c/en/us/support/security/identity-services-engine/products-implementation-design-guides-list.html
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Introduction 
Cisco StealthWatch is a network security solution providing real-time visibility into network and user traffic detecting 
anomalous behavior, APTs, insider threats, DDoS and other malware. Lancope also collects and analyzes holistic 
network trails and responds to these threats before during and after an incident request performing mitigation actions 
on these endpoints in real-time. 

Cisco Platform Exchange Grid (pxGrid) is a unified framework that enables ecosystem partners to obtain user and 
device contextual information from Cisco’s Identity Service Engine (ISE).  ISE publishes topics of information and 
ecosystem partners subscribes to these published topics, obtaining ISE session information and taking Adaptive 
Network Control (ANC) mitigation actions on endpoints.  

Cisco StealthWatch, registers to the ISE pxGrid node as a client and subscribes to the EndpointProtectionService 
capability and performs ANC mitigation actions on the endpoint. These mitigation actions in include quarantining/un-
quarantining and a IEEE 802.1X endpoint authenticated by ISE. 

This document assumes that StealthWatch 6.7.1 or higher and ISE 1.3 or higher have been installed. 

StealthWatch as a pxGrid client requires either Certificate Authority (CA)-signed certificate, or a self-signed certificate 
to be used for pxGrid operation. Both certificate use cases are covered. 

• A signed certificate use case includes importing the CA trusted root certificate, and generating a public key 
pair on the SMC, to be signed by the same CA that signed the ISE pxGrid node certificate.  It is assumed that 
the CA root certificate has been installed in the ISE trusted system certificate store and the pxGrid ISE node 
certificate has been installed in the ISE system certificate store 

• The self-signed certificate use case steps through the complete ISE pxGrid node configuration and self-signed 
public or private key SMC creation.   

• In StealthWatch 6.7.1 the identity certificate must be uploaded to the Client Identity SSL store for pxGrid 
operation. 

Both use cases include SMC mitigation action configuration and examples. 
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Using CA-Signed Certs for SMC and ISE pxGrid Node 
This section takes you through the steps for implementing CA-signed certs on the SMC and for using the java client. 

Customized pxGrid Template for CA-Signed Operation 
A customized pxGrid template having an Enhanced Key Usage (EKU) of both client authentication and server 
authentication is required for pxGrid operation between the pxGrid client, the SMC, and the ISE pxGrid node. This is 
required for a Certificate Authority (CA)-signed environment where both the SMC and the ISE pxGrid node are signed 
by the same CA. 

Step  1 Select Administrative Tools->Certificate Authority-> “+” dropdown next to CA server->Right-Click 
on Certificate Templates->Manage 

 

                  
 
 
Step  2 Right-Click and Duplicate User template->Select Windows 2003 Enterprise->OK 
 

                  
 
 
 
Step  3 Enter name of certificate template, uncheck “Publish certificate in Active Directory”, and provide validity 

period and renewal period. 
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Step  4 Click Extensions->Add->Server Authentication->Ok->Apply 
 

                 
 
 
 
 
 
 
 
 
 
 
 
 
 
Step  5 Click Subject Name, Enable Supply in the request 
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Step  6 Click Extensions->Issuance Policies->Edit->All Issuance Policies 

 

                 
 
 
 
 
 
 
 
 
 
Step  7 Leave the defaults for request handling 
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Step  8 Right-click on Certificate Templates 
Step  9 Select New Template to issue and select pxGrid 

 

 
 
 
 
 
 
 
 
 
Step  10 You should see the pxGrid template 
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Configuring ISE 2.0 
The ISE pxGrid node is configured for a Certificate Authority (CA) signed environment in a stand-alone configuration.  
Initially, a “pxGrid” CSR request is generated from the ISE node and signed by the CA server using the pxGrid 
customized template.  The certificate will be bound to the initial ISE CSR request.   

The CA root certificate will be imported into the ISE certificate trusted store.  The ISE identity certificate will be 
exported in the ISE certificate system store.  The ISE node will be enabled for pxGrid operation. 

Step  1 Generate a CSR request for the ISE node which will become the ISE pxGrid node 
Administration->System->Certificates->Certificate Signing Requests->Generate 

Note: The certificate usage should be admin.  This is required for FMC 6.0 for active bulk download sessions 

                   

 

 

 

Step  2 Copy/paste the CSR information into Request a certificate->Advanced certificate request selecting the 
customized pxGrid template, then Submit 
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Step  3 Download the CA root in base-64 encoded format 
 

                  
 
Step  4 Upload the CA root into the ISE certificate trusted system store 

Select Administration->System->Certificates->Trusted Certificates->upload the CA root certificate 
 
Step  5 Enable “Trust for authentication within ISE”, then Submit 
 

                   
 
 
 

 
Step  6 Upload the ISE pxGrid node certificate into the ISE certificate system store 

Select Administration->System-Certificate Signing Requests and Bind certificate to the CSR request 
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Step  7 Select Administration->System->Certificates->Certificate Management->Certificate Signing 

Request->Generate Certificate Signing Requests (CSR)->Admin for certificate usage 
 

                     
 
Step  8 Select Node 
 
Step  9 Select DNS name for the Subject Alternative Name (SAN) and add the DNS name 
 

                  
 
Step  10 Select Generate 
Step  11 Select Export 
Step  12 Open the pem file and copy or paste the csr request into the customized pxGrid template 
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Step  13 Paste into Request a Certificate->Advanced Certificate Request, select customized pxGrid template-

>Submit 
 

                  
 
Step  14 Select Submit 
Step  15 Download certificate in base 64 encoded format 
 

                    
 
 
 
 
 
 
 



   

 

 

 

 

Cisco Systems © 2016 Page 13  

SECURE ACCESS HOW-TO GUIDES 

Step  16 Download CA root certificate in Base 64 format 
 

                 
 
Step  17 Administration System->Certificates->Certificate Management->Trusted Certificates->Import the 

root certificate 
 

Step  18 Enable Trust for authentication within ISE 
 

                   
 
 
Step  19 Select Submit 

 
Step  20 Select Administration->Certificates->Certificate Management->System Certificates->Certificate 

Signing Requests->select CSR request->Bind Certificate 
 

                    
 
 
 
Step  21 Upload the ISE CA-signed identity certificate 
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Step  22 Select Submit 
Step  23 Select Yes, when you see the following message: 

 

                   
Step  24 Select Yes, when you see the following message 

 
 

                     
 
Step  25 The system will restart, and return to the GUI 

 
 

                     
 
 
Step  26 Select Administration->System->Deployment->edit the Hostname->enable pxGrid 
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Step  27 Select Save 
Step  28 Select Administration->pxGrid Services, verify that you see the published services 

 

 
 

Note: This may take a few seconds to appear, verify that the pxGrid services are initializing by running “sh application status ise” on the ISE VM 

 
Step  29 Enable Enable Auto Registration 
 

 
 
Step  30 Verify that you are connected to pxGrid 

 

                      

 

Creating SMC Identity Certificate and Downloading CA Root Certificate 
Here we generate the SMC private key, certificate-signing request (CSR) to be signed by the CA authority. The CA 
template for pxGrid must contain an EKU of both client authentication and server authentication to be valid for pxGrid 
operation. 
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Step  1 Create the private key on SMC 

openssl genrsa -out smc.key 4096 
Generating RSA private key, 4096 bit long modulus 
.............................................................................................................
..............................................................................++ 
..........++ 
e is 65537 (0x10001) 

Step  2 Create the SMC CSR request to be signed by the CA server 

openssl req -new -key smc.key -out smc.csr 
 
You are about to be asked to enter information that will be incorporated 
into your certificate request. 
What you are about to enter is what is called a Distinguished Name or a DN. 
There are quite a few fields but you can leave some blank 
For some fields there will be a default value, 
If you enter '.', the field will be left blank. 
----- 
Country Name (2 letter code) [AU]: 
State or Province Name (full name) [Some-State]: 
Locality Name (eg, city) []: 
Organization Name (eg, company) [Internet Widgits Pty Ltd]: 
Organizational Unit Name (eg, section) []: 
Common Name (e.g. server FQDN or YOUR name) []: 
Email Address []: 
 
Please enter the following 'extra' attributes 
to be sent with your certificate request 
A challenge password []: 
An optional company name []: 

Step  3 Gain root access to SMC, use SCP to copy the SMC.CSR and SMC.key file over to a secure PC. This PC is 
used to copy or paste the SMC.CSR into an advanced user request for the pxGrid-customized template. 

Note: If using Win Laptop, download freeSSHd or utility that installs SSH service so SCP copy can be used to copy these files from the SMC to a  
Win Laptop 

 
Step  4 Download the certificate in a base-64 encoded format 
Step  5 Rename the .cer file to a .crt file since this a X509 certificate and was downloaded in base-64 encoded 

format.   This renamed .crt file is used to upload the SSL Client identity certificate. This certificate is used 
for pxGrid client authentication. This is new in StealthWatch 6.7.1. 
 

Step  6 Download CA root certificate 
 

Upload CA Root Certificate into SMC Trusted Store 
Step  1 Select Admin Users->Administer Appliance->Configuration->Certificate Authority Certificates-

>Browse Upload the root.cert file 
 

Step  2 Provide a description use underscores, DO NOT USE SPACES->Add Certificate 
You should see the following: 
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Upload SMC Identity Certificate to SSL Server Identity 
Step  3 Select ->Admin Users->Administer Appliance->Configuration->SSL Certificate->SSL Server Identity-

>Upload the SMC public certificate and private key pair 
 

                     
 
Step  4 Click Upload Certificate 
 

Upload SMC Identity Certificate to SSL Client Identities 
Step  1 Select Admin Users->Administer Appliance->Configuration->SSL Certificate->SSL Client Identities-

>Upload the SMC public certificate.crt file and private key pair 
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Step  2 Enter Friendly Name; use underscores, no spaces are allowed. 
Step  3 Click Upload Certificate 

Receiving Syslog Events from ISE 
Step  1 Log in to SMC->Tools->Settings->Cisco ISE Configuration, you will see the following configuration 

If you see the following message, ensure that you have uploaded the CA root certificate to the SMC CA 
store. 

Note: It is assumed that the ISE has already been configured to enable Passed Authentications, RADIUS Accounting, Profiler, Operational, and 
Administration Audit syslog messages to the SMC over UDP 3514. 

 

 
 
 
Step  2 Upload the CA root certificate into the SMC  
Step  3 Select Tools->Settings->fill in the ISE MnT node information, you should see the following 
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Step  4 Add Cisco ISE Mitigation, select the pxGrid_client1 or friendly name you created earlier 

Note: The Primary PAN node name is the primary ISE pxGrid node 

 

                     
 
Step  5 Click Save 
Step  6 You should see 

 

                    
 
 
 
 
 
 
 
Step  7 Click OK 
Step  8 You should see the SMC has registered as a pxGrid client 
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Step  9 Move the registered Lancope smc-01 client to the EPS client group. 

Select smc-01->Group->delete Basic, select EPS->Save 
 

                   
 
Step  10 You should see the smc-01 client has moved to the EPS group 
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SMC Client- Getting the Host Java Store to Trust the CA Certificate 
Note: If the CA does not have a standard public CA as its root the host java store must be configured to trust the CA root certificate in order to open 
the java client. 

Step  1 Open the SMC java client with the Java console enabled.  
Step  2 In the Java console, locate the path for the TrustStoreHelper 

 
Step  3 On the host, import the CA root certificate into the cacerts file identified in the previous step.  The default 

password for most cacerts files is “changeit”.  

keytool -keystore cacerts -importcert -alias myca -file myfile 

where: myfile represents the CA root certificate (i.e. root.cer) 

 
Step  4 Launch the SMC java client.   
 

SMC Client Example 
To launch the SMC java client successfully, import the CA root certificate into the cacerts file, and install the (JDK) 
Java Development Kit on your PC. 

Step  1 Download and install the Oracle Java Development Kit 
Step  2 Include the JDK in your path 
Step  3 Enable Java Console to appear 

All Programs->Java->Configure Java->Advanced->Java Console->Show Console->Apply->OK 
Step  4 Type the following to import (CA root.cert) caroot.cer into the cacerts file: 

 
C:\Program Files\Java\jre1.8.0_66\lib\security>path=c:\program files\java\jdk1.8 
.0_66\bin 
 
C:\Program Files\Java\jre1.8.0_66\lib\security>keytool.exe -keystore cacerts -im 
portcert -alias myca -file caroot.cer 
Enter keystore password:changeit 
Owner: CN=lab9-WIN-I82PDH1PNGR-CA, DC=lab9, DC=com 
Issuer: CN=lab9-WIN-I82PDH1PNGR-CA, DC=lab9, DC=com 
Serial number: 913b274e6a35ea34efcdf6dadfe4f0e 
Valid from: Tue Dec 01 19:52:35 GMT-05:00 2015 until: Tue Dec 01 20:02:35 GMT-05 
:00 2020 
Certificate fingerprints: 
         MD5:  FD:26:D1:E0:FA:C5:31:79:DC:5A:1E:BA:DD:91:03:D7 
         SHA1: 22:2A:22:11:3A:00:50:67:AD:83:85:80:A9:41:25:4A:DE:C0:91:2A 
         SHA256: 98:8E:A1:63:AB:C6:22:2B:50:A7:4A:25:77:03:84:E9:9E:95:B7:E8:45: 
86:5F:58:77:04:42:D2:A3:82:BB:71 
         Signature algorithm name: SHA256withRSA 
         Version: 3 
 
Extensions: 
 
#1: ObjectId: 1.3.6.1.4.1.311.21.1 Criticality=false 
0000: 02 01 00                                           ... 
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#2: ObjectId: 2.5.29.19 Criticality=true 
BasicConstraints:[ 
  CA:true 
  PathLen:2147483647 
] 
 
#3: ObjectId: 2.5.29.15 Criticality=false 
KeyUsage [ 
  DigitalSignature 
  Key_CertSign 
  Crl_Sign 
] 
 
#4: ObjectId: 2.5.29.14 Criticality=false 
SubjectKeyIdentifier [ 
KeyIdentifier [ 
0000: AB D9 CE DB CD 58 19 4A   42 A6 BF 68 7A 96 FF 91  .....X.JB..hz... 
0010: 1F 73 BC 67                                        .s.g 
] 
] 
 
Trust this certificate? [no]:  yes 
Certificate was added to keystore 
 
C:\Program Files\Java\jre1.8.0_66\lib\security> 

Step  5 Click->Launch SMC client 
You should see the following 
 

 
 
 
Step  6 You should see the following in the console 

Java Web Start 11.66.2.17 
Using JRE version 1.8.0_66-b17 Java HotSpot(TM) 64-Bit Server VM 
User home directory = C:\Users\jsmith 
---------------------------------------------------- 
c:   clear console window 
f:   finalize objects on finalization queue 
g:   garbage collect 
h:   display this help message 
m:   print memory usage 
o:   trigger logging 
p:   reload proxy configuration 
q:   hide console 
r:   reload policy configuration 
s:   dump system and deployment properties 
t:   dump thread list 
v:   dump thread stack 
0-5: set trace level to <n> 
---------------------------------------------------- 
Missing Application-Name manifest attribute for: https://smc-01.lab9.com/smc-client/app/guava.jar 
StealthWatch detected JRE version 1.8.0_66 
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2016-01-31 00:34:39,306 INFO  [LogManager] resource=jar:https://smc-01.lab9.com/smc-client/app/sw-manager-
client.jar!/com/lancope/sws/smcClient/log4j.xml 
2016-01-31 00:34:39,306 INFO  [LogManager] level=default 
2016-01-31 00:34:39,306 INFO  [SimpleSMCClient] https://smc-01.lab9.com/smc-client/app 
2016-01-31 00:34:39,311 INFO  [XMLBindings] jar:https://smc-01.lab9.com/smc-client/app/lc-
core.jar!/xml/bindings.xml 
2016-01-31 00:34:39,725 INFO  [XMLBindings] jar:https://smc-01.lab9.com/smc-client/app/sw-manager-
client.jar!/com/lancope/sws/smcClient/bindings.xml 
2016-01-31 00:34:40,230 INFO  [TrustStoreHelper] System CA trust store not found, or could not be opened with 
given password at:C:\Program Files\Java\jre1.8.0_66\lib\security\jssecacerts 
2016-01-31 00:34:40,240 INFO  [TrustStoreHelper] System CA trust store loaded from:C:\Program 
Files\Java\jre1.8.0_66\lib\security\cacerts 
Jan 31, 2016 12:34:40 AM java.util.prefs.WindowsPreferences <init> 
WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows 
RegCreateKeyEx(...) returned error code 5. 
2016-01-31 00:34:40,343 INFO  [JRMProxyInvocationHandler] /smc/public/openJrmService/getBannerMessage 
2016-01-31 00:34:41,195 INFO  [JRMProxyInvocationHandler] /smc/jrmService/userService/getUserProfile 
2016-01-31 00:34:41,352 INFO  [JRMProxyInvocationHandler] /smc/jrmService/objectService/get 
2016-01-31 00:34:41,459 INFO  [SMCClientObjectModel] added LObjectKey:{Domain:{143}} 
2016-01-31 00:34:41,460 INFO  [SMCClientObjectModel] added LObjectKey:{SMC:{0}} 
2016-01-31 00:34:41,460 INFO  [SMCClientObjectModel] added LObjectKey:{Domain:{143},CiscoISE:{162}} 
. 
. 
. 
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Using Self-Signed Certificates for SMC and ISE pxGrid node 
This section discusses using self-signed certificates for the StealthWatch SMC and the ISE pxGrid node. Self-signed 
certificates are primarily used for testing PoC (Proof of Concept).  The ISE pxGrid node is deployed in a stand-alone 
environment.  Please note that in ISE productional deployments, pxGrid will be a dedicated node. 

Configuring ISE 1.3/1.4 for Self-Signed certificates 
The ISE Identity certificate needs to be trusted, the public certificate needs to be exported into the ISE trusted system 
certificate store.  This is not required for ISE 2.0. 

Note: You may not have to perform this step in ISE 1.4; the ISE identity certificate may already be trusted. 

Step  1 Administration->System->Certificates->System Certificates->select the ISE Identity certificate and 
export 

 
Note: Export out the public certificate only, you can change the default certificate name. In these examples, the certificate name was changed to 

ise14.pem 

Step  2 Administration->System->Certificates->Trusted Certificates->Import->certificate file->enable Trust 
for authentication within ISE->Submit 

 

                  

Enabling pxGrid 
Enable pxGrid and persona, pxGrid services should start in ISE.  
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Step  1 Enable pxGrid persona under Administration->System->Deployment->Save 

                   

Step  2 Verify that the pxGrid services are enabled. Administration->pxGrid Services 

Note: this may take a minute, please verify that the pxGrid services are initializing, run “application status ise” on the ISE pxGrid node. 
If the services still do not come up, please export the ISE Identity certificate into the ISE Trusted System Certificate store. 

 

 
 
Step  3 Enable “Enable Auto Registration” 

Note:  If “Auto Registration” is not enabled, you will see the pxGrid client requests in the pending state. 

 

 
 
 

Configuring ISE 2.0 for Self-Signed certificates 
Note:  The ISE self-signed identity certificate is no longer required to be exported into the ISE certificate trusted store as in ISE 1.3 and ISE 1.4. 
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Step  1 Select Administration->System->Deployment, select the node->Edit->enable pxGrid 
 

                     
 
Step  2 Select Save  
Step  3 Verify that the published nodes appear under pxGrid Services and there is connectivity. 

Administration->pxGrid Services 

Note:  The published nodes may take a while to appear.  Verify that pxGrid services have started by running: sh application status ise on the ISE 
VM node. 

Step  4 Enable Enable Auto-Registration 
 

               

 
 
Step  5 Verify that you are connected to pxGrid 

 

 
                      

Exporting ISE Identity Certificate into SMC  
Step  1 Import ISE identity cert into SMC Certificate Authority Store. 
Step  2 Select Administration->System->Certificates->System Certificates 

You should see the following: 
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Step  3 Select the Default self-signed server certificate->Export the public certificate only. You can also rename 

the PEM filename to make it easier to work with. 
 

Step  4 Open the SMC, select Admin User->Administer Appliance->Configuration->Certificate Authority 
Certificates->browse and upload the ISE identity certificate from Step 3 

 

                   
 

 
Step  5 Name the certificate, in the example, ISESelfSignedCert.  Please note you must add a value, you can use 

underscores but no empty spaces. 
 

Step  6 Select->Add Certificate, you will receive a confirmation that the certificate has been added successfully. 
 
 
 
 
 
 
 

Creating Self Signed Certificates for SMC 
Here we create the self-signed certificates for the SMC, the pxGrid client.  You need to gain root access on the SMC. 

Note: These steps are documented on SMC->Help-Self-Signed Certificates 
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Step  1 Generate a private key for SMC, you will also be prompted for a passphrase to be used in later steps 

openssl genrsa –des3 –out selfsmc.key 2048 

     You should see the following: 

Generating RSA private key, 2048 bit long modulus 
.............................................................................................................
...............................................+++ 
.+++ 
e is 65537 (0x10001) 
Enter pass phrase for smc1.key: 
Verifying - Enter pass phrase for smc1.key: 
smc:~# 

 
Step  2 Generate the self-signed certificate request (CSR) 

openssl req -new -key selfsmc.key -out selfsmc.csr 

Note: All the field are required except for the challenge password [] and company name [] 

 
You should see the following: 

Enter pass phrase for selfsmc.key: 
You are about to be asked to enter information that will be incorporated 
into your certificate request. 
What you are about to enter is what is called a Distinguished Name or a DN. 
There are quite a few fields but you can leave some blank 
For some fields there will be a default value, 
If you enter '.', the field will be left blank. 
----- 
Country Name (2 letter code) [AU]:US 
State or Province Name (full name) [Some-State]:Maryland 
Locality Name (eg, city) []:Germantown 
Organization Name (eg, company) [Internet Widgits Pty Ltd]:Lancope 
Organizational Unit Name (eg, section) []:Engineering 
Common Name (e.g. server FQDN or YOUR name) []:smc.lab6.com 
Email Address []:jdoe@lancope.com 
 
Please enter the following 'extra' attributes 
to be sent with your certificate request 
A challenge password []: 
An optional company name []: 
smc:~# 

 
Step  3 Generate the self-signed certificate 

openssl x509 -req -days 365 -in selfsmc.csr -signkey selfsmc.key -out selfsmc.crt 

       You should see the following: 
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Signature ok 
subject=/C=US/ST=Maryland/L=Germantown/O=Lancope/OU=Engineering/CN=smc.lab6.com/emailAddress=jdoe@lancope.com 
Getting Private key 
Enter pass phrase for selfsmc.key: 
smc:~# 

Step  4 To decrypt the passphrase you typed earlier 

cp selfsmc.key selfsmc.key.org 
openssl rsa -in selfsmc.key.org -out selfsmc.key 

     You should see the following: 

Enter pass phrase for selfsmc.key.org: 
writing RSA key 
smc:~# 

Step  5 You should have the following in the /root/smc directory 

smc:~# ls 
selfsmc.crt  selfsmc.csr  selfsmc.key  selfsmc.key.org 
smc:~#  

The selfsmc.cert and selfsmc.key will be uploaded into the SMC under SSL certificates as Admin User 
 
Step  6 Copy the selfsmc.crt and selfsmc.key files over locally using SCP, please “Enabling SSH on a MAC” in 

Appendices for reference, if you receive connection refused when copying to your local PC. 
 
 
 
 
 
 
 
 
 
 
 

Upload self-signed certificates to SMC 
Here we upload the public certificate and private key pair of the self-signed certificate to SMC. 

Step  1 Select Admin User->Configuration->SSL Certificates->SSL Server Identity and upload selfsmc.crt 
and selfsmc.key->Upload Certificate 
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Step  2 Select Upload Certificate 
Step  3 You should see the certificate was uploaded successfully, and a restart is required. 
Step  4 Once the SMC services have started, log back in and add the client identity certificate 
Step  5 Select Admin User->Configuration->SSL Certificates->SSL Client Identities and upload selfsmc.crt 

and selfsmc.key->Upload Certificate 
 

                     
 
 
 
 
Step  6 Add the friendly name ->Upload Certificate 
Step  7 You should see the uploaded certificate under SSL client identities 
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Upload SMC Self-Signed certificate to ISE Trusted System Certificate Store 
Here we upload the SMC self-signed certificate into the ISE trusted system certificate store 
 
Step  1 Administration->System->Certificates->Trusted Certificates->Import the SMC self-signed 

certificate. Enable “trust for authentication within ISE and Submit 
                  

              
 
Step  2 You should see that SMC has registered to the ISE pxGrid node 
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Enabling Adaptive Network Control (ANC) 
This section discusses enabling Adaptive Network Control  (ANC) on ISE 1.4 and configuring the Authorization 
policy. ANC is formerly known as Endpoint Protection Service (EPS) in ISE 1.3.  This is not required in ISE 2.0 and 
above, and is automatically enabled.  However, the ISE quarantine authorization policy must be configured. 

Step  1 To enable ANC in ISE 1.4, Administration->System->Settings->Adaptive Network Control->Enable-
>Save 

 

                   
 
 
 
Step  2 To enable EPS in ISE 1.3, Administration->System->Settings->enable Service Status then Save 
 

                                    
 
Step  3 Policy->Policy Elements->Results->Authorization->Authorization Profiles->Add->Quarantine, enter 

Quarantine for Name->Submit 
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Step  4 Policy->Authorization->Exceptions and add the following: 
 

 
 
 
Step  5 Rule Name: ANC 
Step  6 New Condition Rule Add a new attribute value: Session:EPStatus:Equals:Quarantine 
Step  7 Permissions:Profiles:Standard:Quarantine 
Step  8 Click->Done->Save 
 
In ISE 2.0, you can create the following policy with a default Quarantined Systems SGT as defined below: 
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Testing using CA-signed certs 
In the following use case, an endpoint is quarantined/unquarantined. 

Step  1 From the SMC, select Network->Hosts and select the desired endpoint that you will want to quarantine 
 

 
 
Step  2 Select the endpoint and then “Quarantine” 
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Step  3 You should see that the quarantine request message was successfully sent. 
 

                  
 
 
Step  4 Select OK 
Step  5 From the ISE Operations select RADIUS Livelog view you should see that the endpoint has been 

quarantined 
 

 
 
Step  6 Next, let’s unquarantine the endpoint.  Select the endpoint, and then “Unquarantine”. 

Note: In ISE 2.0, there is no manual way to unquarantine the endpoint, this must be done through the SMC, or you can use the EPS unquarantine 
RESTFUL API.  There should be a future patch that will address this issue. 
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Step  7 You should see that the unquarantine message was successfully sent. 
 

 
 
Step  8 Select OK 
Step  9 From the ISE Operations select  RADIUS Livelog view, note the endpoint has been unquarantined 
 

 
 
 
Step  10 Note the pxGrid client live logs for the SMC, which indicates the time when the smc has subscribed to the 

EndpointProtection Service Capability to intiate the quarantine/unquarantine (ANC) Adaptive Network 
Control mitigation actions. 
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Testing Using Self-Signed Certs 
In the following use case, an endpoint is quarantined/unquarantined. 

Step  1 From the SMC, select the 192.168.1.9 host under Network->Host menu 
 

                 
 
 
Step  2 You should see the following: 
 

                   
 
 
 
 
 
 
 
 
 
 
 
 
 
Step  3 Select Quarantine, you should see the endpoint has been quarantined successfully 
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Step  4 Select OK 
Step  5 View the quarantined endpoint 
 

 
 
 
Step  6 To unquarantine the endpoint, select unquarantine from the SMC operations menu 
 

 
 
 
 
 
Step  7 You should see the unquarantine results successfully sent, select OK 
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Step  8 From the ISE menu, select Operations->RADIUS Livelog, you should see that the endpoint has been 

unquarantined 
 

 
 
Step  9 Note the smc pxGrid client Live Logs which indicate the times that the smc has subscribed to the 

EndpointProtectionService capability and performed the ANC quarantine/unquarantine mitigation actions. 
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References 
Other pxGrid documents can be found at: http://www.cisco.com/c/en/us/support/security/identity-services-
engine/products-implementation-design-guides-list.html 

• Deploying Certificates with pxGrid: using Self-Signed pxGrid client and self-signed ISE pxGrid node 
certificate 

• Deploying Certificates with pxGrid: Certificate Authority (CA) signed pxGrid client and self-signed ISE 
pxGrid node certificate 

• Deploying Certificates with pxGrid: Certificate Authority (CA) signed pxGrid client and CA-signed ISE 
pxGrid node certificate 

• Configure and Test Integration with Cisco pxGrid 

http://www.cisco.com/c/en/us/support/security/identity-services-engine/products-implementation-design-guides-list.html
http://www.cisco.com/c/en/us/support/security/identity-services-engine/products-implementation-design-guides-list.html
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Appendices 

Enabling SSH on MAC 
 
Step  1 Enable ssh on MC 

Johns-Macbook-Pro:Utilities jeppich$ sudo launchctl load -w /System/Library/LaunchDaemons/ssh.plist 
Johns-Macbook-Pro:Utilities jeppich$ 

Step  2 Copying files over from SMC to local PC 

Dddd smc:~# scp smc1.crt jeppich@10.0.0.5:/Applications/ise14_certs/ 
Password: 
smc1.crt                                      100% 1330     1.3KB/s   00:00     
smc:~# ls 
jeppich@10.0.0.5  smc1.crt  smc1.csr  smc1.key  smc1.key.org 
smc:~# scp smc1.key jeppich@10.0.0.5:/Applications/ise14_certs/ 
Password: 
smc1.key                                      100% 1675     1.6KB/s   00:00     
smc:~# 
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Troubleshooting 

Using pxGrid-Active Standby configuration 
There can only be two pxGrid nodes per ISE deployment.  Only one ISE pxGrid node can be active, check “application 
status ise” to see that you have the correct ISE pxGrid node active. 

SMC ANC Mitigation Error Message: Quarantine request failed to be sent to ISE 
Under Administration->pxGrid services assign the SMC registered client into EPS group 

No connectivity to pxGrid in ISE pxGrid node 
For Certificate Authority (CA)-signed certificates, ensure you have the root CA certificate in the ISE trusted system 
certificate store, and the ISE pxGrid node certificate in the ISE system certificate store.  The pxGrid client certificate 
must have an EKU of both client authentication and server authentication. 

For ISE self-signed certificates, the self-signed Identity certificate must be exported from the system certificate store 
and imported into the ISE trusted system certificate store.  This is not required in ISE 2.0 
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