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About This Document   

This document is for Cisco System Engineers, IBM Engineers, Partners, and Customers deploying the 

Cisco Identity Services Engine (ISE) Cisco Platform Exchange Grid (pxGrid) App v3.0+ for IBM the 

QRadar SIEM.    

The supported platforms are:  

• IBM QRadar - As per recommendations for python 3 (python 2 is end of support), this is 

supported on the following versions - 7.3.3 FP6, 7.4.1 FP2, and 7.4.2 or later. 

• Cisco ISE 2.4 and higher with latest patch (check latest recommended release for newest code). 

For this release, validation has been done with the following: 

• The ISE internal CA was used for generating the pxGrid certificates for the Cisco ISE pxGrid 

App. 

• Various tests with 7.3.3 FP7, 7.4.1 FP2 and 7.4.2, and ISE Version 2.4, 2.7, 3.0 (with latest 

patches). 

• Standalone and hybrid distributed deployments. 

It is also assumed that the reader is familiar with both IBM QRadar SIEM and Cisco ISE. 

 

This document provides the details of installing and configuring the Cisco ISE pxGrid App for the IBM 

QRadar SIEM. The Cisco ISE pxGrid App provides Dashboards for Passed Authentications, Failed 

Authentications, Devices, Compliances, TrustSec, Mobile Device Management (MDM), and Currently 

Assigned ANC Policies. 

Cisco Adaptive Network Control (ANC) mitigation actions can be taken directly from the Dashboards 

to quarantine endpoints according to an organization’s security policy. These ANC mitigations can 

also be enforced via IBM QRadar SIEM syslog events as long as the endpoint has been authenticated 

through ISE. 

The Cisco ISE pxGrid App contains an IBM QRadar pxGrid offense rule which is based on pxGrid 

RADIUS failure topic events. 

The contextual information can be obtained from the IP Address of syslog events as long as the 

endpoint has been authenticated through IS.

  

https://www.ibm.com/support/pages/node/6356547
http://cs.co/ise-guides
http://cs.co/ise-guides
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Solution Overview   

IBM® QRadar® SIEM detects anomalies, uncovers advanced threats, and removes false positives. It  

consolidates log events and network flow data from thousands of devices, endpoints, and applications 

distributed throughout a network. It then uses an advanced Sense Analytics engine to normalize and 

correlate this data and identifies security offenses requiring investigation. As an option, it can 

incorporate IBM X-Force® Threat Intelligence which supplies a list of potentially malicious IP addresses 

including malware hosts, spam sources, and other threats. QRadar SIEM is available on premises and in 

a cloud environment. 

Cisco Identity Services Engine (ISE) is a security policy management and identity access management 

solution. ISE provides centralized management by defining, issuing, or enforcing 802.1X authentications, 

guest access management, policies, posture, client provisioning, and TrustSec policies. The ISE session 

directory contains a wealth of information about the endpoint that is published by Cisco Platform 

Exchange Grid (pxGrid). 

ISE also simplifies access control and security compliance for wired, wireless, and VPN connectivity and 

supports corporate security policy initiatives such as BYOD. 

Cisco Platform Exchange Grid (pxGrid) enables multivendor, cross platform network system 

collaboration among parts of the IT infrastructure such as security monitoring and system detection, 

network policy platforms, asset and virtually configuration management identity and access management 

platforms and other IT solutions. pxGrid uses a pub/sub model to publish the contextual information 

received from ISE, and other security solutions will subscribe to this topic, providing more visibility into 

security operations. Other security solutions can use pxGrid to enforce their security policies.  
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Technical Details   

The Cisco ISE pxGrid App installs on an IBM QRadar SEIM instance as an IBM signed app. Once the app 

is installed, the Cisco ISE pxGrid App will be registered as a pxGrid client to the ISE pxGrid node and 

subscribe to topics and consume contextual information to populate the Dashboards and take Adaptive 

Network Control (ANC) mitigation actions. 

The following image is a single standalone ISE 3.0: 

• Go to Administration > pxGrid Services > Diagnostics > WebSocket. 
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The following image is for a distributed deployment of PAN, MNT, and 2 PSN/pxGrid Nodes on ISE 2.7: 

 

The Cisco ISE pxGrid app pxGrid client subscribes to the Session Directory, RADIUS failure, MDM 

endpoint, and ANC configuration Topics. 

The Session Directory topics consist of user contextual information, such as username, MAC address, IP 

Address, endpoint device, posture status and provides wired and wireless connection type information. 

Wired connection type information includes the NAS Port ID, NAS IP Address, NAS Port Type, Location, 

and Device Type attributes. Wireless connection type information includes WLAN, Calling Station ID, 

Called Station ID, NAS IP, Device Type, Location, and NAS Identifier attributes. 

The MDM topic consists of compliance and registration status and is dependent on having an external 

MDM solution configured in Cisco ISE. In this document, the Cisco Meraki Solution was used as the 

external MDM solution. The testing was done with ISE 2.4 initial release so only the compliance and 

registration status attributes were available. In later releases of Cisco ISE after 2.4, the MDM attributes 

are available as follows: Manufacturer, UDID, Serial Number, Encryption Status, Jail Broken Status, Pin 

Lock Status. 

The RADIUS failure topic includes failure reason attributes, such as "invalid password" and drill downs 

based on location and wired/wireless connection types. 

The Config ANC Status Topic provides the Cisco ISE pxGrid client app to perform ISE Adaptive Network 

Control (ANC) mitigation actions on the endpoints. 

The Cisco ISE pxGrid App uses pxGrid 2.0, which uses WebSocket, REST API, and STOMP messaging 

protocol for pxGrid operation and thus supported since Cisco ISE 2.4.
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Cisco ISE pxGrid Installation   

Make sure that you have installed Cisco Identity Services (ISE) 2.4 or higher and it is in a standalone 

deployment (also supports other deployment methods). If this is a production ISE deployment, ensure 

the Cisco ISE pxGrid node is on a dedicated node. See the pxGrid section of ISE Guides for more 

information. 

At minimum, it is recommended to have two standalone nodes for HA purposes. Both nodes would be 

running all personas, including pxGrid. Depending on the number of clients and architecture 

requirements, you may expand into other architecture designs. Please consult with your ISE integrator on 

recommended deployment model. 

 Go to Administration > System Deployment > Edit the ISE node > Enable pxGrid. 

This image is for ISE 2.7. For ISE 3.0, the image doesn’t fit well on a screen. You would need to 

scroll down to the bottom and enable pxGrid. 

 

 

https://www.cisco.com/c/en/us/support/docs/security/identity-services-engine/216120-ise-security-ecosystem-integration-guide.html#anc31


SECURE ACCESS HOW-TO GUIDES 

Cisco Systems © 2021 Page 9 

 

 

 
 

  

  

 

 Select Save. 

You should see the following (ISE 3.0): 

 

Recommended Distributed deployment example (ISE 2.4+): 
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 Select Administration > pxGrid Services > Summary. 

Verify that the published nodes appear. All nodes running pxGrid will have a fanout & pubsub. 

 In ISE 3.0, you may see services not available. This is fixed in patch 3. 

The screenshot below shows that 1 pxGrid client is connected (this is a current setup with 

another vendor that we are showcasing with 5 pubsub connections (internally and to 1 client).  
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 Select Web Clients (Diagnostics > WebSockets in ISE 3.x) and verify that the published nodes 

appear: 

 This is validating pxGrid 2.0 connections. You should see that admin, mnt, and pxGrid 

nodes have connections with each other. They should all be ON. This is from a 4-node 

deployment. 
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Generating the Cisco ISE pxGrid App Certificate   

A certificate for the Cisco ISE pxGrid App will be generated from the ISE internal CA so the App will 

register and connect to the ISE pxGrid node. If you are using an external CA server for pxGrid 

operation, please see pxGrid section of the ISE Guides. 

For more information on certificates, please refer to this section under cs.co/ise-guides. 

 

 Select Administration > pxGrid Services > Certificates (ISE 2.4+) or Administration > pxGrid 

Services > Client Management > Certificates (ISE 3.x). 

You should see the following: 

 

 Type the following: 

It is recommended to use the full name of the server ex: qradar.securitydemo.net. 

  

https://www.cisco.com/c/en/us/support/docs/security/identity-services-engine/216120-ise-security-ecosystem-integration-guide.html#anc31
https://www.cisco.com/c/en/us/support/docs/security/identity-services-engine/216120-ise-security-ecosystem-integration-guide.html#anc52
https://cs.co/ise-guides
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 This is the IP address and FQDN of your QRadar system. You are generating a 

certificate here to install on QRadar app so it can present when communicating with ISE. 

I want to: Generate a single certificate (without a certificate signing request) 

Common Name (FQDN): qradar.securitydemo.net 

Description: QRadar 

Certificate Template: Pxgrid_Certificate_Template 

Subject Alternative Name (IP Address): 10.1.100.27 

Subject Alternative Name (FQDN): qradar.securitydemo.net 

Certificate Download Format: Certificate in Privacy Enhanced Mail (PEM) format, key in PKCS8 

PEM format including certificate chain  

Certificate Password: xxxxxxxx  

Confirm Password: xxxxxx 

 Select Create. 

This will create a zipped file 1520701037382_cert.zip. 

 Make sure your browser pop-up blocker is disabled when generating certificates. 

 Unzip the file, you will see the following files: 

 Keep the original zip, we are exporting here to just look at the contents and discuss the 

certificate. However, the QRadar App is able to import the zip package with its key as 

well. 

 

The QRadar identity certificate consists of the public private key-pair: 
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qradar.securitydemo.net_qradar.securitydemo.net.cer 
qradar.securitydemo.net_qradar.securitydemo.net.key 

The CertificateServicesRootCA-ise_.cer is the ISE internal Root CA certificate. 

Depending on your setup, you may have certificates being used for different ISE personas in your 

environment. If pxGrid is not assigned to the local Certificate services endpoint, as seen below, then 

make sure that you export the root certificate chain that was used to sign it. For example, if you have ISE 

signed up an external identity source. 

Don’t assign pxGrid to the self-signed certificate of ISE. This is not the best practice. If it moves pxGrid 

back to the Certificate Services Endpoint Sub CA as you can see in the image below. If for some reason 

you need this, then you will need to manually export this certificate and upload as package with the 

internal CA generated cert and key to QRadar and choose that as the root. The relevant certificates from 

the internal CA won’t matter even though they are in the package. 

In the following example, the pxGrid certificate is signed by the same ISE internal CA. When ISE 

communicates to QRadar system, it will present this as part of the communication. When you generate 

the certificate on ISE in the above steps, it gives you a package that includes the certificate chain from 

ISE internal CA. When QRadar talks to ISE, its certificate is automatically accepted because ISE is aware 

of the certificates it issues and the associated certificate chain. 
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Installing Cisco ISE pxGrid App   

In this section, you will learn how to install the Cisco ISE pxGrid App. 

To download the app, please visit the IBM App Exchange. 

 

If user is upgrading the Cisco ISE pxGrid QRadar App, we recommend users to uninstall the old app and 

install the latest version. 

To uninstall the old app: 

 Go to Admin > System Config > Extensions Mgmt. 

 Select Cisco ISE pxGrid, and then click Uninstall. 

 

  

https://exchange.xforce.ibmcloud.com/hub/extension/6091fd93042043212fd2494fe97ff5b7
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Install the extension: 

 In IBM QRadar, select Admin > Extensions Management.  

 

 Click Add a New Extension, upload the signed Cisco ISE pxGrid App, and select the Install 

Immediately checkbox. 
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 If asked the following, select the Replace option to install new components, and click 

Install at the very bottom. 

 

Next you may see this: Click OK. 

 

 After installation, you should see the following: 

 This is showing an exclamation as we were testing with an unsigned copy before 

posting to IBM app exchange. 

 

 Clear the browser cache, close the browser, launch the app, and login again. 

 Configure the logging IP address for the primary/secondary nodes: 

 On QRadar, in the upper-left corner, click the hamburger.  

 Navigate to Admin > Data Sources > Events > Log Sources.  
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 Change your log source identifiers QRadar 7.3 (see 7.4 below this section). 

Choose Name > pxGrid_Primary/pxGrid_Secondary. 

Edit and change the Log Source Identifier to corresponding ISE IP for Primary and 

Secondary accordingly. 

You may disable the secondary if you don’t need it . 

 

 

 

 



SECURE ACCESS HOW-TO GUIDES 

Cisco Systems © 2021 Page 19 

 

 

 
 

  

  

 

 Change your log source identifiers for QRadar 7.4. 

• The app opens in a new window. 

• Choose Log source type to filter on pxGrid. 

 

• Change the primary and secondary log source identifier. 

• Click on the primary, edit, and then choose protocol. Change Primary to actual ISE pxGrid node 

IP, and then click Save. 

 Do the same for the secondary. If one is not used, then disable the toggle slider as in 

the image above. 
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• Close the edit window, and then the second browser tab. 

 Configure the Authorized Services in QRadar: 

 Select Admin > System Configuration > User Mgmt > Authorized Services. 

 

 Add Authorized Service: 

• In the Service name box, enter pxGridService. 

• In the User Role and Security Profile dropdown lists, select Admin (default). 

• Select the No Expiry checkbox. 
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 Click Create Service. 

 Copy the authentication token into the notepad. 

 

 This is later used for Cisco ISE pxGrid App for pxGrid integration. 

 Close the Authorized Service browser window. 

 Make sure to deploy changes at this point. 
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Configuring pxGrid Integration on QRadar 

Setup pxGrid settings: 

 Select Admin > Apps > Cisco ISE pxGrid > pxGrid Settings. 

 

 Copy and paste the authentication token into the QRadar Service Token Window. 

 

 When going through the setup, you will notice the following message at the bottom of 

the app. This is due to the config not being completed. You won’t see it change to 

green until all configuration is completed and polling is done via HealthAuditLog. 

 If you continue to see this after putting all the settings in and ISE shows Enabled then 

clear your browser cache to refresh. 

 

 Enter the QRadar Event collector (EC) IP / QRadar Console IP (If EC is not available).  
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 Select Save & Continue, this will move you to the ISESettings tab. 

 Select Primary and type the IP address of the ISE pxGrid node. 

 Leave 8910 as the default port. 

 Enter the Client username (for example, QRadar App). 

 This will be the unique registered pxGrid client name displayed on ISE. 

 Select the certificate format type. You can choose between PEM or Pkcs12(.p12). 

 You may upload the zip package you generated from ISE certificate services (ISE internal CA); 

otherwise, if you’re using your own internal PKI, you can upload all (selecting al l  in the 

browse windows at once) the Cisco ISE pxGrid App certificates in the PEM format under 

Select and Upload Certificates (only PEM is supported) application settings page. 

CertificaeServicesEndpointSubCA-ise24k_.cer  
CertificateServicesNodeCA-is24k_.cer  
CertificateServicesRootCA-ise24k_.cer  
ise24k.lab10.com_.cer  
qradar.lab10.com_qradar.lab10.com.cer  
qradar.lab10.com_qradar.lab10.com.key 

 Choose the Cisco ISE pxGrid App Certificate file name: 

qradar.lab10.com_qradar.lab10.com.cer. 

Choose the Cisco ISE pxGrid App Certificate key file name: 

qradar.lab10.com_qradar.lab10.com.key. 

Choose the Cisco ISE Internal Root Certificate Root CA certificate file name: 

qradar.lab10.com_qradar.lab10.com.cer. 
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Enter the certificate pass phrase.  

You will see the following if PEM format is selected: 

 

When working with certificates, you must understand where the certificate was issued for your pxGrid 

nodes. Here are some criteria: 

• On any ISE deployment, you could have multiple certificates for different roles personas.  

• The admin node with an internal PKI certificate so that your admin machines with the root trust 

them. 

• Portals for guest services would likely have a well-known certificate so that any client coming in 

off the street can trust the portal. 

• Your pxGrid node will likely be side either by ISE internal CA or a well-known certificate root, 

depending on how you certificate trust is set up. Carefully choose your Root in the setup 

settings. 

• All nodes running pxGrid should have the same root. 

• See more about certificates at ISE Guides page for certificates and ISE 2.7 Certificate Section of 

Admin Guide. 
 

  

https://community.cisco.com/t5/security-documents/ise-security-ecosystem-integration-guides/ta-p/3621164#toc-hId--1761730573
https://www.cisco.com/c/en/us/td/docs/security/ise/2-0/admin_guide/b_ise_admin_guide_20/b_ise_admin_guide_20_chapter_0111.html
https://www.cisco.com/c/en/us/td/docs/security/ise/2-0/admin_guide/b_ise_admin_guide_20/b_ise_admin_guide_20_chapter_0111.html
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At the bottom of the page, select Save and Continue. 

 

You will be provided with a message to approve client connection. You can ignore if auto 

approve is enabled. Steps to approve client connection in provided below. 

 

Administration > pxGrid Services > Settings (ISE 3.x) 

Administration > pxGrid > Settings (ISE 2.4+) 

 

 

Let’s allow the connection manually: 

Admin > pxGrid Services > Client Management (ISE 3.x), and click to Approve the qradarapp. 

Admin > pxGrid Services > All Clients (ISE 2.4+), click Approve all. 
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Navigate back to the QRadar ISE pxGrid app ui and refresh the policy list UI. Either create or 

select the policies you want to use in your environment. Click Save. 

 

Validate the HealthAuditLog in the app. Notice it shows enabled as the last status. This may 

take a bit to update the polling. Perhaps 1-2 min. There is Refresh and Poll now. 

On clicking the refresh button, the latest status of the node will be read from the internal App Db and 

updated on the table, by default the page refreshed every 5 min. 

The Poll now button will send a request to the nodes to poll the status of the node. 

You may now close the app window. 
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Validate the pxGrid client on ISE: 

 In ISE 2.4+ On the All Clients tab, the Client Status can be Offline (XMPP). This is for 

pxGrid 1.0 and doesn’t represent any value. ISE 3.0 shows XMPP and WebSockets 

screens. 

Admin > pxGrid Services > Web Clients (2.4+). 

Admin > pxGrid Services > Diagnostics > WebSocket (3.0) and see registered Cisco ISE 

pxGrid QRadar app client. 

 If you do not see the pxGrid registered client, ensure the ISE pxGrid QRadar app client is 

using Fully Qualified Domain Name (FQDN). 
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You will see the client connected twice if there are two pxGrid (primary/secondary) nodes. Only 

one entry for single pxGrid nodes.Assign the QRadar client to the ANC Group permissions: 

 Select All Clients (Admin > pxGrid Services > Client Management > Clients (ISE 3.x) > Check 

the QRadar Client. 

 Go to Group > Add > ANC. 

 Click Save. 

 

 You should see the pxGrid client Group ANC assigned to the Cisco ISE pxGrid client, 

the below image is of ISE 3.x (above is 2.x). 
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Setup Indexing in QRadar  

Following are the steps to Index CEPs in QRadar. 

 Return to the IBM QRadar Web Console. 

 Navigate to Admin tab, and then click Index Management. 

       

 To setup the Indexes for use with pxGRid: 

 Search for pxgrid indexes: in the upper-left corner, enter pxgrid into the search window, and 

then search. 

 

 Sort by Property: 

 

 To Index the CEPs Packaged with the app, right-click on the property name, and then Enable 

Index. 

Recommended CEPs to be indexed are the following: 

• pxGrid_adNormalizedUser 
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• pxGrid_auditSessionId 

• pxGrid_EventName 

• pxGrid_macAddress 

• pxGrid_nasPortType 

• pxGrid_src 

 Click Save. 
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App installation on QROC  

Cisco pxGrid QRadar App is certified ‘QRadar on cloud ready’  by IBM. 

The following image shows data sources on your network that send information to your gateway 

appliance. The gateway appliance then communicates with an instance of QRadar that is running in 

the IBM cloud. 

 

The pxGrid QRadar App installation on QROC is very similar to the QRadar enterprise . 

NOTE: Use the QRadar® on Cloud Self Serve app to perform administrative tasks that are related to the 

provisioning and configuration of your QRadar on Cloud instance. The Self Serve app is installed on all QRadar on 

Cloud Consoles by default. 

Log on to the QRadar console(QROC) from a web browser to install and access Cisco ISE pxGrid QRadar 

App, just as you would with QRadar deployed on your premises. 

Step 1: Follow all the steps under the section “Generating the Cisco ISE pxGrid App Certificate” to 

download the certificates but ensure to use the Data Gateway IP and FQDN instead of QRadar 

console details. 

Step 2: Follow all the steps under the section “Installing Cisco ISE pxGrid App”  to install the app on 

QROC. 

 

https://www.ibm.com/docs/en/qradar-on-cloud?topic=started-self-serve-app
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A  QRadar cloud user should ensure, that both the ISE Nodes IPs should be  whitelist on data gateway. 

This can be directly done in QROC UI with the help of “Self-serve app” provided by default in QROC. 

Allowlisting an IP address 

Performing the below steps should whitelist ISE server and allow communication between ISE Server 

and QROC. 

Users can allowlist an IP address by adding the classless inter-domain routing (CIDR) value to the Allowlist 

Management page. Here user should allowlist the ISE IP here. 

1. Open the Admin settings and click QRadar on Cloud Self Serve. 

2. Click Allowlist Management. 

3. Click Add. 

4. Enter the CIDR. 

5. Click Save. 

6. Click Submit, and then click Confirm 

Refer here for more details. 

If the communication is still not ON, whitelist 8910 (pxGrid Service) port as well. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

file:///C:/Users/Jabez%20Daniel/Downloads/CiscoISEpxGridApp3.0.0_v1.0.docx/Aujas-my.sharepoint.com/personal/jabez_daniel_aujas_com/_layouts/15/onedrive.aspx
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Cisco ISE pxGrid App Dashboard Panels   

The dashboards and panels are populated with contextual information from ISE via pxGrid. This 

contextual information includes:  

•  Security or network admin visibility into who is connecting to the network and how they are 

connecting 

•  Type of devices connecting to the network, how they are connecting, and the owners of 

these devices  

• Users’ compliance with the organization’s security policy 

• Data on the incorporation of Bring Your Own Device (BYOD) security polices within the 

organization and whether they include external Mobile Device Management (MDM) vendors 

The dashboards and panels are designed or provide investigative insight across the entire organization 

or by connection-type such as wired or wireless. These dashboards include: Passed Authentications, 

Failed Authentications, Devices, Compliance, MDM, TrustSec, and Currently Assigned ANC policies. 

The admin can also take ISE ANC mitigative actions on the endpoint through these all QRadar ISE 

pxGrid App dashboards, except for TrustSec and Currently Assigned ANC Dashboards under ANC 

Details. 

Tab Name Description Search Criteria 

P
a
s
s
e
d

 A
u
th

e
n
ti
c
a
ti

o
n
s
 

User All Top ten users with passed 

auth 

▪ Select by 

pxGrid_adNormalizedUser 

▪ pxGrid_EventName as User 

Sessions 

Wired Top ten Wired users with 

passed auth 

▪ Select by 

pxGrid_adNormalizedUser 

▪ pxGrid_EventName as User 

Sessions 

▪ pxGrid_nasPortType as Ethernet 

Wireless Top ten Wireless users with 

passed auth 

▪ Select by 

pxGrid_adNormalizedUser 

▪ pxGrid_EventName as User 

Sessions 

▪ pxGrid_nasPortType as Wireless 
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Tab Name Description Search Criteria 

VPN Top ten VPN users with 

passed auth 

▪ Select by 

pxGrid_adNormalizedUser 

▪ pxGrid_EventName as User 

Sessions 

▪ pxGrid_nasPortType as Virtual 

WebAuth Top ten WebAuth 

(MAB+Guest) users with 

passed auth 

▪ Select by pxGrid_username  

▪ pxGrid_EventName as User 

Sessions 

▪ pxGrid_radiusFlowType as 

wiredMAB or wirelessMAB 

▪ pxGrid_username as a valid 

name, not MAC ID 

Device All Top ten endPointProfile ▪ Select by pxGrid_endPointProfile 

▪ pxGrid_EventName as User 

Sessions 

Wired Top ten Wired 

endPointProfile 

▪ Select by pxGrid_endPointProfile 

▪ pxGrid_EventName as User 

Sessions 

▪ pxGrid_nasPortType as Ethernet 

Wired 

Dot1x 

Top ten Wired Dot1x 

endPointProfile 

▪ Select by pxGrid_endPointProfile 

▪ pxGrid_EventName as User 

Sessions 

▪ pxGrid_nasPortType as Ethernet 

▪ pxGrid_serviceType as Framed 

Wired 

MAB 

Top ten Wired MAB 

endPointProfile 

▪ Select by pxGrid_endPointProfile 

▪ pxGrid_EventName as User 

Sessions 

▪ pxGrid_nasPortType as Ethernet 

▪ pxGrid_serviceType as Call 

Check 

Wireless Top ten Wireless 

endPointProfile 

▪ Select by pxGrid_endPointProfile 

▪ pxGrid_EventName as User 

Sessions 

▪ pxGrid_nasPortType as Wireless 

Wireless 

Dot1x 

Top ten Wireless Dot1x 

endPointProfile 

▪ • Select by 

pxGrid_endPointProfile 

▪ pxGrid_EventName as User 

Sessions 

▪ pxGrid_nasPortType as Wireless 

▪ pxGrid_serviceType as Framed 
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Tab Name Description Search Criteria 

Wireless 

MAB 

Top ten Wireless MAB 

endPointProfile 

▪ Select by pxGrid_endPointProfile 

▪ pxGrid_EventName as User 

Sessions 

▪ pxGrid_nasPortType as Wireless 

▪ pxGrid_serviceType as Call 

Check 

VPN Top ten VPN 

endPointProfile 

▪ Select by pxGrid_endPointProfile 

▪ pxGrid_EventName as User 

Sessions 

▪ pxGrid_nasPortType as Virtual 

WebAuth Top ten WebAuth 

(MAB+Guest) 

endPointProfile 

▪ Select by pxGrid_endPointProfile 

▪ pxGrid_EventName as User 

Sessions 

▪ pxGrid_radiusFlowType as 

wiredMAB or wirelessMAB 

▪ pxGrid_username as a valid 

name, not MAC ID 

F
a
il
e
d

 A
u
th

e
n
ti

c
a
ti

o
n
s
 

User All Top ten users with failed 

auth 

▪ Select by pxGrid_username 

▪ pxGrid_EventName as Radius 

Failure 

Wired Top ten Wired users with 

failed auth 

▪ Select by pxGrid_username 

▪ pxGrid_EventName as Radius 

Failure 

▪ pxGrid_nasPortType as Ethernet 

Wireless Top ten Wireless users with 

failed auth 

▪ Select by pxGrid_username 

▪ pxGrid_EventName as Radius 

Failure 

▪ pxGrid_nasPortType as Wireless 

VPN Top ten VPN users with 

failed auth 

▪ Select by pxGrid_username 

▪ pxGrid_EventName as Radius 

Failure 

▪ pxGrid_nasPortType as Virtual 

WebAuth Top ten WebAuth 

(MAB+Guest) users with 

failed auth 

▪ Select by pxGrid_username 

▪ pxGrid_EventName as Radius 

Failure 

▪ pxGrid_radiusFlowType as 

wiredMAB or wirelessMAB 

▪ pxGrid_username as a valid 

name, not MAC ID 
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Tab Name Description Search Criteria 

Failure 

reasons 

All Top ten Failure reason with 

failed auth 

▪ Select by pxGrid_failureReason 

▪ pxGrid_EventName as Radius 

Failure 

Wired Top ten Failure Reason for 

wired user with failed auth 

▪ Select by pxGrid_failureReason 

▪ pxGrid_EventName as Radius 

Failure 

▪ pxGrid_nasPortType as Ethernet 

Wireless Top ten Failure Reason for 

wireless user with failed 

auth 

▪ Select by pxGrid_failureReason 

▪ pxGrid_EventName as Radius 

Failure 

▪ pxGrid_nasPortType as Wireless 

VPN Top ten Failure Reason for 

VPN users with failed auth 

▪ Select by pxGrid_failureReason 

▪ pxGrid_EventName as Radius 

Failure 

▪ pxGrid_nasPortType as Virtual 

WebAuth Top ten Failure Reason for 

WebAuth (MAB+Guest) with 

failed auth 

▪ Select by pxGrid_failureReason 

▪ pxGrid_EventName as Radius 

Failure 

▪ pxGrid_radiusFlowType as 

wiredMAB or wirelessMAB 

▪ pxGrid_username as a valid 

name, not MAC ID 

Auth 

Type 

All Top ten deviceType by 

Failed Auth with failed auth 

▪ Select by pxGrid_deviceType 

▪ pxGrid_EventName as Radius 

Failure 

Wired Top ten deviceType for 

Wired users with failed auth 

▪ Select by pxGrid_deviceType 

▪ pxGrid_EventName as Radius 

Failure 

▪ pxGrid_nasPortType as Ethernet 

Wireless Top ten deviceType for 

Wireless users with failed 

auth 

▪ Select by pxGrid_deviceType 

▪ pxGrid_EventName as Radius 

Failure 

▪ pxGrid_nasPortType as Wireless 

VPN Top ten deviceType for 

VPN users with failed auth 

▪ Select by pxGrid_deviceType 

▪ pxGrid_EventName as Radius 

Failure 

▪ pxGrid_nasPortType as Virtual 

WebAuth Top ten deviceType 

WebAuth (MAB+Guest) 

users with failed auth 

▪ Select by pxGrid_deviceType 

▪ pxGrid_radiusFlowType as 

wiredMAB or wirelessMAB 
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Tab Name Description Search Criteria 

▪ pxGrid_username as a valid 

name, not MAC ID 

Location All Top ten locations with failed 

auth 

▪ Select by pxGrid_location  

▪ pxGrid_EventName as Radius 

Failure 

Wired Top ten locations of Wired 

users with failed auth 

▪ Select by pxGrid_location  

▪ pxGrid_EventName as Radius 

Failure 

▪ pxGrid_nasPortType as Ethernet 

Wireless Top ten locations of 

Wireless users with failed 

auth 

▪ Select by pxGrid_location  

▪ pxGrid_EventName as Radius 

Failure 

▪ pxGrid_nasPortType as Wireless 

VPN Top ten locations of VPN 

users with failed auth 

▪ Select by pxGrid_location  

▪ pxGrid_EventName as Radius 

Failure 

▪ pxGrid_nasPortType as Virtual 

WebAuth Top ten location of 

WebAuth (MAB+Guest) 

users with failed auth 

▪ Select by pxGrid_location  

▪ pxGrid_EventName as Radius 

Failure 

▪ pxGrid_radiusFlowType as 

wiredMAB or wirelessMAB 

▪ pxGrid_username as a valid 

name, not MAC ID 

Compliance 
All Top ten postureStatus ▪ Select by pxGrid_postureStatus 

Wired Top ten postureStatus of 

Wired users 

▪ Select by pxGrid_postureStatus 

▪ pxGrid_nasPortType as Ethernet 

Wired 

MAB 

Top ten postureStatus of 

Wired MAB users 

▪ Select by pxGrid_postureStatus 

▪ pxGrid_nasPortType as Ethernet 

▪ pxGrid_serviceType as Call 

Check 

Wireless Top ten postureStatus of 

Wireless users 

▪ Select by pxGrid_postureStatus 

▪ pxGrid_nasPortType as Wireless 

Wireless 

MAB 

Top ten postureStatus of 

Wireles MAB users 

▪ Select by pxGrid_postureStatus 

▪ pxGrid_nasPortType as Wireless 

▪ pxGrid_serviceType as Call 

Check 
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Tab Name Description Search Criteria 

VPN Top ten postureStatus of 

VPN users 

▪ Select by pxGrid_postureStatus 

▪ pxGrid_nasPortType as Virtual 

T
ru

st
S

e
c
 

Group 

Tag 

All Top ten ctsSecurityGroup ▪ Select by 

pxGrid_ctsSecurityGroup 

Wired Top ten ctsSecurityGroup 

of Wired users 

▪ Select by 

pxGrid_ctsSecurityGroup 

▪ pxGrid_nasPortType as Ethernet 

Wired 

MAB 

Top ten ctsSecurityGroup 

of Wired MAB users 

▪ Select by 

pxGrid_ctsSecurityGroup 

▪ pxGrid_nasPortType as Ethernet 

Wireless Top ten ctsSecurityGroup 

of Wireless users 

▪ Select by 

pxGrid_ctsSecurityGroup 

▪ pxGrid_nasPortType as Wireless 

Wireless 

MAB 

Top ten ctsSecurityGroup 

of Wireles MAB users 

▪ Select by 

pxGrid_ctsSecurityGroup 

▪ pxGrid_nasPortType as Wireless 

VPN Top ten ctsSecurityGroup 

of vpn users 

▪ Select by 

pxGrid_ctsSecurityGroup 

▪ pxGrid_nasPortType as Virtual 

WebAuth Top ten ctsSecurityGroup 

of WebAuth (MAB+Guest) 

users 

▪ Select by 

pxGrid_ctsSecurityGroup 

▪ pxGrid_radiusFlowType as 

wiredMAB or wirelessMAB 

▪ pxGrid_username as a valid 

name, not MAC ID 

M
D

M
 

Compliance Top ten 

mdmComplianceStatus 

▪ Select by 

pxGrid_mdmComplianceStatus 

▪ pxGrid_EventName as User 

Sessions 

Registration Top ten 

mdmRegistrationStatus 

▪ Select by 

pxGrid_mdmRegistrationStatus 

▪ pxGrid_EventName as User 

Sessions 
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Search Functionality 

The Search tab is the first tab on the page where user can enter the search details. While clicking on the 

tab the search page should be displayed with a search box, dropdown to select the type of event 

(Session, Radius, or both) to search, and a date-picker adjacent. 

When the user enters text in the search box and clicks the Search’ button, the date field should be 

populated with the existing date range from the application window by default. The end users should be 

able to change its according to their needs. If the search returns more than 200 (TBD) records the user 

should get an acknowledgement saying "This search returns too many records" and displaying the first 

200 records. In such cases, the user should narrow down their search by using the event type filter and 

the minimum time span. 

In the search window, the user should be able to enter IP Address, MAC Address and Session ID. When 

the user clicks the search button, the results should be displayed in a tabular format with pagination. The 

result’s displayed format will be same as the current window displayed with details while clicking on the 

existing graph in dashboard. 

There should be an option (hyperlink) provided at the end of the table to view the raw event associated 

with the selected event. The request data from the UI should be validated for security and valid request 

format. 
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Accepted Search format: 

IP Address          X.X.X.X 

MAC Address     X:X:X:X 

Session ID          XXXX 

Partial Search Criteria: 

IP Address should begin with X. 

Mac Address should begin with X: 

Accepted Wildcard characters: 

Wildcard 

Character 

Description Example 

* Matches a string of zero or more 

characters 

*.*,*:*,192.*,192.168.*.*,AE:BC:* 

? Matches any single character 192.??.??.??,192.168.??.124,DE:??:DF:* 
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Passed Authentications 

The Passed Authentications dashboard view provides visibility into successful machine and user 

authentications across an organization and by wired and wireless connection type. This provides the 

admin with a view of how employees are connecting to the network, are they connecting over Wired, 

Wireless, VPN or Guest and where are they connecting from. This information is obtained from the 

Cisco ISE pxGrid App pxGrid client subscribing to the Session Directory topic. 

The admin drills down on the user or host and obtains the following contextual information: endpoint 

device information, MAC Address, IP Address, posture status, NAS Port Type, NAS Port ID, NAS 

Identifier, NAS IP Address, WLAN Information, Calling Station ID, Called Station ID, AD resolvable user 

and host identities. 

The AD resolvable user and host identities provide a consistent name format when different EAP 

methods are used, for example, EAP Chaining. 

For the WebAuth (guest & employee access) portion we show the credentialed authentication flow. 

We don’t show Hotspot (basic MAB).  

 

Go to Cisco ISE pxGrid > Passed Authentications. 
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 Select an end-user, this provides a tabular view of the following contextual information: 

 

The Endpoint Profile, Endpoint Operating System, and the AD Normalized User Name provide 

the endpoint information for the user. 
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The AD user Resolved Identities and AD User Resolved DNS provide the consistent identities 

of the end user. 

 

The Is Machine Authentication attribute determines if this is machine authentication or user 

authentication. If this attribute is set to "true", then this is machine authentication, if this is set 

to "false", then this is user authentication. 
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Devices 

The Devices Dashboard View provides the admin with visibility into the connected devices across the 

organization or by wired and wireless connection types. An organization may have a security policy 

about recommended or non-recommended devices for employees. The admin is able to drill down 

and see the owners of these devices and their location. This information is obtained from the Cisco ISE 

pxGrid App client subscribing to the Session Directory topic. 

The admin drills down on the endpoint profile and obtains the following contextual information: 

endpoint device information, MAC Address, IP Address, posture status, NAS Port Type, NAS Port ID, 

NAS Identifier, NAS IP Address, WLAN Information, Calling Station ID, Called Station ID, AD resolvable 

user and host identities. 

The AD resolvable user and host identities provide a consistent name format when different EAP 

methods are used, for example, EAP Chaining. 

Go to Cisco ISE pxGrid > Passed Authentications > Devices. 

 Select EndProfile (All) > Microsoft-Workstation. 
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The Username, IP address and MAC address attributes are associated with the device. 

The NAS IP, NAS Port ID and NAS Port Type attributes contain the connection type information. 

 

The NAS Identifier attribute may contain more information about the device such as the MAC address. 

The EndPoint Profile and Endpoint Operating System attributes provide the type of device and operating 

system. 
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The AD Username/Host and AD Resolved Username/Host identity attributes provide a consistent way 

of providing the username and hostname despite various EAP authentication types. 

 

The Is Machine Authentication attribute if set to "true" denotes that this is machine authentication. If it 

is set to "false", it denotes user authentication. 
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Failed Authentications 

The Failed Authentications dashboard view provides visibility into failed authentication attempts across 

the organization and by wired and wireless connection types. This provides the admin with a view of 

how these failed authentications occur with panel breakdowns by user, failure reason, device type, 

and location. This information is obtained from the Cisco ISE pxGrid client App subscribing to the 

RADIUS failure topic. 

The user panel provides a breakdown by user and provides the following contextual information: 

failure reason, device type, location, endpoint device information, MAC address, IP Address, posture 

status, NAS IP address, NAS Port Type, NAS Port ID, WLAN information, NAS Identifier, Calling Station 

ID, Called Station ID, access, identity store, and credit check. 

The other panels provide a breakdown by failure reason, device type and location, and provide the 

admin insight to how these failed authentications occur. The same contextual information from the 

user panel is available in these panel breakdowns. 

The AD resolvable user and host identities provide a consistent name format when different EAP 

methods are used, for example, EAP Chaining. 

User Panel 

The user panel provides a breakdown by username. 

Go to Cisco ISE pxGrid > Failed Authentications. 

 

 Go to Cisco ISE pxGrid > Failed Authentications > User > ScaleUser7. 

 The IP Address, Failure Reason, Username attributes provide information into failed 

authentication attempts. 
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The Server Name, Authentication Protocol, Device Type, Location, Calling Station ID, NAS IP Address, 

NAS Port ID, NAS Port Type attributes provide more authentication details and location information of 

failed authentication attempts. 

 

The Access Service attribute provide the ISE allowed protocol rules, the Identity Store attribute 

provides the back-end credential database of the end-user in question.  

The Authentication Method attribute provides the ISE authentication rule, and the Credit Check 

attribute provides the EAP authentication method. 

 

The AD Host/User Resolved Identities, AD Host/User Resolved DNS, AD User Domain, AD User Net 

BIOS Name Host attributes in the screenshots provide additional context around the host and user 

identities. 
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Failure Reason Panel 

The Failure Reason panel provides a breakdown by failure reason. 

 Go to Cisco ISE pxGrid > Failed Authentications. 

 Select Failure Reason > 24408 User authentication against Active Directory failed since user has 

entered the wrong password. 

 

The IP Address, Calling Station ID, Username attributes provide basic information for end users 

associated with failure reasons. 

 

The Server Name, Authentication Protocol, Device Type, Location, Calling Station ID, NAS IP Address, 

NAS Port ID, NAS Port Type attributes provide more authentication details and location information of 

failed authentication attempts. 
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The Access Service attribute provides the ISE allowed protocol rules, the Identity Store attribute 

provides the back-end credential database of the needed end user. 

The Authentication Method attribute provides the ISE authentication rule, and the Credit Check attribute 

provides the EAP authentication method. 

 

The AD Host/User Resolved Identities, AD Host/User Resolved DNS, AD User Domain, AD User Net 

BIOS Name Host attributes in the images provide additional context around the host and user identities. 

Auth Type Panel 

The Auth Type attribute categorizes the NAD device for Network Device Groups that may distinguish 

by different locations. For example, you may have Cisco Catalysts switches for the North America 

locations. 

To categorize device type: 

 Go to Cisco ISE pxGrid > Failed Authentications. 

 Select Device Type > All Device Types. 
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The IP Address, Calling Station ID, and Username attributes provide basic information for end users 

associated with failure reasons. 

 

The Server Name, Authentication Protocol, Device Type, Location, Calling Station ID, NAS IP Address, 

NAS Port ID, and NAS Port Type attributes provide more authentication details and location information 

of failed authentication attempts. 

 

The Access Service attribute provides the ISE allowed protocol rules, the Identity Store attribute 

provides the back-end credential database of the needed end user. 

The Authentication Method attribute provides the ISE authentication rule, and the Credit Check 

attribute provides the EAP authentication method. 
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The AD Host/User Resolved Identities, AD Host/User Resolved DNS, AD User Domain, AD User Net 

BIOS Name Host attributes in the screenshot provides additional context around the host and user 

identities. 

Locations Panel 

The location panel provides insight into attempted by failures by NAD location type and provides a 

drill-down based on Locations. 

 Go to Cisco ISE pxGrid > Failed Authentications. 

 Go to Location > All > All Location. 

 

 

The IP Address, Calling Station ID, Username attributes provide basic information for end users 

associated with failure reasons. 

 

The Server Name, Authentication Protocol, Device Type, Location, Calling Station ID, NAS IP Address, 

NAS Port ID, NAS Port Type attributes provide more authentication details and location information of 

failed authentication attempts. 
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The AD Host/User Resolved Identities, AD Host/User Resolved DNS, AD User Domain, and AD User Net 

BIOS Name Host attributes in the following screenshots provide additional context around the host and 

user identities. 
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Compliance 

The Compliance Dashboard provides the admin with ISE posture compliant or non-compliant devices 

across the organization or by wired or wireless connection type. The organization may have security 

policy for their employees such as ensuring that AV DAT files are up-to-date and AV services must be 

running for compliance. If either of these are not the case, then the end user is deemed non-

compliance. 

 Go to Cisco pxGrid > Compliance (All). 

 Go to Compliant. 

 

 

You will see a list of compliant end users along with the associated contextual information. 

The IP address, MAC address, Username, Calling Station ID and Posture Status attributes provide the 

basic user information. The NAS Port ID, NAS Port Type, NAS IP Address attributes contain the 

location and connection-type information. The State attribute determines the Postured Status. 
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The Posture Status attribute contains the value of the posture status, compliant, non-compliance, and 

pending. 

The Endpoint Profile attribute is the device information of the end user along with the Endpoint 

Operating System attribute. 

 

The AD Username/Host and AD Resolved Username/Host identity attributes provide a consistent way 

of providing the username and hostname despite various EAP authentication types. 

 

The Is Machine Authentication attribute if set to "true" denotes that this is machine authentication. If 

set to "false" denotes user authentication.
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TrustSec 

The TrustSec dashboard contains the Security Group Tag (SGT) Information for assigned end users.  

This provides the admin with visibility to see which end user is associated with a SGT. For example, a 

SGT of Quarantined Systems, will provide a view of end users who have been assigned this label. 

 Go to Cisco ISE pxGrid > Trustsec. 

 Select Group Tag (All.) 

 Select Quarantined Systems. 

 

 

This provides the end-user information associated with the SGT. Here we see the Username, IP 

Address, and MAC Address attributes.  We also see the NAS IP Address, NAS Port ID, and NAS Port 

type attributes to determine the location and connection type. 
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This also provides the Endpoint Profile, Endpoint Operating System and AD normalized user/host names 

and AD user/host FQDN identities attributes. 

 

The AD Username/Host and AD Resolved Username/Host identity attributes provide a consistent way 

of providing the username and hostname despite various EAP authentication types. 

 

The Is Machine Authentication attribute if set to "true" denotes that this is machine authentication. If set 

to "false" denotes user authentication. 
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Mobile Device Management (MDM) 

The MDM Dashboard provides the admin with the visibility to look into an organizations MDM security 

policy. In the ISE 2.4 initial release, only the registration and compliance status are available. 

 Go to Cisco ISE pxGrid > MDM. 

 Select Compliance. 

 

The Username, MAC Address, IP Address and Registration and Compliance Status attribute are 

available. 
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ANC Details 

The ANC Details Dashboard View provides visibility into the ANC policies currently assigned to 

endpoints MAC address. 

Go to Cisco ISE pxGrid > ANC Details. 
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Configuring Cisco ISE Adaptive Network Control Policies   

Cisco ISE Adaptive Network Control (ANC) Policies provide a means of enforcing an organization’s 

security policy by issuing a quarantine, port-bounce, or port-shut on the endpoint. When an endpoint 

is quarantined, this issues a Change of Authorization (CoA) and the endpoint is quarantined due to the 

organization’s security policy. The security policy may be just to monitor the traffic and take no action. 

In this case, a Security Group Tag (SGT) can be assigned. SGT are part of the Cisco TrustSec Solution 

and is used here for assigning labels to an organization’s security policy. As an example, Quarantined 

System SGT will be applied to an ANC quarantine policy to monitor and not enforce network access. 

Port-bounce will bounce the port the endpoint is connected, and user will be re-authenticated. 

Port-shut will issue a shutdown on the port the endpoint is connected. This is the most severe and 

may be issued if the endpoint is infected with malware and the malware is in suspect of propagating 

over file shares. 

These ISE ANC policies will be used by the Cisco ISE pxGrid app to enforce mitigation actions on the 

endpoints from either the Dashboard and Panels or through IBM QRadar system syslog events as long 

as the endpoint has been authenticated through ISE. 

The following Cisco ISE ANC policies will be created: 

• pxGridQRadarQuarantine - issues a quarantine 

• pxGridQRadarPortBounce - issues a port-bounce 

• pxGridQRadarShutDown - issues a shut down 

The Cisco ISE pxGrid app will read in the existing ISE ANC policies; however, these default ANC 

policies need to be configured first. Also, the Cisco ISE pxGrid app pxGrid client will need to be added 

to the pxGrid ANC Group. You will perform this exercise later, when configuring the Cisco ISE pxGrid 

for pxGrid integration. 
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Configuring Default ANC policies for Cisco ISE pxGrid App 

 

 Go to Operations > Adaptive Network Control > Policy List > Add > The following for the Policy 

Name and Action: 

pxGridQRadarQuarantine, QUARANTINE 

pxGridQRadarPortBounce, PORT_BOUNCE  

pxGridQRadatShutDown, SHUT_DOWN, 

 Select Save. 

After Policy Name and associated action, you should see the following: 
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Adding ANC Policies to ISE Policy Sets 

 Go to Policy > Policy Sets > Default > ">" > Authorization Policy > Global Exceptions > "+". 

 Under Rule Name, type: ANC Quarantine. 

 Under Conditions, select "+". 

 To close the introductory screen, select "x". 

 Under Dictionary, select Session > ANCPolicy > Equals > pxGridQRadarQuarantine. 

 Select Use. 

 Under Profiles, select Permit Access. 

 Under Security Groups, select Quarantine_Systems. 

 Select Save. 

Perform steps 1-9 for the Rule Name ANCShutDown and ANCPolicy pxGridQRadarShutDown. 
 

 You can also click on the Gear and duplicate line below and add the rule name and 

ANCPolicy. 

Perform steps 1-9 for the Rule Name ANCPortBounce and ANCPolicy pxGridQRadarPorBounce. 

 You can also click the Gear icon and duplicate line below and add the rule name and 

ANCPolicy. 

You should see the following: 
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Performing Cisco ISE ANC Mitigation Actions Through Cisco 
ISE pxGrid App Dashboard Panel   

This section steps the reader through performing ANC mitigation actions on the endpoint from the 

dashboards and panels. 

User pxGrid1 authenticates in ISE. 

 

 Go to Cisco ISE pxGrid > Passed Authentications. 

 

  



SECURE ACCESS HOW-TO GUIDES 

Page 65 Cisco Systems © 2021 Page 65 

 

 

 
 

  

   

 Select an end user, ScaleUser7, and then see the following: 

 

 Right-click on the IP address, and then see the ANC policies: 

 

 Select pxGridQRadarPortBounced. 

 You should see a successful status message: 

 

 Select OK. 
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 To view in ISE, select Operations > RADIUS LiveLogs. 

Based on the ANCQuarantine Policy, the endpoint has been quarantined: 

 

 To view the quarantine details in the Cisco ISE pxGrid App ANC Dashboard, go to Cisco ISE 

pxGrid > ANC Details. 

See an example of the MAC Address of the quarantined endpoint: 
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To view the details in the Cisco ISE pxGrid App TrustSec Dashboard, go to Cisco ISE pxGrid > 

Trusts. 

 

To see the quarantined endpoints, select Quarantined_Systems: 

 

To un-quarantine or clear the endpoint either in the Dashboards or directly in ISE. The 

endpoint wil l  be un-quarantined from this view. 

Right-click on the MAC Address: 
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Select pxGridQRadarClear. 

You should see successful status message: 

 

Select OK. 

To un-quarantine the endpoints and view the results in ISE, go to Operations > RADIUS > Live 

Logs.  
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Go to Cisco ISE pxGrid > ANC Details, you should see the endpoint is no longer assigned to the 

ANC policy: 
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Configuring IBM QRadar for Cisco ISE Syslog Events   

The IBM Device Support Module (DSM) for Cisco Identity Service Engine (ISE) Syslog is installed by 

default on QRadar. For more information on DSM (beyond the scope of this guide) visit the DSM guide. 

 

Configure log source on IBM QRadar. 

 Configure both primary and secondary MNT log sources in an HA environment. 

 Open the IBM QRadar Console. 

 Go to Admin > Data Sources > Log Sources. 

 

 Add in a new log source for Cisco ISE Syslog. 

Add a new log source >  Single Source > Source Type: Identity Services Engine. 

• Log Source Name and Description: Cisco_ISE 

• Log Source Type Cisco Identity Services Engine 

• Protocol Configuration: UDP Multiline Syslog 

• Log Source Identifier: IP Address of your ISE MNT node(s) 

• Listen port (leave default 517) 

• Message ID Pattern: CISE_\S+ (\d{10}) 

• Source Name Formatting String (researching) 

 For version 7.3, there will be a single screen configuration.  

ftp://ftp.software.ibm.com/software/security/products/qradar/documents/iTeam_addendum/b_dsm_guide.pdf
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 For QRadar 7.4, this will open a new application window and will take you through a 

guided configuration. 

 Select Save or Finish, close the new app window. 

 Select Deploy Changes > Deploy.
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Configuring Cisco ISE Syslog Events   

Cisco ISE will be configured to send syslog information to the IBM QRadar instance. Please make sure 

you have the QRadar ISE DSM installed. Future releases of the QRadar ISE DSM will include ISE syslog 

events such as Framed IP Address, IP address, where you can take ANC mitigation actions on the 

endpoint. 

Go to Administration > System > Logging > Remote Logging Targets. 

 Add in a new Remote logging target - Host/IP address of IBM QRadar instance:  

• Port – non-default 517 (QRadar UDP multiline listening port) 

• Maximum length of 8192 (to see complete logs instead of those truncated)  

• Include alarms for this Target (checked) 

 

 Select Submit/Save. 

 Configure Logging Categories: 

Choose AAA Audit element > Edit. 



SECURE ACCESS HOW-TO GUIDES 

Page 73 Cisco Systems © 2021 Page 73 

 

 

 
 

  

   

 

 Move QRadar from Targets Available into the Selected column. 

Don’t worry about the local logging checkbox, leave it alone. 

 

 Select Save. 
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 Perform previous steps for additional elements: Passed Authentications, Failed Attempts, 

Accounting, RADIUS Accounting, Administration and Operational Audit, Posture and Client 

Provisioning Audit, and Profile. 

 When completed, you should see elements with QRadar listed in the Targets column where 

appropriate. 
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Performing ISE ANC Mitigation Actions Through IBM QRadar 
Syslog Events   

The desired endpoints for performing ANC mitigation actions must have been authenticated through 

ISE. In this example, we have Cisco ISE Passed Authentication syslog events sent over to IBM QRadar.  

We have to create a custom FramedIPAddress field to provide the IP address of the endpoint. 

 

The FramedIPAddress field will be added to the available columns field in the Log Activity Search 

created for ISE. 

The FramedIPAddress field will now appear in ISE Log Activity searches. 

 

Creating Custom Field for Framed IP Address ISE Syslog Event 

In IBM QRadar, go toLog Activity > Search > New Search > Manage Groups.  

Create New Group > Cisco_ISE. 

You should see the Cisco ISE group: 
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 Close the Search groups page and select the newly created Cisco_ISE Group for Saved 

Searches. 

 

 Keep the Search defaults. 
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 Keep the column defaults. 

 

 Under Search Parameters > Parameter > Quick Filters. 

Go to Log Source (Indexed) > Equals > Log Source Filter > Cisco_ISE Add Filter. 
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 Click Search. 

 

 

 In the upper right corner, click Pause, and then double-click Passed Auth (wired) or 

Radius_Acct (wireless). 

 Click Extract Property and for New Property, then type: FramedIPAddress. 
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 For Field Type, type: IP. 

For Description, type: FramedIPAddress. 

For Extraction > RegEx > type: Framed-IP-Address=(\b\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\b). 
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You should see: 

 

Select Test. 

You should see: 
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Select OK. 

Select Save. 

Ensure the FramedIPAddress appeared: 

 

Select Return to Event List. 

Select Search > Edit Search > Saved Searches > Group: Cisco_IS. 

Scroll down to Column Definition > Available Columns > FramedIPAddress(Custom) > Move to 

columns by selecting ">". 
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Select Filter. Now, you should see the custom FramedIPAddress field:  
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ANC Mitigation Syslog Event Example 

The user has been successfully authenticated through ISE. 

 

 In QRadar, select the syslog event, right-click FramedIPAddress,  and then select More 

Options. 

In the following example, a Passed authentication (or RADIUS Accounting) syslog event was 

received from ISE: 

 

 You can right-click the Source IP and Destination IP address. This will also work on 

customized IP Fields. 
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 Select More Options > Cisco pxGrid – ANC Quarantine. 

 

 You should see a successful status message: 

 

 Select OK. 

 To view in ISE, go to Operations > RADIUS > Live Logs. 
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You should see the quarantined endpoint designated by the ANC Quarantine Policy: 

 

 To view in Cisco ISE pxGrid ANC Details Dashboard, go to Cisco ISE pxGrid > ANC Details. 

You should see the MAC address assigned to the ISE ANC policy name: 

 

 To un-quarantine or clear the endpoint: 

Go to ISE > Operations > Adaptive Network Control > Endpoint Assignment. 
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 Select the endpoint MAC address > Trash. 

 

Select Selected, and then you should see: 

 

Select Yes. 

In ISE, go to Operations > RADIUS-Live Logs. 

You should see that the endpoint has been un-quarantined: 
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Hovering Over IBM QRadar Syslog IP Address for ISE 
Contextual Information   

Once the endpoint has been authenticated, you can hover the IP address fields and obtain additional 

contextual information such as the User Name, Mac Address, Posture Status, and Endpoint Profile. 

When you hover over the IP address field, the contextual information is displayed: 
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IBM QRadar Cisco ISE pxGrid Offense Rule   

IBM QRadar Custom Rules Engine (CRE) displays the rules and building blocks that are used by IBM 

QRadar. The CRE provides information about how the rules are groups, the types of tests that the rules 

perform, and the rule responses. A rule is a collection of tests that triggers an action when specific 

actions are met.  

Offenses are generated when events and flow data pass through the CRE. They are correlated against 

the rules that are configured and an offense can be generated based on this correlation and viewed on 

the Offenses tab. 

The Cisco pxGrid offense rule gets triggered when an event occurs, the match Radius Failure session 

or simply three events in the Cisco ISE pxGrid App Failed Authentication Dashboard from the same 

source IP address that occur within 10 minutes. 

As a simple test, you can attempt to log in with an invalid password, and then login successfully. This 

will trigger a failed event followed by a successful login. Repeat this step three or four times within 10 

minutes, and this will trigger the IBM QRadar pxGrid Offense rule. 

The following image is an example of ISE authentication failure report that confirms failed 

authentications. 
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You can also view events in ISE. 
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Verify pxGrid offense rule via Log Activity 

 Go to Log Activity > Add Filter > Parameter > Payload Contains > Operator > is any of > Value > 

QRadarAppForPxgrid > "+". 

 

Select Add Filter. 

Select View Real Time Events > Last interval setting, for example, 45 minutes.
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Click the offense rule . 

You will see the following: 
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Verify pxGrid offense rule via Offenses Dashboard 

After select Offenses, you should see the pxGrid Radius Failure Offense rule: 

 

Taking ISE ANC mitigations from Offenses Dashboard 

 Under the Offense Source, right-click the IP address, and then select the Cisco pxGrid – ANC 

Quarantine mitigation action. 

 

 This will trigger the ANC Quarantine: 

 

 Select OK. 
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 In ISE, select Operations > RADIUS > Live Logs. 

 The endpoint has been quarantined as designated by the ANC Quarantine 

Authorization Policy. 

 

 To un-quarantine or clear, go to Operations > Adaptive Network Control > Endpoint Assignment. 

 

 Select the endpoint > Trash. 
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Select > Selected. 

 

 Select Yes. 

 In ISE, you should see the endpoint has been un-quarantined: 

 

Select Dashboard 
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Select pxGrid Radius Failure. 

Hover over the Offense Source IP Address. 
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Addendums 

Adding Log Activity Filter to View Session Information    

In this section, a pxGrid app filter is created to view the incoming session information. 

 Select Log Activity > Add Filter > Select the following: 

 

 Add the following search criteria:  

SELECT "pxGrid_adNormalizedUser" AS 'label' , COUNT("pxGrid_adNormalizedUser") AS 'value' FROM 
events WHERE LOGSOURCENAME(logsourceid)='pxGrid' AND "pxGrid_EventName"='User Sessions' GROUP 
BY "pxGrid_adNormalizedUser" ORDER BY value DESC LIMIT 10 LAST 1 DAYS 

 Click Search.  

 You should see the Cisco ISE pxGrid User Sessions.  



SECURE ACCESS HOW-TO GUIDES 

Page 99 

 

Cisco Systems © 2021 

 

 

 

   

 

Using an External Certificate Authority   

This section illustrates generating certificates for the IBM QRadar pxGrid App, using the ISE internal CA.  

It is assumed that the ISE pxGrid node and the other ISE nodes are signed by an external CA server. In 

this example, there are two ISE instances. The ISE26.lab20.com node is the primary ISE instance, and 

contains the Primary Admin, Primary MNT, Primary pxGrid node, and PSN personas.  

The ISE26ca.lab10.com node is the secondary ISE instance, and contains the Secondary Admin, 

Secondary MNT, Secondary pxGrid, and PSN personas.  

 Verify that the ISE pxGrid, the ISE Admin and ISE MNT nodes are signed by the external CA 

Server. 

Go to Administration > System > Certificate > System > Certificates > System Certificates. 

 The ISE pxGrid and ISE Primary Admin nodes are signed by an external CA Server. 
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 Verify the pxGrid and Admin certificates are signed by the external CA server. 

 

 

 Ensure that the published pxGrid nodes appear and you have pxGrid node connectivity: 

Go to Administration > pxGrid Services.  

Now, you see the following: 

 



SECURE ACCESS HOW-TO GUIDES 

Page 101 

 

Cisco Systems © 2021 

 

 

 

   

 Ensure that there is pxGrid connectivity. If in the lower-left corner you see "no connectivity", 

there is a certificate issue with the ISE pxGrid node, the ISE admin and MNT nodes. 

Generating IBM QRadar Certificate from ISE Internal CA   

In this example, the certificate is generated for the IBM QRadar instance using the ISE Internal CA. You 

can also use opens to create the private key, generate a Certificate Signing Request (CSR), and get this 

signed by the same customized template that was used for the ISE pxGrid node. To summarize, the 

customized template must have an EKU of both client and server authentication.  

 Create and generate certificate for the IBM QRadar instance:  

Go to Administration > pxGrid Services > Certificates. 

 

 From the I want to list, select Generate a single certificate without a signing request . 

 In the Common Name (CN) box, enter the Fully Qualified Domain Name (FQDN) of the QRadar 

Instance. 

 From the Subject Alternative Name (SAN) list, select the IP Address, and then enter the IP 

address of the QRadar instance. 

 Provide a description name. 

 From the Certificate Download Format list, select the PEM format. 

 In the Certificate Password box, enter the encryption password. 
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 In the Confirm Password box, enter the password once again. 

  

 Select Create. 

Copy the zipped file into a folder and unzip the files:  

  

Unencrypt the QRadar private key:  

Copy the original QRadar .key file to QRadar.key.org file: 

cp QRadar3.lab10.com_192.168.1.249.key QRadar3.lab10.com_192.168.1.249.key.org   

Then, run openness to remove the encryption password from the key.org file. You will get an 

unencrypted file as defined by the –out parameter. The unencrypted key will be the .key file.  

QRadar3.lab10.com_192.168.1.249.key.org -out QRadar3.lab10.com_192.168.1.249.key Enter pass 
phrase for QRadar3.lab10.com_192.168.1.249.key.org:(enter passphrase used when generating 
certificate) writing RSA key 

 Open SSL is on most Linux and MAC operating systems. 
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To download the certificate root chain:  

Go to Administration > pxGrid services > Certificates. 

  

From the I want to list, select Download Root Certificate Chain. 

In the Host Names box, select the ISE PAN Nodes: 

  

From the Certificate Downloaded Format list, select PEM format. 

Select Create. 

Download the zipped file into the same folder where you downloaded the QRadar certificate 

zipped files. Now, you see the following files: 

 

Create a new folder, for example, QRadar_all_certs.  

Then, copy the ISE identity certificates, for example, ise26.lab10.cer and ise26ca.lab10.com, 
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the QRadar certificate key-pair files, the external root CA, and the ISE certificate files into this 

new folder.  

 

 Please DO NOT copy the encrypted key.org file into the new folder. 
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Troubleshooting  

Cisco ISE pxGrid App pxGrid client not showing under ISE pxGrid Client View 

If using an external CA server, upload the CA root certificate and include it in Root CA Certificate file 

name. 

Cisco ISE pxGrid App pxGrid client not showing under ISE pxGrid Web Client View 

Ensure that both the IBM QRadar SIEM and the Cisco ISE pxGrid node are FQDN are resolvable. 

Make sure the Forward and Reverse DNS for ISE is defined on the network, And FQDN is resolvable 

completely from QRadar. 

Troubleshoot inside QRadar: 

 Take an SSH to the PxGrid Docker Container on Qradar. 

 For QRadar versions 7.3.3 and above run the commands: 

1> /opt/qradar/support/recon ps 

2> /opt/qradar/support/recon  connect <App ID> 

Cisco ISE pxGrid Dashboards not populating with ISE Contextual Information 

Ensure that the Cisco ISE pxGrid App appears under the ISE pxGrid Web Client View. 

Using the IBM QRadar pxGrid App Logs for Troubleshooting    

The QRadar app logs are used for troubleshooting the connection between the QRadar pxGrid App and 

the ISE pxGrid node. 

For example, if the QRadar pxGrid client does not appear under the ISE pxGrid Clients View, you can 

view the QRadar app log to see if the secure web socket connection is established between the QRadar 

app and the ISE pxGrid node.  

To see the QRadar apps, type the following:  

[root@QRadar3 support]# /opt/qradar/support/recon  ps 

PORT   CONTAINER     IMAGE  STATUS  appID  NAME 

32768  28ac62f3a3d8  2cabd65ea8554650b3990bbdd83f59d8  RUNNING  1201  Cisco ISE 

pxGrid 

 Use Recon connect to retrieve the container contents:  

[root@QRadar3 support]# /opt/qradar/support/recon connect <<appID>> bash-4.1# ls 
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App 

Bin 

boot 

Dev 

etc 

executeapp.bat 

home 

init 

lib 

lib64 

media 

mnt 

opt 

proc 

qpython 

root 

run.py 

sbin 

selinux 

src_deps 

srv 

start_container.sh 

start_flask.sh 

store 

Sys 

Tmp 

upgradePath.sh 

Usr 

var 

          

 For QRadar versions 7.3.2 and above, run the commands:  

1> /opt/qradar/support/recon ps   

2> /opt/qradar/support/recon connect <App ID>      

Use tail to view the app.log: bash-4.1# tail -f store/log/app.log 

 A successful connection will look like this:  

2019-04-14 21:14:43,812 [abstract_qpylib.log] [Thread-1] [INFO] - 127.0.0.1 

[APP_ID/1201][NOT:0000006000] Primary Server: ise26.lab10.com 2019-04-14 21:14:43,812 
[abstract_qpylib.log] [Thread-1] [INFO] - 127.0.0.1  
[APP_ID/1201][NOT:0000006000] Secondary Server: 192.168.1.138  
2019-04-14 21:14:43,813 [abstract_qpylib.log] [Thread-1] [INFO] - 127.0.0.1  
[APP_ID/1201][NOT:0000006000] Current Active Server: primary  

2019-04-14 21:14:48,933 [abstract_qpylib.log] [Thread-1] [INFO] - 127.0.0.1  

[APP_ID/1201][NOT:0000006000] Account Activation Status: 200  
2019-04-14 21:14:48,933 [abstract_qpylib.log] [Thread-1] [INFO] - 127.0.0.1  
[APP_ID/1201][NOT:0000006000] Performing service lookup for:com.cisco.ise.pubsub  
19-04-14 21:14:49,280 [abstract_qpylib.log] [Thread-1] [INFO] - 127.0.0.1 
[APP_ID/1201][NOT:0000006000] Creating WebSocketClient....  
2019-04-14 21:14:49,282 [abstract_qpylib.log] [Thread-1] [INFO] - 127.0.0.1 
[APP_ID/1201][NOT:0000006000]  

Connecting to websocket  

2019-04-14 21:14:49,321 [abstract_qpylib.log] [Thread-1] [INFO] - 127.0.0.1 
[APP_ID/1201][NOT:0000006000] Connected and about to running for ever....  
2019-04-14 21:14:49,322 [abstract_qpylib.log] [WebSocketClient] [INFO] - 127.0.0.1  

[APP_ID/1201][NOT:0000006000] Subscribe request sent to websocket for 
/topic/com.cisco.ise.session  

2019-04-14 21:14:49,322 [abstract_qpylib.log] [WebSocketClient] [INFO] - 127.0.0.1  

[APP_ID/1201][NOT:0000006000] Subscribe request sent to websocket for 
/topic/com.cisco.ise.radius.failure  
2019-04-14 21:14:49,323 [abstract_qpylib.log] [WebSocketClient] [INFO] - 127.0.0.1  
[APP_ID/1201][NOT:0000006000] Subscribe request sent to websocket for 
/topic/com.cisco.ise.config.anc.status  
2019-04-14 21:14:49,324 [abstract_qpylib.log] [WebSocketClient] [INFO] - 127.0.0.1  

[APP_ID/1201][NOT:0000006000] Subscribe request sent to websocket for 

/topic/com.cisco.ise.mdm.endpoint 

 
 You should see a successful connection to the primary server connection and an 

activation status. You should also see a subscription to the pxGrid topic over a secure 

Websockets connection. Please disregard the *crypto messages and the unauthorized 

messages.  

 If you do not see a successful connection where there is no Primary server response, or the 

connection keeps switching between the primary and secondary pxGrid nodes, this can be an 

indication that some of the services have not started or may be in an inconsistent state. 
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2019-04-14 20:20:57,799 [abstract_qpylib.log] [Thread-100] [INFO]  - 127.0.0.1  
[APP_ID/1201][NOT:0000006000] Primary  Server  Response: None  
2019-04-14 20:22:08,369 [abstract_qpylib.log] [Thread-103] [INFO]  - 127.0.0.1 

[APP_ID/1201][NOT:0000006000] Received  request  to test primary  files  
2019-04-14 20:22:08,374 [abstract_qpylib.log] [Thread-103] [INFO]  - 127.0.0.1 
[APP_ID/1201][NOT:0000006000] Trying  http connection .................. 2019-04-14 20:22:13,380 
[abstract_qpylib.log] [Thread-103] [INFO]  - 127.0.0.1 [APP_ID/1201][NOT:0000006000] Wraping  SSL 
socker  ..................   

You can stop or restart your app by using the IBM QRadar GUI Application Framework REST API 

endpoints. As a reference, see this page. 

 Stop the pxGrid App: 

POST /api/gui_app_framework/applications/{app_id}?status="STOPPED" 

 Start or restart the pxGrid app: 

 Start the app: POST /api/gui_app_framework/applications/{app_id}?status="RUNNING"   

 Restart the app:  

 Copy the PxGrid app ID: ssh to QRadar >> /opt/qradar/support/recon ps. 

 In the GUI, open the QRadar Menu bar. 

 Click the Interactive API for Developer. 

 Click the drop button of the latest version >>gui_app_framework>>applications>>application_id. 

 Under POST, enter the application_id. 

 Update the status to STOPPED, then RUNNING, to stop and start the app. 

 Review the QRadar app log again or check to see if the pxGrid client appears under Web Clients 

on the ISE pxGrid node view. 

 If you are stuck in the loading page, click Reset and change the date, to reflect a day before and 

a day after. There should be real-time authentications in ISE, so the session information can be 

seen in the IBM QRadar App.  

Here are some more log issues with connectivity: 

pxGrid app pending state in the logs due to ISE pxGrid client not being approved. 

This is showing the QRadar ISE pxGrid app as pending. You can see this under admin > pxGrid > All 

Clients. You should not see the app listed under Web Clients as it hasn’t been approved. You can 

manually approve it in the All clients page (this was noted in the setup section of the guide).  

 

https://www.ibm.com/support/knowledgecenter/SS42VS_7.3.2/com.ibm.appfw.doc/c_appframework_disableApp.html
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 2021-02-02 17:35:00,088 [abstract_qpylib.log] [Thread-740] [INFO] 
- 127.0.0.1[APP_ID/1102][NOT:0000006000] Checking response got from primary server 
2021-02-02 17:35:00,088 [abstract_qpylib.log] [Thread-740] [INFO] 
- 127.0.0.1[APP_ID/1102][NOT:0000006000] Checking status from primary server: 200 
2021-02-02 17:35:00,088 [abstract_qpylib.log] [Thread-740] [INFO] 
- 127.0.0.1[APP_ID/1102][NOT:0000006000] Checking response from primary server: 
{"accountState":"PENDING","version":"2.0.3.14"} 

After its connected. 

2021-02-02 20:40:00,097 [abstract_qpylib.log] [Thread-1193] [INFO] 
- 127.0.0.1[APP_ID/1102][NOT:0000006000] Checking response from primary server: 
{"accountState":"ENABLED","version":"2.0.3.14"} 

Not able to connect to ISE node from QRadar ISE pxGrid app. 

These logs were seen when pointing Qradar ISE pxGrid app to the admin node of ISE (should be 

pointing to a pxGrid node). 

2021-02-02 17:20:04,148 [abstract_qpylib.log] [Thread-707] [INFO] 
- 127.0.0.1[APP_ID/1102][NOT:0000006000] Client Name Jabe02022021 
2021-02-02 17:20:04,148 [abstract_qpylib.log] [Thread-707] [INFO] 

- 127.0.0.1[APP_ID/1102][NOT:0000006000] URL /pxgrid/control/ServiceLookup 
2021-02-02 17:20:04,148 [abstract_qpylib.log] [Thread-707] [INFO] 
- 127.0.0.1[APP_ID/1102][NOT:0000006000] Service Name com.cisco.ise.pubsub 
2021-02-02 17:20:04,191 [abstract_qpylib.log] [Thread-707] [ERROR] 
- 127.0.0.1[APP_ID/1102][NOT:0000003000] Exception reported from invoke_cisco_ws_api method: <type 
'exceptions.ValueError'> 
2021-02-02 17:20:04,191 [abstract_qpylib.log] [Thread-707] [ERROR] 
- 127.0.0.1[APP_ID/1102][NOT:0000003000] Exception reported from invoke_cisco_ws_api method: No JSON 
object could be decoded 
2021-02-02 17:20:04,191 [abstract_qpylib.log] [Thread-707] [ERROR] 
- 127.0.0.1[APP_ID/1102][NOT:0000003000] Exception reported from subscribefromwebsocket method: <type 
'exceptions.ValueError'> 
2021-02-02 17:20:04,192 [abstract_qpylib.log] [Thread-707] [ERROR] 
- 127.0.0.1[APP_ID/1102][NOT:0000003000] Exception reported from subscribefromwebsocket method: No JSON 
object could be decoded 

2021-02-02 17:25:00,032 [abstract_qpylib.log] [Thread-718] [INFO] 
- 127.0.0.1[APP_ID/1102][NOT:0000006000] Checking http connection with primary server 
2021-02-02 17:25:00,036 [abstract_qpylib.log] [Thread-718] [INFO] 
- 127.0.0.1[APP_ID/1102][NOT:0000006000] Checking connection with primary server using PROTOCOL_SSLv23 

  

https://127.0.0.1/
https://127.0.0.1/
https://127.0.0.1/
https://2.0.3.14/
https://127.0.0.1/
https://2.0.3.14/
https://127.0.0.1/
https://127.0.0.1/
https://127.0.0.1/
https://127.0.0.1/
https://127.0.0.1/
https://127.0.0.1/
https://127.0.0.1/
https://127.0.0.1/
https://127.0.0.1/


SECURE ACCESS HOW-TO GUIDES 

Page 111 

 

Cisco Systems © 2021 

 

 

 

   

TCP Dump to Analysis Failed Certificate Exchange in ISE  

In this section, we are going to see how we can download .pcap file for analysis from ISE, in case the 

certificate exchange fails, or the Client is not subscribing to topics.  

 Navigate to Operation > Troubleshoot > Diagnostic Tools > TCP Dump. 

 From the Format drop-down list, select the Raw Packet Data, and then click Start. 

  

 While you keep the TCP Dump running, log in to QRadar and reconfigure the App settings page. 

 Stop the dump collection and download the .pcap file. 

 Analyze the .pcap file using Wireshark and observe if there are any packets being dropped, 

Certificate exchange failing, or Unknown CA alert. 
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TCP Dump to Check if pxGrid Logs are Available in QRadar  

In this section, we are going to run few tcpdump commands in QRadar, to verify if pxGrid Logs are 

available in QRadar database, if the pxGrid Dashboard is not loading with data, or the Log Activity 

search does not show the pxGrid Events.  

 Take SSH to QRadar console. 

 Find the PxGrid docker IP:  

/opt/qradar/support/recon ps  

/opt/qradar/support/recon connect <<App ID>>  

ifconfig (Ip associates with the  inet addr)  

 Run this command > tcpdump -nnAs0 -i any host <<PxGrid Docker Ip Address>> and port 514. Wait 

for few minutes if the Events are available on your ISE for the subscribed topic, then you should 

see events showing up in LEEF Format. 

Uploading Logs with the case 

Upload the following logs with the case can help our engineers assist you further: 

• qradar.error 

• startup.log 

• app.log 

 To get qradar.error logs, first we need to SSH to QRadar Console. 

QRadar error logs are available in this location: /var/log/qradar.error 

 To get startup.log and app.log, first we need to get inside pxGrid App docker: 

 Login to QRadar console (putty/terminal). 

 Get the pxGrid APP ID execute this command: /opt/qradar/support/recon ps. 

 The startup.log and app.log are available in this location: /store/docker/volumes/qapp-<<App 

ID>>/log. 

 Replace App ID with pxGrid App ID from Step 2. 

 For example: /store/docker/volumes/qapp-110. 
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