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About This Document   

This document is for Cisco System Engineers, IBM Engineers, Partners, and Customers deploying the 

Cisco Identity Services Engine (ISE) Cisco Platform Exchange Grid (pxGrid) App v2.0+ for IBM the 

QRadar SIEM.    

The supported platforms are:  

• IBM QRadar SIEM 7.3.1 patch 7 and higher 

• Cisco ISE 2.4 and higher with latest patch 

 

Validation has been done with the following for this release: 

• The ISE internal CA was used for generating the pxGrid certificates for the Cisco ISE pxGrid App. 

• ISE 2.4 Standalone with IBM QRadar SIEM 7.3.1 Patch 7 

• ISE 2.7 patch 2 standalone/distributed with IBM QRadar SIEM 7.4.0, should work with 7.4.x  

It is also assumed that the reader is familiar with both IBM QRadar SIEM and Cisco ISE. 

This document provides the details of installing and configuring the Cisco ISE pxGrid App for the IBM 

QRadar SIEM. The Cisco ISE pxGrid App provides Dashboards for Passed Authentications, Failed 

Authentications, Devices, Compliances, TrustSec, Mobile Device Management (MDM) and Currently 

Assigned ANC Policies. 

Cisco Adaptive Network Control (ANC) mitigation actions can be taken directly from the Dashboards 

to quarantine endpoints according to an organization’s security policy. These ANC mitigations can be 

also be enforced via IBM QRadar SIEM syslog events as long as the endpoint has been authenticated 

through ISE. 

The Cisco ISE pxGrid App contains an IBM QRadar pxGrid offense rule which is based on pxGrid 

RADIUS failure topic events. 

The contextual information can be obtained from the IP Address of syslog events as long as the 

endpoint has been authentication through IS.

  

https://community.cisco.com/t5/security-news/announcing-ise-2-7-as-recommended-release/ba-p/4104487
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Solution Overview   

IBM® QRadar® SIEM detects anomalies, uncovers advanced threats, and removes false positives. It 

consolidates log events and network flow data from thousands of devices, endpoints, and applications 

distributed throughout a network. It then uses an advanced Sense Analytics engine to normalize and 

correlate this data and identifies security offenses requiring investigation. As an option, it can 

incorporate IBM X-Force® Threat Intelligence which supplies a list of potentially malicious IP addresses 

including malware hosts, spam sources, and other threats. QRadar SIEM is available on premises and in 

a cloud environment. 

Cisco Identity Services Engine (ISE) is a security policy management and identity access management 

solution. ISE provides centralized management by defining/issuing/enforcing 802.1X authentications, 

guest access management, policies, posture, client provisioning and TrustSec policies. The ISE session 

directory contains a wealth of information about the endpoint that is published by Cisco Platform 

Exchange Grid (pxGrid).  

ISE also simplifies access control and security compliance for wired, wireless, and VPN connectivity and 

supports corporate security policy initiatives such as BYOD. 

Cisco Platform Exchange Grid (pxGrid) enables multivendor, cross platform network system 

collaboration among parts of the IT infrastructure such as security monitoring and system detection, 

network policy platforms, asset and virtually configuration management identity and access management 

platforms and other IT solutions. pxGrid uses a pub/sub model to publish the contextual information 

received from ISE, and other security solutions will subscribe to this topic, providing more visibility into 

security operations. Other security solutions can use pxGrid to enforce their security policies. 
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Technical Details   

The Cisco ISE pxGrid App installs on an IBM QRadar SEIM instance as an IBM signed app. Once the 

app installs, the Cisco ISE pxGrid App will be registered as a pxGrid client to the ISE pxGrid node and 

subscribe to topics and consume contextual information to populate the Dashboards and take Adaptive 

Network Control (ANC) mitigation actions. 

At the bottom of the screen, you should see a connection for distributed deployment:  

 

The following image is a single standalone: 

 

The following image is for a distributed deployment of PAN, MNT, and 2 PSN/pxGrid Nodes: 
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The Cisco ISE pxGrid app pxGrid client subscribes to the Session Directory, RADIUS failure, MDM 

endpoint, and ANC configuration Topics. 

The Session Directory topics consist of user contextual information, such as username, MAC address, 

IP Address, endpoint device, posture status and provides wired and wireless connection type 

information. Wired connection type information includes the NAS Port ID, NAS IP Address, NAS Port 

Type, Location and Device Type attributes. Wireless connection type information includes WLAN, 

Calling Station ID, Called Station ID, NAS IP, Device Type, Location, and NAS Identifier attributes. 

The MDM topic consists of compliance and registration status and is dependent on having an external 

MDM solution configured in Cisco ISE. In this document, the Cisco Meraki Solution was used as the 

external MDM solution. The test ing done was with ISE 2.4 init ial  release so only the 

compliance and registration status attributes were available. In later releases of Cisco ISE after 2.4, 

the MDM attributes are available as follows: Manufacturer, UDID, Serial Number, Encryption Status, Jail 

Broken Status, Pin Lock Status. 

The RADIUS failure topic includes failure reason attributes, such as "invalid password", and drill downs 

based on location and wired/wireless connection types. 

The Config ANC Status Topic provides the Cisco ISE pxGrid client app to perform ISE Adaptive 

Network Control (ANC) mitigation actions on the endpoints. 
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The Cisco ISE pxGrid App uses pxGrid 2.0, which uses WebSocket, REST API, and STOMP messaging 

protocol for pxGrid operation and thus supported since Cisco ISE 2.

Cisco ISE pxGrid Installation   

Make sure that you have installed Cisco Identity Services (ISE) 2.4 or higher and it is in a stand-alone 

deployment (also supports other deployment methods). If this is a production ISE deployment, ensure 

the Cisco ISE pxGrid node is on a dedicated node, see How to Configure pxGrid in ISE Production 

Environments.  

At minimum, it is recommended to have two standalone nodes for HA purposes. Both nodes would be 

running all personas, including pxGrid. Depending on the number of clients and architecture 

requirements, you may expand into other architecture designs. Please consult with your ISE integrator on 

recommended deployment model. 

 Select Administration > System Deployment > Edit the ISE node > Enable pxGrid 

 

 Select Save 

https://community.cisco.com/t5/security-documents/how-to-configure-pxgrid-in-ise-production-environments/ta-p/3646330
https://community.cisco.com/t5/security-documents/how-to-configure-pxgrid-in-ise-production-environments/ta-p/3646330
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You should see the following: 
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Recommended Distributed deployment example: 

 

 Select Administration > pxGrid Services 

Verify the published nodes appear. All nodes running pxGrid will have a fanout & pubsub. 

 XMPP is for pxGrid 1.0 and for releases prior to ISE 3.0 the All Clients page doesn’t 

provide the best view. You should look at the Web Clients view below. 

 Select Web Clients and verify the published nodes appear: 

 This is validating pxGrid 2.0 connections. You should see admin, mnt, and pxGrid nodes 

have connections with each other. They should all be ON. 
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Generating the Cisco ISE pxGrid App Certificate   

A certificate for the Cisco ISE pxGrid App will be generated from the ISE internal CA so the App will 

register and connect to the ISE pxGrid node. If you are using an external CA server for pxGrid 

operation, please see How to Configure pxGrid in ISE Production Environments. 

For more information on certificates please reference this section under cs.co/ise-guides. 

 

 Select Administration > pxGrid Services > Certificates 

You should see the following: 

 

 Type the following: 

Recommended to use the full name of the server ex: qradar.securitydemo.net 

  

https://community.cisco.com/t5/security-documents/how-to-configure-pxgrid-in-ise-production-environments/ta-p/3646330
https://www.cisco.com/c/en/us/support/docs/security/identity-services-engine/216120-ise-security-ecosystem-integration-guide.html#anc52
https://cs.co/ise-guides
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 This is the IP address and FQDN of your QRadar system. You are generating a 

certificate here to install on QRadar app so it can present when communicating with ISE.  

I want to: Generate a single certificate (without a certificate signing request) 

Common Name (FQDN): qradar.securitydemo.net 

Description: QRadar 

Certificate Template: Pxgrid_Certificate_Template 

Subject Alternative Name (IP Address): 10.1.100.27 

Subject Alternative Name (FQDN): qradar.securitydemo.net 

Certificate Download Format: Certificate in Privacy Enhanced Mail (PEM) format, key in PKCS8 

PEM format including certificate chain  

Certificate Password: xxxxxxxx  

Confirm Password: xxxxxx 

 Select Create 

This will create a zipped file 1520701037382_cert.zip 

 Make sure your browser pop-up blocker is disabled, when generating certificates 

 Unzip the file, you will see the following files: 

 

The QRadar identity certificate consists of the public private key-pair: 

qradar.securitydemo.net_qradar.securitydemo.net.cer 
qradar.securitydemo.net_qradar.securitydemo.net.key 

The CertificateServicesRootCA-ise_.cer is the ISE internal Root CA certificate. 
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Depending on your setup, you may have certificates being used for different ISE personas in your 

environment. If pxGrid is not assigned to the local Certificate services endpoint, as seen below, then 

make sure that you export the root certificate chain that was used to sign it. For example, if you have ISE 

signed up an external identity source. 

Don’t assign pxGrid to the self-signed certificate of ISE. This is not best practice. If it is move pxGrid 

back to the Certificate Services Endpoint Sub CA as you can see in the image below. If for some reason 

you need this then you will need to manually export this certificate and upload as package with the 

internal CA generated cert and key to QRadar and choose that as the root. The relevant certificates from 

the internal CA won’t matter even though they are in the package. 

In the following example, the pxGrid certificate is signed by the same ISE internal CA. When ISE 

communicates to QRadar system it will present this as part of the communication. When you generate 

the certificate on ISE in the above steps, it gives you a package that includes the certificate chain from 

ISE internal CA. When QRadar talks to ISE, its certificate is automatically accepted as ISE is aware of the 

certificates it issues and the associated certificate chain. 

 

 Decrypt the file on the QRadar box: 

a. Using WinSCP Copy the qradar.securitydemo.net_qradar.securitydemo.net.key to the QRadar 

Setup 

 The certificate might also have the IP address since it was part of the SAN above.  

b. SSH to your QRadar setup and make sure you’re in the root directory 

c. Run the following to remove the encryption password when importing into the Cisco ISE 

pxGrid App: 

mv qradar.securitydemo.net_qradar.securitydemo.net.key 
qradar.securitydemo.net_qradar.securitydemo.net.key.old 
openssl rsa -in qradar.securitydemo.net_qradar.securitydemo.net.key.old-out 
qradar.securitydemo.net_qradar.securitydemo.net.key 
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You will be prompted to enter the encryption password when generating the certificate in ISE 

 The Cisco ISE pxGrid App does not support encryption due to the Python libraries 

d. Refresh your WinSCP and copy the key file back (not the .org) to the same windows location 

overwriting the key file 

e. Close your WinSCP and SSH sessions to QRadar server 

 You will need to upload these six certificates when configuring the Cisco ISE pxGrid 

App for pxGrid integration 
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Installing Cisco ISE pxGrid App   

In this section, you will learn how to install the Cisco ISE pxGrid App. 

To download the app, please visit the IBM App Exchange. 

 

If user is upgrading the Cisco ISE pxGrid QRadar App from ver1.x.x, we recommend users to uninstall 

the old app (1.x.x) and install the latest version. 

To uninstall the old app: 

 Go to Admin > System Config > Extensions Mgmt  

 Select Cisco ISE pxGrid, and then click Uninstall 

 

Install the extension: 

a. From IBM QRadar, select Admin > Extensions Management  

 

 

https://exchange.xforce.ibmcloud.com/hub/extension/6091fd93042043212fd2494fe97ff5b7
https://www.ibm.com/support/pages/release-qradar-731-patch-7-iso-73120181123182336
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b. Click Add > Upload the signed Cisco ISE pxGrid App > Select Install Immediately 

 

  



SECURE ACCESS HOW-TO GUIDES 

Cisco Systems © 2021 Page 18 

 

 

 
 

  

  

c. After the install, you should see the following: 

 

d. Clear the browser cache, close the browser, launch the app, and login again. 

 Configure the logging IP address for the primary/secondary nodes: 

a. On QRadar, in the upper-left corner, click the hamburger button 

b. Navigate to Admin > Data Sources > Events > Log Sources  

 

c. Change your log source identifiers QRadar 7.3 (see 7.4 below this section) 

Choose Name > pxGrid_Primary/pxGrid_Secondary 

Edit and change the Log Source Identifier to corresponding ISE IP for Primary and 

Secondary accordingly  

You may disable the secondary if you don’t need it 
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d. Change your log source identifiers for QRadar 7.4  

• The app opens in a new window. 

• Choose Log source type to filter on pxGrid. 
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• Change the primary and secondary log source identifier. 

• Click on the primary, edit, and then choose protocol. Change Primary to actual ISE pxGrid node 

IP, and then click Save.  

 Do the same for the secondary. If one is not used, then disable the toggle slider as in 

the image above. 

 

• Close the second browser tab. 
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 Configure the Authorized Services in QRadar: 

a. Select Admin > System Configuration > User Mgmt > Authorized Services  

 

b. Add Authorized Service: 

• In the Service name box, enter pxGridService 

• For both the User Role and Security Profile drop-down list boxes, select Admin (default)  

• Enable No for Expiry 

 

c. Click Create Service 
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d. Copy the authentication token into the notepad 

 

 

 This is later used for Cisco ISE pxGrid App for pxGrid integration.  

e. Close the Authorized Service browser window 

f. Make sure to deploy changes at this point 
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Configuring pxGrid Integration on QRadar 

Setup pxGrid settings: 

a. Select Admin > Apps > Cisco ISE pxGrid > pxGrid Settings 

 

b. Copy and paste the authentication token from into the QRadar Service Token Window 

 

 Enter the QRadar Event collector (EC) IP / QRadar Console IP (If EC is not available).  
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 Select Submit and Test Connection, you should see a successful connection in a pop-up 

window 

 Select Primary, and type the IP address of the ISE pxGrid node  

 Leave 8910 as the port default 

 Enter the Client username (for example, QRadar App) 

 This will be the unique registered pxGrid client name displayed on ISE. 

 Upload al l (selecting al l  in the browse windows at once) the Cisco ISE pxGrid App 

certificates in PEM format under Select and Upload Certificates (only PEM is supported) 

application settings page 

CertificaeServicesEndpointSubCA-ise24k_.cer  
CertificateServicesNodeCA-is24k_.cer  
CertificateServicesRootCA-ise24k_.cer  
ise24k.lab10.com_.cer  
qradar.lab10.com_qradar.lab10.com.cer  
qradar.lab10.com_qradar.lab10.com.key 

 Type in the Cisco ISE pxGrid App Certificate file name: 

qradar.lab10.com_qradar.lab10.com.cer 

 Type in the Cisco ISE pxGrid App Certificate key file name: 

qradar.lab10.com_qradar.lab10.com.key 

Type in the Cisco ISE Internal Root Certificate Root CA certificate file name: 

qradar.lab10.com_qradar.lab10.com.key 
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You will see the following: 

 

When working with certificates, you must understand where the certificate was issued for your pxGrid 

nodes. Here are some criteria: 

• On any ISE deployment you could have multi certificates for different roles personas.  

• The admin node with an internal PKI cert so that your admin machines with the root trust them. 

• Portals for guest services would likely have a well-known certificate so that any client coming in 

off the street can trust the portal. 

• Your pxGrid node will likely be side either by ISE internal CA or a well-known certificate root, 

depending on how you certificate trust is set up. Carefully choose your Root in the setup 

settings. 

• All nodes running pxGrid should have the same root.  

• See more about certificates at the ISE Guides page for certificates and the ISE 2.7 Certificate 

Section of Admin Guide. 

At the bottom of the page, select Submit and Test Connection. Then you should see a 

successful connection message. If a secondary connection exists, do the same.  

 

Validate the pxGrid client on ISE: 

a .  In your browser, open ISE and log in 

b .  Select Administration > pxGrid Services 

c. On the All Clients tab, you should see your QRadar pxGrid client (pending) 

https://community.cisco.com/t5/security-documents/ise-security-ecosystem-integration-guides/ta-p/3621164#toc-hId--1761730573
https://www.cisco.com/c/en/us/td/docs/security/ise/2-0/admin_guide/b_ise_admin_guide_20/b_ise_admin_guide_20_chapter_0111.html
https://www.cisco.com/c/en/us/td/docs/security/ise/2-0/admin_guide/b_ise_admin_guide_20/b_ise_admin_guide_20_chapter_0111.html
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 The visibility of QRadar pxGrid client depends on the setting under pxGrid > Settings for 

automatic approval of cert accounts. If that setting is disabled, then you will need to 

manually approve it. 

 

 

d. Click Approve All as you should see just one pending client 

 On the All Clients tab, the Client Status can be Offline (XMPP). This is for pxGrid 1.0 and 

doesn’t represent any value. ISE 3.0 has a different view to better represent the setting, 

but we don’t address it here. 

Select Web Clients and see registered Cisco ISE pxGrid QRadar app client  

 If you do not see the pxGrid registered client, ensure the ISE pxGrid QRadar app client is 

using Fully Qualified Domain Name (FQDN). 

If you see gai error in the app.log, check if your ISE IP address and its FQDN entry is 

present in /etc/hosts in pxGrid Docker Container inside QRadar. 
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 You will see the client connected twice if there are two pxGrid (primary/secondary) 

nodes. Only one entry for single pxGrid nodes. 

Assign the QRadar client to the ANC Group permissions 

a. Select All Clients > Check the QRadar Client  

b. Group > Add > ANC   

c. Click Save 

 

 You should see the pxGrid client Group ANC assigned to the Cisco ISE pxGrid client 
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Setup Indexing in QRadar  

Following are the steps to Index CEPs in QRadar. 

Return to the IBM QRadar 

Navigate to Admin tab, and then click Index Management 

       

To setup the Indexes for use with pxGRid: 

a. Search for pxgrid indexes: in the upper-left corner, enter pxgrid into the search window, and then 

search.  

 

b. Sort by Property: 

 

c. To Index the CEPs Packaged with the app, click on the property name, and then Enable 

Index. 
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Recommended CEPs to be indexed are the following: 

• pxGrid_adNormalizedUser 

• pxGrid_auditSessionId 

• pxGrid_EventName 

• pxGrid_macAddress 

• pxGrid_nasPortType 

• pxGrid_src 

d. Click Save 
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Cisco ISE pxGrid App Dashboard Panels   

The dashboards and panels are populated with contextual information from ISE via pxGrid. This 

contextual information includes:  

•  Security or network admin visibility into who is connecting to the network and how they are 

connecting 

•  Type of devices connecting to the network, how they are connecting, and the owners of 

these devices  

• Users’ compliance with the organization’s security policy 

• Data on the incorporation of Bring Your Own Device (BYOD) security polices within the 

organization and whether they include external Mobile Device Management (MDM) vendors 

The dashboards and panels are designed or provide investigative insight across the entire organization 

or by connection-type such as wired or wireless. These dashboards include: Passed Authentications, 

Failed Authentications, Devices, Compliance, MDM, TrustSec, and Currently Assigned ANC policies. 

The admin can also take ISE ANC mitigative actions on the endpoint through these all QRadar ISE 

pxGrid App dashboards, except for TrustSec and Currently Assigned ANC Dashboards under ANC 

Details. 

Search Functionality 

The Search tab is the first tab on the page where user can enter the search details. While clicking on the 

tab the search page should be displayed with a search box, dropdown to select the type of event 

(Session, Radius, or both) to search, and a date-picker adjacent.  

When the user enters text in the search box and clicks the Search’ button, the date field should be 

populated with the existing date range from the application window by default. The end users should be 

able to change its according to their needs. If the search returns more than 200 (TBD) records the user 

should get an acknowledgement saying "This search returns too many records" and displaying the first 

200 records. In such cases, the user should narrow down their search by using the event type filter and 

the minimum time span. 

In the search window, the user should be able to enter IP Address, MAC Address and Session ID. When 

the user clicks the search button, the results should be displayed in a tabular format with pagination. The 

result display format will be same as the current window displayed with details while clicking on the 

existing graph in dashboard.  

There should be an option (hyperlink) provided at the end of the table to view the raw event associated 

with the selected event. The request data from the UI should be validated for security and valid request 

format. 
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Accepted Search format: 

IP Address          X.X.X.X 

MAC Address     X:X:X:X 

Session ID          XXXX 

Partial Search Criteria: 

IP Address should begin with X. 

Mac Address should begin with X: 
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Accepted Wildcard characters: 

Passed Authentications 

The Passed Authentications Dashboard View provides visibility into successful machine and user 

authentications across an organization and by wired and wireless connection type. This provides the 

admin with a view of how employees are connecting to the network, are they connecting over a wired 

or wireless connection, and where are they connecting from. This information is obtained from the 

Cisco ISE pxGrid App pxGrid client subscribing to the Session Directory topic. 

The admin drills down on the user or host and obtains the following contextual information: endpoint 

device information, MAC Address, IP Address, posture status, NAS Port Type, NAS Port ID, NAS 

Identifier, NAS IP Address, WLAN Information, Calling Station ID, Called Station ID, AD resolvable user 

and host identities. 

The AD resolvable user and host identities provide a consistent name format when different EAP 

methods are used, for example, EAP Chaining. 

Select Cisco ISE pxGrid > Passed Authentications 

 

Wildcard Character Description Example 

* Matches a string of zero or more 

characters 

*.*,*:*,192.*,192.168.*.*,AE:BC:* 

? Matches any single character 192.??.??.??,192.168.??.124,DE:??:DF:* 
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 Select an end-user, this provides a tabular view of the following contextual information: 

 

The Endpoint Profile, Endpoint Operating System, and the AD Normalized User Name provide 

the endpoint information for the user.
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The AD user Resolved Identities and AD User Resolved DNS provide the consistent identities 

of the end user. 

 

The Is Machine Authentication attribute determines if this is machine authentication or user 

authentication. If this attribute is set to "true", then this is machine authentication, if this is set 

to "false", then this is user authentication. 
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Failed Authentications 

The Failed Authentications Dashboard View provides visibility into failed authentication attempts 

across the organization and by wired and wireless connection types. This provides the admin with a 

view of how these failed authentications occur with panel breakdowns by user, failure reason, device 

type, and location. This information is obtained from the Cisco ISE pxGrid client App subscribing to the 

RADIUS failure topic. 

The user panel provides a breakdown by user and provides the following contextual information: 

failure reason, device type, location, endpoint device information, MAC address, IP Address, posture 

status, NAS IP address, NAS Port Type, NAS Port ID, WLAN information, NAS Identifier, Calling Station 

ID, Called Station ID, access, identity store, and credit check. 

The other panels provide a breakdown by failure reason, device type and location, and provide the 

admin insight to how these failed authentications occur. The same contextual information from the 

user panel is available in these panel breakdowns. 

The AD resolvable user and host identities provide a consistent name format when different EAP 

methods are used, for example, EAP Chaining. 
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User Panel 

The user panel provides a breakdown by username. 

Select Cisco ISE pxGrid > Failed Authentications 

 

 Select Cisco ISE pxGrid > Failed Authentications > User >  pxGrid2@lab10.com 

The IP Address, Failure Reason, Username attributes provide information into failed authentication 

attempts. 

 

The Server Name, Authentication Protocol, Device Type, Location, Calling Station ID, NAS IP Address, 

NAS Port ID, NAS Port Type attributes provide more authentication details and location information of 

failed authentication attempts. 

mailto:pxGrid2@lab10.com
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The Access Service attribute provide the ISE allowed protocol rules, the Identity Store attribute 

provides the back-end credential database of the end-user in question, the Authentication Method 

attribute provides the ISE authentication rule, and the Credit Check attribute provides the EAP 

authentication method. 

 

The AD Host/User Resolved Identities, AD Host/User Resolved DNS, AD User Domain, AD User Net 

BIOS Name Host attributes in the following screenshots provide additional context around the host and 

user identities. 
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Failure Reason Panel 

The Failure Reason panel provides a breakdown by failure reason. 

 Select Cisco ISE pxGrid > Failed Authentications 

 Select Failure Reason > 24408 User authentication against Active Directory failed since user has 

entered the wrong password 

 

The IP Address, Calling Station ID, Username attributes provide basic information for end users 

associated with failure reasons. 
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The Server Name, Authentication Protocol, Device Type, Location, Calling Station ID, NAS IP Address, 

NAS Port ID, NAS Port Type attributes provide more authentication details and location information of 

failed authentication attempts. 

 

The Access Service attribute provides the ISE allowed protocol rules, the Identity Store attribute 

provides the back-end credential database of the needed end user, the Authentication Method 

attribute provides the ISE authentication rule, and the Credit Check attribute provides the EAP 

authentication method. 
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The AD Host/User Resolved Identities, AD Host/User Resolved DNS, AD User Domain, AD User Net 

BIOS Name Host attributes in the following images provide additional context around the host and user 

identities. 

 

Device Type Panel 

The Device Type attribute categorizes the NAD device for Network Device Groups that may distinguish 

by different locations. For example, you may have Cisco Catalysts switches for the North America 

locations. 

To categorize device type: 

 Select Cisco ISE pxGrid > Failed Authentications 

 Select Device Type > All Device Types 
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The IP Address, Calling Station ID, and Username attributes provide basic information for end users 

associated with failure reasons. 

 

The Server Name, Authentication Protocol, Device Type, Location, Calling Station ID, NAS IP Address, 

NAS Port ID, and NAS Port Type attributes provide more authentication details and location information 

of failed authentication attempts. 

 

The Access Service attribute provides the ISE allowed protocol rules, the Identity Store attribute 

provides the back-end credential database of the needed end user, the Authentication Method 

attribute provides the ISE authentication rule, and the Credit Check attribute provides the EAP 

authentication method. 

 

  



SECURE ACCESS HOW-TO GUIDES 

Cisco Systems © 2021 Page 43 

 

 

 
 

  

  

The AD Host/User Resolved Identities, AD Host/User Resolved DNS, AD User Domain, AD User Net 

BIOS Name Host attributes in the following screenshot provides additional context around the host and 

user identities. 

 

Locations Panel 

The location panel provides insight into attempted by failures by NAD location type and provides a 

drill-down based on Locations. 

 Select Cisco ISE pxGrid > Failed Authentications 

 Select Location > All > All Location 

 

The IP Address, Calling Station ID, Username attributes provide basic information for end users 

associated with failure reasons. 
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The Server Name, Authentication Protocol, Device Type, Location, Calling Station ID, NAS IP Address, 

NAS Port ID, NAS Port Type attributes provide more authentication details and location information of 

failed authentication attempts. 

 

The AD Host/User Resolved Identities, AD Host/User Resolved DNS, AD User Domain, and AD User Net 

BIOS Name Host attributes in the following screenshots provide additional context around the host and 

user identities. 
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Devices 

The Devices Dashboard View provides the admin with visibility into the connected devices across the 

organization or by wired and wireless connection types. An organization may have a security policy 

about recommended or non-recommended devices for employees. The admin is able to drill down 

and see the owners of these devices and their location. This information is obtained from the Cisco ISE 

pxGrid App client subscribing to the Session Directory topic. 

The admin drills down on the endpoint profile and obtains the following contextual information: 

endpoint device information, MAC Address, IP Address, posture status, NAS Port Type, NAS Port ID, 

NAS Identifier, NAS IP Address, WLAN Information, Calling Station ID, Called Station ID, AD resolvable 

user and host identities. 

The AD resolvable user and host identities provide a consistent name format when different EAP 

methods are used, for example, EAP Chaining. 

 Select Cisco ISE pxGrid > Devices 

 Select EndProfile (All) > Windows7-Workstation 
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The Username, IP address and MAC address attributes are associated with the device. 

The NAS IP, NAS Port ID and NAS Port Type attributes contain the connection type information 

 

The NAS Identifier attribute may contain more information about the device such as the MAC address. 

The EndPoint Profile and Endpoint Operating System attributes provide the type of device and operating  

system.  
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The AD Username/Host and AD Resolved Username/Host identity attributes provide a consistent way 

of providing the username and hostname despite various EAP authentication types. 

 

The Is Machine Authentication attribute if set to "true" denotes that this is machine authentication. If it 

is set to "false", it denotes user authentication. 
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Compliance 

The Compliance Dashboard provides the admin with ISE posture compliant or non-compliant devices 

across the organization or by wired or wireless connection type. The organization may have security 

policy for their employees such as ensuring that AV DAT files are up-to-date and AV services must be 

running for compliance. If either of these are not the case, then the end user is deemed non-

compliance. 

 Select Cisco pxGrid > Compliance (All) 

 Select Compliant 

 

You will see a list of compliant end users along with the associated contextual information. 

The IP address, MAC address, Username, Calling Station ID and Posture Status attributes provide the 

basic user information. The NAS Port ID, NAS Port Type, NAS IP Address attributes contain the 

location and connection-type information. The State attribute determines the Postured Status. 



SECURE ACCESS HOW-TO GUIDES 

Cisco Systems © 2021 Page 51 

 

 

 
 

  

  

  



SECURE ACCESS HOW-TO GUIDES 

Cisco Systems © 2021 Page 52 

 

 

 
 

  

  

The Posture Status attribute contains the value of the posture status, compliant, non-compliance, and 

pending. 

The Endpoint Profile attribute is the device information of the end user along with the Endpoint 

Operating System attribute. 

 

The AD Username/Host and AD Resolved Username/Host identity attributes provide a consistent way 

of providing the username and hostname despite various EAP authentication types. 

 

The Is Machine Authentication attribute if set to "true" denotes that this is machine authentication. If 

set to "false" denotes user authentication.
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TrustSec 

The TrustSec dashboard contains the Security Group Tag (SGT) Information for assigned end users.  

This provides the admin with visibility to see which end user is associated with a SGT. For example, a 

SGT of Quarantined Systems, will provide a view of end users who have been assigned this label. 

 Select Cisco ISE pxGrid > Trustsec 

 Select Group Tag (All) 

 Select Quarantined Systems 

 

This provides the end-user information associated with the SGT. Here we see the Username, IP 

Address, and MAC Address attributes.  We also see the NAS IP Address, NAS Port ID, and NAS Port 

type attributes to determine the location and connection type. 
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This also provides the Endpoint Profile, Endpoint Operating System and AD normalized user/host names 

and AD user/host FQDN identities attributes. 

 

The AD Username/Host and AD Resolved Username/Host identity attributes provide a consistent way 

of providing the username and hostname despite various EAP authentication types. 

 

The Is Machine Authentication attribute if set to "true" denotes that this is machine authentication. If set 

to "false" denotes user authentication. 
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Mobile Device Management (MDM) 

The MDM Dashboard provides the admin with the visibility to look into an organizations MDM security 

policy. In the ISE 2.4 initial release, only the registration and compliance status are available. 

 Select Cisco ISE pxGrid > MDM 

 Select Compliance 

 

The Username, MAC Address, IP Address and Registration and Compliance Status attribute 

are available. 

 It is assumed that MDM is already configured in ISE. In this example, Cisco Meraki is 

used. 
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ANC Details 

The ANC Details Dashboard View provides visibility into the ANC policies currently assigned to 

endpoints MAC address. 

Select Cisco ISE pxGrid > ANC Details 
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Configuring Cisco ISE Adaptive Network Control Policies   

Cisco ISE Adaptive Network Control (ANC) Policies provide a means of enforcing an organization’s 

security policy by issuing a quarantine, port-bounce, or port-shut on the endpoint. When an endpoint 

is quarantined, this issues a Change of Authorization (CoA) and the endpoint is quarantined due to the 

organization’s security policy. The security policy may be just to monitor the traffic and take no action. 

In this case, a Security Group Tag (SGT) can be assigned. SGT are part of the Cisco TrustSec Solution 

and is used here for assigning labels to an organization’s security policy. As an example, Quarantined 

System SGT will be applied to an ANC quarantine policy to monitor and not enforce network access. 

Port-bounce will bounce the port the endpoint is connected to, and the end-user will be re-

authenticated. 

Port-Shut will issue a shutdown on the port the endpoint is connected. This is the most severe and 

may be issued if the endpoint is infected with malware and the malware is in suspect of propagating 

over file shares. 

These ISE ANC policies will be used by the Cisco ISE pxGrid app to enforce mitigation actions on the 

endpoints from either the Dashboard and Panels or through IBM QRadar system syslog events as long 

as the endpoint has been authenticated through ISE. 

The following Cisco ISE ANC policies will be created: 

• pxGridQRadarQuarantine - issues a quarantine 

• pxGridQRadarPortBounce - issues a port-bounce 

• pxGridQRadarShutDown - issues a shut down 

The Cisco ISE pxGrid app will read in the existing ISE ANC policies; however, these default ANC 

policies need to be configured first. Also, the Cisco ISE pxGrid app pxGrid client will need to be added 

to the pxGrid ANC Group. You will perform this exercise later on, when configuring the Cisco ISE 

pxGrid for pxGrid integration. 

Configuring Default ANC policies for Cisco ISE pxGrid App 

 

 Select Operations > Adaptive Network Control > Policy List > Add > The following for the Policy 

Name and Action: 

pxGridQRadarQuarantine, QUARANTINE 

pxGridQRadarPortBounce, PORT_BOUNCE  
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pxGridQRadatShutDown, SHUT_DOWN, 

 Select Save after Policy Name and associated action, you should see: 

 

Adding ANC Policies to ISE Policy Sets 

 Select Policy > Policy Sets > Default > ">" > Authorization Policy > Global Exceptions > "+" 

 Under Rule Name, type: ANC Quarantine 

 Under Conditions, select "+" 

 To close the introductory screen, select "x" 

 Under Dictionary, select Session > ANCPolicy > Equals > pxGridQRadarQuarantine 

 Select Use 

 Under Profiles, select Permit Access 

 Under Security Groups, select Quarantine_Systems 

 Select Save 

Perform steps 1-9 for the Rule Name ANCShutDown and ANCPolicy pxGridQRadarShutDown 
 

 You can also click on the Gear and duplicate line below and add the rule name and 

ANCPolicy 

Perform steps 1-9 for the Rule Name ANCPortBounce and ANCPolicy pxGridQRadarPorBounce 

 You can also click the Gear icon and duplicate line below and add the rule name and 

ANCPolicy 
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You should see the following: 
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Performing Cisco ISE ANC Mitigation Actions Through Cisco 
ISE pxGrid App Dashboard Panel   

This section steps the reader through performing ANC mitigation actions on the endpoint from the 

dashboards and panels. 

User pxGrid1 authenticates in ISE 

 

 Select Cisco ISE pxGrid > Passed Authentications 
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 Select an end user, pxGrid1, and then see the following: 

 

 Right-click on the IP address, and then see the ANC policies: 

 

 Select pxGridQRadarQuarantine 

 You should see a successful status message: 

 

 Select OK 
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 To view in ISE, select Operations > RADIUS LiveLogs 

Based on the ANCQuarantine Policy, the endpoint has been quarantined: 

 

 To view the quarantine details in the Cisco ISE pxGrid App ANC Dashboard, select Cisco ISE 

pxGrid > ANC Details 

See an example of the MAC Address of the quarantined endpoint: 

 

To view the details in the Cisco ISE pxGrid App TrustSec Dashboard, select Cisco ISE pxGrid > 

Trusts
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To see the quarantined endpoints, select Quarantined_Systems: 

 

You have the option of un-quarantine or clearing the endpoint either through the Dashboards 

or directly in ISE. We will un-quarantine the endpoint from this view. 

Right-click on the MAC Address: 
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Select pxGridQRadarClear 

You should see successful status message: 

 

Select OK 

To un-quarantine the endpoints and view the results in ISE: 

 Select Operations > RADIUS > Live Logs 
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Select Cisco ISE pxGrid > ANC Details, you should see the endpoint is no longer assigned to the 

ANC policy: 
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Configuring IBM QRadar for Cisco ISE Syslog Events   

The IBM Device Support Module (DSM) for Cisco Identity Service Engine (ISE) Syslog is installed by 

default on QRadar. For more information on DSM (beyond the scope of this guide) visit the DSM guide. 

 

 Configure log source on IBM QRadar 

 Configure both primary and secondary MNT log sources in an HA environment 

a. Open the IBM QRadar Console 

b. Select Admin > Data Sources > Log Sources  

 

c. Add in a new log source for Cisco ISE Syslog 

Add a new log source >  Single Source > Source Type: Identity Services Engine 

• Log Source Name and Description: Cisco_ISE 

• Log Source Type Cisco Identity Services Engine 

• Protocol Configuration: UDP Multiline Syslog 

• Log Source Identifier: IP Address of your ISE MNT node(s) 

• Listen port (leave default 517) 

• Message ID Pattern: CISE_\S+ (\d{10}) 

• Source Name Formatting String (researching) 

 For version 7.3, there will be a single screen configuration.  

 

ftp://ftp.software.ibm.com/software/security/products/qradar/documents/iTeam_addendum/b_dsm_guide.pdf
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 For QRadar 7.4, this will open a new application window and will take you through a 

guided configuration 

d. Select Save or Finish, close the new app window 

e. Select Deploy Changes > Deploy 
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Configuring Cisco ISE Syslog Events   

Cisco ISE will be configured to send syslog information to the IBM QRadar instance. Please make sure 

you have the QRadar ISE DSM installed. Future releases of the QRadar ISE DSM will include ISE syslog 

events such as Framed IP Address, IP address, where you can take ANC mitigation actions on the 

endpoint. 

Select Administration > System > Logging > Remote Logging Targets 

 Add in a new Remote logging target - Host/IP address of IBM QRadar instance:  

• Port – non-default 517 (QRadar UDP multiline listening port) 

• Maximum length of 8192 (to see complete logs instead of those truncated)  

• Include alarms for this Target (checked) 

 

 Select Submit/Save 

 Configure Logging Categories: 

Choose AAA Audit element > Edit 
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 Move QRadar from Targets Available into the Selected column. Don’t worry about the local 

logging checkbox, leave it alone. 

 

 Select Save 
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 Perform previous steps for additional elements: Passed Authentications, Failed Attempts, 

Accounting, RADIUS Accounting, Administration and Operational Audit, Posture and Client 

Provisioning Audit, and Profile 

 When completed, you should see elements with QRadar listed in the Targets column where 

appropriate 
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Performing ISE ANC Mitigation Actions Through IBM QRadar 
Syslog Events   

The desired endpoints for performing ANC mitigation actions must have been authenticated through 

ISE. In this example, we have Cisco ISE Passed Authentication syslog events sent over to IBM QRadar.  

We have to create a custom FramedIPAddress field to provide the IP address of the endpoint. 

 

The FramedIPAddress field will be added to the available columns field in the Log Activity Search 

created for ISE. 

The FramedIPAddress field will now appear in ISE Log Activity searches. 

 

Creating Custom Field for Framed IP Address ISE Syslog Event 

In IBM QRadar, select Log Activity > Search > New Search > Manage Groups  

Create New Group > Cisco_ISE 

You should see the Cisco ISE group: 
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 Close the Search groups page and select the newly created Cisco_ISE Group for Saved 

Searches 

 

 Keep the Search defaults 
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 Keep the column defaults 

 

 Under Search Parameters > Parameter > Quick Filters  

Select Log Source (Indexed) > Equals > Log Source Filter > Cisco_ISE Add Filter 
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 Click Search 

 

 

 In the upper right corner, click Pause, and then double-click Passed Auth (wired) or 

Radius_Acct (wireless) 

 Click Extract Property and for New Property, then type: FramedIPAddress 



SECURE ACCESS HOW-TO GUIDES 

Page 76 Cisco Systems © 2021 Page 76 

 

 

 
 

  

   

 

 For Field Type, type: IP 

For Description, type: FramedIPAddress 

For Extraction > RegEx > Type: Framed-IP-Address=(\b\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\b) 

You should see: 
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Select Test 

You should see: 

 

Select OK 

Select Save 
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Ensure you see you see the FramedIPAddress appear: 

 

Select Return to Event List 

Select Search > Edit Search > Saved Searches > Group: Cisco_IS 

Scroll down to Column Definition > Available Columns > FramedIPAddress(Custom) > Move to 

columns by selecting ">" 
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Select Filter
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Now, you should see the custom FramedIPAddress field 

 

ANC Mitigation Syslog Event Example 

The user has been successfully authenticated through ISE 

 

 In QRadar, select the syslog event, right-click FramedIPAddress,  and then select More 

Options 

In the following example, a Passed authentication (or RADIUS Accounting) syslog event was 

received from ISE: 
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 You can right-click the Source IP and Destination IP address. This will also work on 

customized IP Fields. 

 Select More Options > Cisco pxGrid – ANC Quarantine 
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 You should see a successful status message: 

 

 Select OK 

 To view in ISE, select Operations > RADIUS > Live Logs 

You should see the quarantined endpoint designated by the ANC Quarantine Policy: 

 

 To view in Cisco ISE pxGrid ANC Details Dashboard, select Cisco ISE pxGrid > ANC Details 

You should see the MAC address assigned to the ISE ANC policy name: 
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 To un-quarantine or clear the endpoint: 

Select ISE > Operations > Adaptive Network Control > Endpoint Assignment 

 

 Select the endpoint MAC address > Trash 

 

Select Selected, and then you should see: 

 

Select Yes 

In ISE, select Operations > RADIUS-Live Logs 
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You should see that the endpoint has been un-quarantined: 
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Hovering Over IBM QRadar Syslog IP Address for ISE 
Contextual Information   

Once the endpoint has been authenticated, you can hover the IP address fields and obtain additional 

contextual information such as the User Name, Mac Address, Posture Status, and Endpoint Profile. 

When you hover over the IP address field, the contextual information is displayed: 
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IBM QRadar Cisco ISE pxGrid Offense Rule   

IBM QRadar Custom Rules Engine (CRE) displays the rules and building blocks that are used by IBM 

QRadar. The CRE provides information about how the rules are groups, the types of tests that the rules 

perform, and the rule responses. A rule is a collection of tests that triggers an action when specific 

actions are met.  

Offenses are generated when events and flow data pass through the CRE. They are correlated against 

the rules that are configured and an offense can be generated based on this correlation and viewed on 

the Offenses tab. 

The Cisco pxGrid offense rule gets triggered when an event occurs, the match Radius Failure session 

or simply three events in the Cisco ISE pxGrid App Failed Authentication Dashboard from the same 

source IP address that occur within 10 minutes. 

As a simple test, you can attempt to log in with an invalid password, and then login successfully. This 

will trigger a failed event followed by a successful login. Repeat this step three or four times within 10 

minutes, and this will trigger the IBM QRadar pxGrid Offense rule. 

The following image is an example of ISE authentication failure report that confirms failed 

authentications. 
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You can also view events in ISE. 

 

Verify pxGrid offense rule via Log Activity 

 Select Log Activity > Add Filter > Parameter > Payload Contains > Operator > is any of > Value > 

QRadarAppForPxgrid > "+" 

 

Select Add Filter 

Select View Real Time Events > Last interval setting, for example, 45 minutes
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Click the offense rule  

You will see: 
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Verify pxGrid offense rule via Offenses Dashboard 

After select Offenses, you should see the pxGrid Radius Failure Offense rule: 

 

Taking ISE ANC mitigations from Offenses Dashboard 

 Under the Offense Source, right-click the IP address, and then select the Cisco pxGrid – ANC 

Quarantine mitigation action. 

 

 This will trigger the ANC Quarantine: 

 

 Select OK 
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 In ISE, select Operations > RADIUS > Live Logs 

 The endpoint has been quarantined as designated by the ANC Quarantine 

Authorization Policy 

 

 To un-quarantine or clear, select Operations > Adaptive Network Control > Endpoint Assignment 

 

 Select the endpoint > Trash 
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Select > Selected 

 

 Select Yes 

 In ISE, you should see the endpoint has been un-quarantined: 

 

Select Dashboard 
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Select pxGrid Radius Failure 

Hover over the Offense Source IP Address 
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Addendums 

Adding Log Activity Filter to View Session Information    

In this section, a pxGrid app filter is created to view the incoming session information.  

 Select Log Activity > Add Filter > Select the following:  

 

 Add the following search criteria:  

SELECT "pxGrid_adNormalizedUser" AS 'label' , COUNT("pxGrid_adNormalizedUser") AS 'value' FROM 
events WHERE LOGSOURCENAME(logsourceid)='pxGrid' AND "pxGrid_EventName"='User Sessions' GROUP 
BY "pxGrid_adNormalizedUser" ORDER BY value DESC LIMIT 10 LAST 1 DAYS 

 Click Search  
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 You should see the Cisco ISE pxGrid User Sessions  

 

Using an External Certificate Authority   

This section illustrates generating certificates for the IBM QRadar pxGrid App, using the ISE internal CA.  

It is assumed that the ISE pxGrid node and the other ISE nodes are signed by an external CA server. In 

this example, there are two ISE instances. The ISE26.lab20.com node is the primary ISE instance, and 

contains the Primary Admin, Primary MNT, Primary pxGrid node, and PSN personas. The 

ISE26ca.lab10.com node is the secondary ISE instance, and contains the Secondary Admin, Secondary 

MNT, Secondary pxGrid, and PSN personas.  

 Verify that the ISE pxGrid node, the ISE Admin and ISE MNT nodes are signed by the external CA 

Server  

Select Administration > System > Certificate > System > Certificates > System Certificates   

 The ISE pxGrid node and ISE Primary Admin node are signed by an external CA Server  
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 Verify the pxGrid certificate is signed by the external CA server and ensure that the admin 

certificate is signed by the external CA server as well  
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 Ensure that the published pxGrid nodes appear and you have pxGrid node connectivity: Select 

Administration > pxGrid Services  

Now, you see the following:  

 

 Ensure that there is pxGrid connectivity. If in the lower-left corner you see "no connectivity", 

there is a certificate issue with the ISE pxGrid node, the ISE admin and MNT nodes. 

  



SECURE ACCESS HOW-TO GUIDES 

Page 100 

 

Cisco Systems © 2021 

 

 

 

   

Generating IBM QRadar Certificate from ISE Internal CA   

In this example, the certificate is generated for the IBM QRadar instance using the ISE Internal CA. You 

can also use opens to create the private key, generate a Certificate Signing Request (CSR), and get this 

signed by the same customized template that was used for the ISE pxGrid node. To summarize, the 

customized template must have an EKU of both client and server authentication.  

 Create and generate certificate for the IBM QRadar instance:  

Select Administration > pxGrid Services > Certificates  

 

 From the I want to list, select Generate a single certificate without a signing request  

 In the Common Name (CN) box, enter the Fully Qualified Domain Name (FQDN) of the QRadar 

Instance  

 From the Subject Alternative Name (SAN) list, select the IP Address, and then enter the IP 

address of the QRadar instance  

 Provide a description name  

 From the Certificate Download Format list, select the PEM format  

 In the Certificate Password box, enter the encryption password  
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 In the Confirm Password box, enter the password once again 

  

 Select Create  

Copy the zipped file into a folder and unzip the files:  

  

Unencrypt the QRadar private key:  

Copy the original QRadar .key file to QRadar.key.org file: 

cp QRadar3.lab10.com_192.168.1.249.key QRadar3.lab10.com_192.168.1.249.key.org   

Then, run openness to remove the encryption password from the key.org file. You will get an 

unencrypted file as defined by the –out parameter. The unencrypted key will be the .key file.  

QRadar3.lab10.com_192.168.1.249.key.org -out QRadar3.lab10.com_192.168.1.249.key Enter pass 
phrase for QRadar3.lab10.com_192.168.1.249.key.org:(enter passphrase used when generating 
certificate) writing RSA key 

 Open ssl is on most Linux and MAC operating systems  
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To download the certificate root chain:  

Select Administration > pxGrid services > Certificates  

  

From the I want to list, select Download Root Certificate Chain  

In the Host Names box, select the ISE PAN Nodes: 

  

  

From the Certificate Downloaded Format list, select PEM format  

Select Create  

Download the zipped file into the same folder where you downloaded the QRadar certificate 

zipped files. Now, you see the following files: 
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Create a new folder, for example, QRadar_all_certs. Then, copy the ISE identity certificates, for 

example, ise26.lab10.cer and ise26ca.lab10.com, the QRadar certificate key-pair files, the 

external root CA, and the ISE certificate files into this new folder.  

 

 Please DO NOT copy the encrypted key.org file into the new folder 
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Troubleshooting  

Cisco ISE pxGrid App pxGrid client not showing under ISE pxGrid Client View 

If using an external CA server, upload the CA root certificate and include it in Root CA Certificate file 

name. 

Cisco ISE pxGrid App pxGrid client not showing under ISE pxGrid Web Client View 

Ensure that both the IBM QRadar SIEM and the Cisco ISE pxGrid node are FQDN are resolvable. 

Troubleshoot inside QRadar: 

 Take an SSH to the PxGrid Docker Container on QRadar  

• In QRadar versions 7.3.2 and above run the commands: 

1> /opt/qradar/support/recon ps 

2> /opt/qradar/support/recon  connect <App ID> 

• In QRadar versions 7.3.1 run the commands: 

1> /opt/qradar/support/qapp_utils_730.py ps 

2> /opt/qradar/support/qapp_utils_730.py connect <App ID> 

 Once you are inside the PxGrid docker container, enter the following command: 

• echo <ISE IP Address>   <FQDN> >> /etc/hosts 

e.g  echo 11.0.50.90  xyc.org.uk >> /etc/hosts  (Please Verify the ISE Ip Address and FQDN on your 
deployment from administration>>system>>deployment>>hostname in ISE) 

Cisco ISE pxGrid Dashboards not populating with ISE Contextual Information 

Ensure that the Cisco ISE pxGrid App appears under the ISE pxGrid Web Client View. 

ANC Mitigation Actions not appearing in Dashboards 

Ensure the app created the following ISE policies and you have them: 

• pxGridQRadarQuarantine - issues a quarantine 

• pxGridQRadarPortBounce - issues a port-bounce 

• pxGridQRadarShutDown - issues a port-shut 

  



SECURE ACCESS HOW-TO GUIDES 

Page 106 

 

Cisco Systems © 2021 

 

 

 

   

Using the IBM QRadar pxGrid App Logs for Troubleshooting    

The QRadar app logs are used for troubleshooting the connection between the QRadar pxGrid App and 

the ISE pxGrid node. For example, if the QRadar pxGrid client does not appear under the ISE pxGrid 

Clients View, you can view the QRadar app log to see if the secure web socket connection is 

established between the QRadar app and the ISE pxGrid node.  

To see the QRadar apps, type the following:  

[root@QRadar3 support]# /opt/qradar/support/recon  ps 

PORT   CONTAINER     IMAGE  STATUS  appID  NAME 

32768  28ac62f3a3d8  2cabd65ea8554650b3990bbdd83f59d8  RUNNING  1201  Cisco ISE 

pxGrid 

 Use Recon connect to retrieve the container contents:  

[root@QRadar3 support]# /opt/qradar/support/recon connect <<appID>> bash-4.1# ls 

App 

Bin 

boot 

Dev 

etc 

executeapp.bat 

home 

init 

lib 

lib64 

media 

mnt 

opt 

proc 

qpython 

root 

run.py 

sbin 

selinux 

src_deps 

srv 

start_container.sh 

start_flask.sh 

store 

Sys 

Tmp 

upgradePath.sh 

Usr 

var 

          

 For QRadar versions 7.3.2 and above, run the commands:  

1> /opt/qradar/support/recon ps   

2> /opt/qradar/support/recon connect <App ID>      

For QRadar versions 7.3.1, run the commands:  

1> /opt/qradar/support/qapp_utils_730.py ps   

2> /opt/qradar/support/qapp_utils_730.py connect <App ID>      

Use tail to view the app.log: bash-4.1# tail -f store/log/app.log  
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 A successful connection will look like this:  

2019-04-14 21:14:43,812 [abstract_qpylib.log] [Thread-1] [INFO] - 127.0.0.1 

[APP_ID/1201][NOT:0000006000] Primary Server: ise26.lab10.com 2019-04-14 21:14:43,812 
[abstract_qpylib.log] [Thread-1] [INFO] - 127.0.0.1  
[APP_ID/1201][NOT:0000006000] Secondary Server: 192.168.1.138  
2019-04-14 21:14:43,813 [abstract_qpylib.log] [Thread-1] [INFO] - 127.0.0.1  
[APP_ID/1201][NOT:0000006000] Current Active Server: primary  

2019-04-14 21:14:48,933 [abstract_qpylib.log] [Thread-1] [INFO] - 127.0.0.1  
[APP_ID/1201][NOT:0000006000] Account Activation Status: 200  

2019-04-14 21:14:48,933 [abstract_qpylib.log] [Thread-1] [INFO] - 127.0.0.1  
[APP_ID/1201][NOT:0000006000] Performing service lookup for:com.cisco.ise.pubsub  
19-04-14 21:14:49,280 [abstract_qpylib.log] [Thread-1] [INFO] - 127.0.0.1 
[APP_ID/1201][NOT:0000006000] Creating WebSocketClient....  
2019-04-14 21:14:49,282 [abstract_qpylib.log] [Thread-1] [INFO] - 127.0.0.1 
[APP_ID/1201][NOT:0000006000]  
Connecting to websocket  

2019-04-14 21:14:49,321 [abstract_qpylib.log] [Thread-1] [INFO] - 127.0.0.1 
[APP_ID/1201][NOT:0000006000] Connected and about to running for ever....  

2019-04-14 21:14:49,322 [abstract_qpylib.log] [WebSocketClient] [INFO] - 127.0.0.1  
[APP_ID/1201][NOT:0000006000] Subscribe request sent to websocket for 
/topic/com.cisco.ise.session  

2019-04-14 21:14:49,322 [abstract_qpylib.log] [WebSocketClient] [INFO] - 127.0.0.1  
[APP_ID/1201][NOT:0000006000] Subscribe request sent to websocket for 

/topic/com.cisco.ise.radius.failure  
2019-04-14 21:14:49,323 [abstract_qpylib.log] [WebSocketClient] [INFO] - 127.0.0.1  
[APP_ID/1201][NOT:0000006000] Subscribe request sent to websocket for 
/topic/com.cisco.ise.config.anc.status  
2019-04-14 21:14:49,324 [abstract_qpylib.log] [WebSocketClient] [INFO] - 127.0.0.1  
[APP_ID/1201][NOT:0000006000] Subscribe request sent to websocket for 
/topic/com.cisco.ise.mdm.endpoint 

 
 You should see a successful connection to the primary server connection and an 

activation status. You should also see a subscription to the pxGrid topic over a secure 

Websockets connection. Please disregard the *crypto messages and the unauthorized 

messages.  

 If you do not see a successful connection where there is no Primary server response, or the 

connection keeps switching between the primary and secondary pxGrid nodes, this can be an 

indication that some of the services have not started or may be in an inconsistent state. 

2019-04-14 20:20:57,799 [abstract_qpylib.log] [Thread-100] [INFO]  - 127.0.0.1  
[APP_ID/1201][NOT:0000006000] Primary  Server  Response: None  
2019-04-14 20:22:08,369 [abstract_qpylib.log] [Thread-103] [INFO]  - 127.0.0.1 

[APP_ID/1201][NOT:0000006000] Received  request  to test primary  files  
2019-04-14 20:22:08,374 [abstract_qpylib.log] [Thread-103] [INFO]  - 127.0.0.1 
[APP_ID/1201][NOT:0000006000] Trying  http connection .................. 2019-04-14 20:22:13,380 
[abstract_qpylib.log] [Thread-103] [INFO]  - 127.0.0.1 [APP_ID/1201][NOT:0000006000] Wraping  SSL 
socker  ..................   

You can stop or restart your app by using the IBM QRadar GUI Application Framework REST API 

endpoints. As a reference, see this page. 

 Stop the pxGrid App: 

https://www.ibm.com/support/knowledgecenter/SS42VS_7.3.2/com.ibm.appfw.doc/c_appframework_disableApp.html
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POST /api/gui_app_framework/applications/{app_id}?status="STOPPED"   
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 Start or restart the pxGrid app: 

a. Start the app: POST /api/gui_app_framework/applications/{app_id}?status="RUNNING"   

b. Restart the app:  

 Copy the PxGrid app ID: ssh to QRadar >> /opt/qradar/support/recon ps 

 In the GUI, open the QRadar Menu bar  

 Click the Interactive API for Developer  

 Click the drop button of the latest version >>gui_app_framework>>applications>>application_id 

 Under POST, enter the application_id 

 Update the status to STOPPED, then RUNNING, to stop and start the app 

 Review the QRadar app log again, or check to see if the pxGrid client appears under Web 

Clients on the ISE pxGrid node view  

 If you are stuck in the loading page, click Reset and change the date, to reflect a day before and 

a day after. There should be real-time authentications happening in ISE, so the session 

information can be seen in the IBM QRadar App.  
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Here are some more log issues with connectivity: 

pxGrid app pending state in the logs due to ISE pxGrid client not being approved  

This is showing the QRadar ISE pxGrid app as pending. You can see this under admin > pxGrid > All 

Clients. You should not see the app listed under Web Clients as it hasn’t been approved. You can 

manually approve it in the All clients page (this was noted in the setup section of the guide).  

Note: In order to automatically approve, for future connections you can allow under pxGrid > Settings > 

check the box to automatically approve certificate based connections. This is entirely up to the 

administrator choice depending on security concerns. Someone would have to create a certificate that 

ISE trusts either through external or internal PKI. 

 2021-02-02 17:35:00,088 [abstract_qpylib.log] [Thread-740] [INFO] 
- 127.0.0.1[APP_ID/1102][NOT:0000006000] Checking response got from primary server 
2021-02-02 17:35:00,088 [abstract_qpylib.log] [Thread-740] [INFO] 
- 127.0.0.1[APP_ID/1102][NOT:0000006000] Checking status from primary server: 200 
2021-02-02 17:35:00,088 [abstract_qpylib.log] [Thread-740] [INFO] 
- 127.0.0.1[APP_ID/1102][NOT:0000006000] Checking response from primary server: 
{"accountState":"PENDING","version":"2.0.3.14"} 

After its connected 

2021-02-02 20:40:00,097 [abstract_qpylib.log] [Thread-1193] [INFO] 
- 127.0.0.1[APP_ID/1102][NOT:0000006000] Checking response from primary server: 
{"accountState":"ENABLED","version":"2.0.3.14"} 

Not able to connect to ISE node from QRadar ISE pxGrid app 

These logs were seen when pointing Qradar ISE pxGrid app to the admin node of ISE (should be 

pointing to a pxGrid node) 

2021-02-02 17:20:04,148 [abstract_qpylib.log] [Thread-707] [INFO] 
- 127.0.0.1[APP_ID/1102][NOT:0000006000] Client Name Jabe02022021 
2021-02-02 17:20:04,148 [abstract_qpylib.log] [Thread-707] [INFO] 
- 127.0.0.1[APP_ID/1102][NOT:0000006000] URL /pxgrid/control/ServiceLookup 
2021-02-02 17:20:04,148 [abstract_qpylib.log] [Thread-707] [INFO] 
- 127.0.0.1[APP_ID/1102][NOT:0000006000] Service Name com.cisco.ise.pubsub 
2021-02-02 17:20:04,191 [abstract_qpylib.log] [Thread-707] [ERROR] 
- 127.0.0.1[APP_ID/1102][NOT:0000003000] Exception reported from invoke_cisco_ws_api method: <type 
'exceptions.ValueError'> 
2021-02-02 17:20:04,191 [abstract_qpylib.log] [Thread-707] [ERROR] 
- 127.0.0.1[APP_ID/1102][NOT:0000003000] Exception reported from invoke_cisco_ws_api method: No JSON 
object could be decoded 
2021-02-02 17:20:04,191 [abstract_qpylib.log] [Thread-707] [ERROR] 
- 127.0.0.1[APP_ID/1102][NOT:0000003000] Exception reported from subscribefromwebsocket method: <type 
'exceptions.ValueError'> 
2021-02-02 17:20:04,192 [abstract_qpylib.log] [Thread-707] [ERROR] 

- 127.0.0.1[APP_ID/1102][NOT:0000003000] Exception reported from subscribefromwebsocket method: No JSON 
object could be decoded 
2021-02-02 17:25:00,032 [abstract_qpylib.log] [Thread-718] [INFO] 
- 127.0.0.1[APP_ID/1102][NOT:0000006000] Checking http connection with primary server 

https://127.0.0.1/
https://127.0.0.1/
https://127.0.0.1/
https://2.0.3.14/
https://127.0.0.1/
https://2.0.3.14/
https://127.0.0.1/
https://127.0.0.1/
https://127.0.0.1/
https://127.0.0.1/
https://127.0.0.1/
https://127.0.0.1/
https://127.0.0.1/
https://127.0.0.1/
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2021-02-02 17:25:00,036 [abstract_qpylib.log] [Thread-718] [INFO] 
- 127.0.0.1[APP_ID/1102][NOT:0000006000] Checking connection with primary server using PROTOCOL_SSLv23 

 

TCP Dump to Analysis Failed Certificate Exchange in ISE  

In this section, we are going to see how we can download .pcap file for analysis from ISE, in case the 

certificate exchange fails, or the Client is not subscribing to topics.  

 Navigate to Operation > Troubleshoot > Diagnostic Tools > TCP Dump  

 From the Format drop-down list, select the Raw Packet Data, and then click Start  

  

 While you keep the TCP Dump running, log in to QRadar and reconfigure the App settings page  

 Stop the dump collection and download the .pcap file  

 Analyze the .pcap file using Wireshark and observe if there are any packets being dropped, 

Certificate exchange failing, or Unknown CA alert  

  

https://127.0.0.1/


SECURE ACCESS HOW-TO GUIDES 

Page 112 

 

Cisco Systems © 2021 

 

 

 

   

TCP Dump to Check if pxGrid Logs are Available in QRadar  

In this section, we are going to run few tcpdump commands in QRadar, to verify if pxGrid Logs are 

available in QRadar database, if the pxGrid Dashboard is not loading with data, or the Log Activity 

search does not show the pxGrid Events.  

 Take SSH to QRadar console  

 Find the PxGrid docker IP:  

/opt/qradar/support/recon ps  

/opt/qradar/support/recon connect <<App ID>>  

ifconfig (Ip associates with the  inet addr)  

 Run this command > tcpdump -nnAs0 -i any host <<PxGrid Docker Ip Address>> and port 514. 

Wait for few minutes if the Events are available on your ISE for the subscribed topic, then you 

should see events showing up in LEEF Format.  

Uploading Logs with the case 

Upload the following logs with the case can help our engineers assist you further: 

• qradar.error 

• startup.log 

• app.log 

 To get qradar.error logs, first we need to SSH to QRadar Console 

qradar.error logs are available in this location: /var/log/qradar.error 

 To get startup.log and app.log, first we need to get inside pxGrid App docker: 

 Login to QRadar console (putty/terminal) 

 Get the pxGrid APP ID execute this command: /opt/qradar/support/recon ps 

 The startup.log and app.log are available in this location: /store/docker/volumes/qapp-<<App 

ID>>/log 

 Replace App ID with pxGrid App ID from Step 2 

For example: /store/docker/volumes/qapp-110  
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