2 Replies Latest reply: Apr 12, 2018 5:29 PM by misoule01 RSS

Deployment Failed - Failed to Create User Data

misoule01

Hi all,

 

I have installed the C3 infrastructure, the CCO for the cloud region (VMware) shows Running status, mapped the Image ID for the cloud, and modeled a 1 tier application using only a single image mapping.

 

I found the following post and double checked everything it mentions: How does CloudCenter support VMware templates

 

Full error detail from UI: "Failed to launch VM's..failed to create userdata\n Additional logs for debugging is :Failed to launch VM's..failed to create userdata"

 

Searching through Kibana I found the following error messages from /usr/local/cliqr/logs/gateway.log, but unable to get more context. Is the bootstrap script a dependency or could it cause the error the UI reflected?

 

service.LifecycleClusterStartAction [threadPoolExecutor-5] - Exception occurred while launching VMs

impl.GatewayServiceImpl [threadPoolExecutor-5] - Failed to read linux bootstrap script from URL cdn.cliqr.com/bootstrap-cliqr-init.sh, but worker images should still work.

event.LifecycleEventProcessor [threadPoolExecutor-5] - Exception occurred while resolving Action-event.

service.LifecycleClusterStartAction [threadPoolExecutor-5] - Exception occured in lifecycle

 

I changed the level to debug on the gateway.log and got a little more, but still nothing that helps define what "user data" is. It just looks like it inits a new deployment is missing "userdata" and fails the deployment.

 

com.osmosix.gateway.GatewayServiceException: com.osmosix.gateway.GatewayServiceException: failed to create userdata

at com.osmosix.gateway.lifecycle.event.LifecycleAgentListener.onApplicationEvent(LifecycleAgentListener.java:7) [classes!/:4.8.2]

Caused by: com.osmosix.gateway.GatewayServiceException: failed to create userdata

... 28 more

at org.springframework.context.event.SimpleApplicationEventMulticaster.multicastEvent(SimpleApplicationEventMulticaster.java:139) [spring-context-4.3.11.RELEASE.jar!/:4.3.11.RELEASE]

at com.osmosix.gateway.impl.GatewayServiceImpl.createInstancesAsync(GatewayServiceImpl.java:633) ~[classes!/:4.8.2]

at java.net.URL.<init>(URL.java:439) ~[?:1.8.0_152]

at org.springframework.context.support.AbstractApplicationContext.publishEvent(AbstractApplicationContext.java:393) [spring-context-4.3.11.RELEASE.jar!/:4.3.11.RELEASE]

at com.osmosix.gateway.lifecycle.action.orchestration.common.AbstractNodeStartAction.launchAsync(AbstractNodeStartAction.java:255) ~[classes!/:4.8.2]

at org.springframework.context.support.AbstractApplicationContext.publishEvent(AbstractApplicationContext.java:347) [spring-context-4.3.11.RELEASE.jar!/:4.3.11.RELEASE]

Caused by: java.net.MalformedURLException: no protocol: cdn.cliqr.com/bootstrap-cliqr-worker.sh