cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2098
Views
10
Helpful
3
Replies

Limit Bandwidth Per VLAN on Nexus 3000 Series

Hey Everyone,

how can i limit TX/RX or Upload/Download per VLAN? on Nexus 3000?

Example

Vlan 10 = 20Mbps

Vlan 20 = 70Mbps

it is possible or not possible? thank you 

 
 

 

 

3 Replies 3

MaxShantar
Cisco Employee
Cisco Employee

To limit the bandwidth per VLAN on a Nexus 3000 running NX-OS, you can use the "rate-limit" command in the VLAN's interface configuration. Here's an example:

interface Ethernet1/1
   switchport mode access
   switchport access vlan 10
   rate-limit input 1000000 1000 10000 conform-action transmit exceed-action drop
   rate-limit output 1000000 1000 10000 conform-action transmit exceed-action drop

In this example, the bandwidth is limited to 1,000,000 bits per second (bps) for both input and output traffic on VLAN 10. The burst size is set to 1,000 bits and the maximum burst size is set to 10,000 bits. The "conform-action" is set to "transmit", which means that traffic within the specified rate limit will be allowed to pass. The "exceed-action" is set to "drop", which means that traffic that exceeds the rate limit will be dropped.

You can apply this configuration to any VLAN on the Nexus 3000 by replacing the interface (Ethernet1/1 in this example) and the VLAN number (10 in this example) with the appropriate values for your network.

Note: Before you use the "rate-limit" command, you should make sure that you have a good understanding of your network's bandwidth requirements and the impact of rate limiting on your network. You may need to adjust the rate limit and burst size values to achieve the desired result. It's also important to test the configuration carefully before implementing it in a production environment.

 

skydragoon
Level 1
Level 1

Hello,

Can kindly advise if the above config is appliable to Nexus 3548?  any idea for firmware required to have this feature?  thanks alot!

jamessmilleree
Level 1
Level 1

You can limit TX/RX or Upload/Download per VLAN on a Nexus 3000 switch by using Quality of Service (QoS) policies. Here's a concise solution:

Create QoS Policies:

Log in to your Nexus 3000 switch.
Define QoS policies for each VLAN that specify the desired bandwidth limits. For example:

SQL

vlan 10
bandwidth percent 20
vlan 20
bandwidth percent 70

Apply QoS Policies:

Apply these QoS policies to the respective VLAN interfaces:

GraphQL

interface vlan 10
service-policy type queuing input vlan10-policy
service-policy type queuing output vlan10-policy
interface vlan 20
service-policy type queuing input vlan20-policy
service-policy type queuing output vlan20-policy

Verify Configuration:

To ensure that the configuration is applied correctly, use the show policy-map interface command to verify the QoS settings for each VLAN interface.
This will limit the TX/RX or Upload/Download bandwidth for VLAN 10 to 20Mbps and VLAN 20 to 70Mbps, as per your example.

 

Thanks