cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1298
Views
0
Helpful
0
Replies

GigaEtherchannel+Dot1q configuration

Nicolas Woycik
Level 1
Level 1

Hi all,

I would like someone to help me regarding the following issue that I have found trying to configure Etherchannel+dot1q in a b2b connection from an ES20+ port to a LAN SW board.

We have a 7600 with c7600rsp72043-advipservicesk9-mz.122-33.SRE3.

show module
Mod Ports Card Type                              Model             
--- ----- -------------------------------------- ------------------ -----------
  1    0  4-subslot SPA Interface Processor-400  7600-SIP-400      
  2    0  4-subslot SPA Interface Processor-400  7600-SIP-400      
  3   48  CEF720 48 port 10/100/1000mb Ethernet  WS-X6748-GE-TX    
  4   22  7600 ES+                               76-ES+XC-40G3CXL  
  5    2  Route Switch Processor 720 (Hot)       RSP720-3CXL-GE    
  6    2  Route Switch Processor 720 (Active)    RSP720-3CXL-GE   

There are two b2b connections between Gi3/1-2 -> 4/0/0-1

I'm trying to configure the following:

!#############################################################
!Initial Conf:
!#############################################################
!
vlan 2
name VLAN0002
!
interface GigabitEthernet3/1
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
switchport nonegotiate
mls qos trust dscp
spanning-tree portfast trunk
spanning-tree bpduguard disable
spanning-tree link-type point-to-point
channel-group 40 mode on
no shut
!
interface GigabitEthernet3/2
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
switchport nonegotiate
mls qos trust dscp
spanning-tree portfast trunk
spanning-tree bpduguard disable
spanning-tree link-type point-to-point
channel-group 40 mode on
no shut
!
interface Port-channel40
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
switchport nonegotiate
mls qos trust dscp
no shut
!
interface GigabitEthernet4/0/0
mac-address 0248.0010.0400
mtu 1650
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1500
load-interval 30
speed 1000
no mls qos trust
channel-group 45 mode on
hold-queue 1500 in
no shut
!
interface GigabitEthernet4/0/1
mac-address 0248.0010.0401
mtu 1650
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1500
load-interval 30
speed 1000
no mls qos trust
channel-group 45 mode on
hold-queue 1500 in
no shut
!
interface Port-channel45
mtu 1650
no ip address
no shut
!
interface Port-channel45.2
no shut
end
!
!#############################################################
!                          TESTS
!#############################################################
!Verify : Po40 (Switch Card), Po45 (ES Card) and vlan 2
!#############################################################
!
BB1#show etherchannel 40 summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
40     Po40(SU)         -        Gi3/1(P)    Gi3/2(P)

Last applied Hash Distribution Algorithm: Fixed
!
!
BB1#show etherchannel 45 summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
45     Po45(RU)         -        Gi4/0/0(P)  Gi4/0/1(P)

Last applied Hash Distribution Algorithm: Fixed
!
BB1#show vlan brief
*Apr 28 14:48:46.411: %SYS-5-CONFIG_I: Configured from console by console

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active
2    VLAN0002                         active
3    vlan_3_prueba                    active
1002 fddi-default                     act/unsup
1003 trcrf-default                    act/unsup
1004 fddinet-default                  act/unsup
1005 trbrf-default                    act/unsup
!
!#############################################################
!Error trying to create a sub-interface dot1q with the Po45
!#############################################################
!
BB1(config)#int port-channel 45.2
BB1(config-subif)#encapsulation dot1Q 2
Command rejected: VLAN 2 cannot be allocated. VLANs 1-1005 are VTP VLANs
VTP mode is client or server and must be changed to Transparent to use VLANs 1-1005
!
!#############################################################
!Change to VTP Mode Transparent/Server to test on transparent mode
!with dot1Q 2
!#############################################################
!
BB1(config-subif)#exit
BB1(config)#vtp mode transparent
Setting device to VTP Transparent mode for VLANS.
BB1(config)#int po45.2
BB1(config-subif)#encapsulation dot1Q 2
Command rejected: VLAN 2 not available
!
!#############################################################
!Now we can assign with dot1Q from the 1005 vlan but it does not allow
!to creat the vlan in the switch board
!#############################################################
!
BB1(config)#vtp mode transparent
Setting device to VTP Transparent mode for VLANS.
BB1(config)#
!
BB1#show vtp status
VTP Version capable             : 1 to 3
VTP version running             : 3
VTP Domain Name                 : BB1
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : 8843.e1de.bb00

Feature VLAN:
--------------
VTP Operating Mode                : Transparent
Number of existing VLANs          : 7
Number of existing extended VLANs : 0


Feature MST:
--------------
VTP Operating Mode                : Transparent


Feature UNKNOWN:
--------------
VTP Operating Mode                : Transparent
!
BB1(config)#int po45.2
BB1(config-subif)#encapsulation dot1Q 1006
BB1(config-subif)#ip address 10.10.10.1 255.255.255.0
BB1(config-subif)#exit
BB1(config)#vlan 1006
VLAN id: 1006 is an internal vlan id - cannot use it to create a VTP VLAN.
!
BB1(config)#int po45.2
BB1(config-subif)#no encapsulation dot1Q 1006
BB1(config-subif)#exit
BB1(config)#vlan 1006
BB1(config-vlan)#name Test
BB1(config-vlan)#exit
BB1(config)#int po45.2
BB1(config-subif)#encapsulation dot1Q 1006
Command rejected: VLAN 1006 not available
BB1(config-subif)#exit
!
BB1(config)#vtp mode server
Setting device to VTP Server mode for VLANS.
BB1(config)#
BB1#show vtp status
VTP Version capable             : 1 to 3
VTP version running             : 3
VTP Domain Name                 : BB1
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : 8843.e1de.bb00

Feature VLAN:
--------------
VTP Operating Mode                : Server
Number of existing VLANs          : 7
Number of existing extended VLANs : 1
Configuration Revision            : 0
Primary ID                        : 0000.0000.0000
Primary Description               :
MD5 digest                        : 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00
                                    0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00


Feature MST:
--------------
VTP Operating Mode                : Transparent


Feature UNKNOWN:
--------------
VTP Operating Mode                : Transparent
!
BB1(config)#int po45.2
BB1(config-subif)#encapsulation dot1Q 1006
Command rejected: VLAN 1006 not available
!

May someone help me to understand what I'm doing wrong, or if there is a bug or something with this kind of scenario?.

Thanks in advance for your help.

0 Replies 0