cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
408
Views
2
Helpful
20
Replies

Unable to ping between two tunnel points

noforshow92
Level 1
Level 1

Hello, I built using the packet tracer a simple topology of three routers with ospf routing. I created a tunnel between the two routers that are not physically connected to each other, but I can't ping between one end and the other. I managed to ping between two in loopbacks. 

hanks for all replies.

 

Router#show run

Building configuration...

 

Current configuration : 1084 bytes

!

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

ip cef

no ipv6 cef

!

!

!

!

license udi pid CISCO2911/K9 sn FTX152412Z5-

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface Loopback0

ip address 10.10.10.254 255.255.255.0

!

interface Tunnel0

ip address 100.100.100.10 255.255.255.0

mtu 1476

tunnel source Loopback0

tunnel destination 20.20.20.254

!

!

interface GigabitEthernet0/0

ip address 10.0.1.1 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.0.5.1 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

duplex auto

speed auto

shutdown

!

interface Vlan1

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

network 10.0.1.0 0.0.0.255 area 0

network 192.168.1.1 0.0.0.0 area 0

network 100.100.100.0 0.0.0.3 area 0

network 10.0.5.0 0.0.0.255 area 0

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

____________________________________________

 

Router#show run

Building configuration...

 

Current configuration : 1084 bytes

!

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

ip cef

no ipv6 cef

!

!

!

!

license udi pid CISCO2911/K9 sn FTX152412Z5-

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface Loopback0

ip address 10.10.10.254 255.255.255.0

!

interface Tunnel0

ip address 100.100.100.10 255.255.255.0

mtu 1476

tunnel source Loopback0

tunnel destination 20.20.20.254

!

!

interface GigabitEthernet0/0

ip address 10.0.1.1 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.0.5.1 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

duplex auto

speed auto

shutdown

!

interface Vlan1

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

network 10.0.1.0 0.0.0.255 area 0

network 192.168.1.1 0.0.0.0 area 0

network 100.100.100.0 0.0.0.3 area 0

network 10.0.5.0 0.0.0.255 area 0

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

 

1 Accepted Solution

Accepted Solutions

Hi @noforshow92 ,

I made the modification to use the physical interface instead of the loopback interface as recommended previously and it works for me.

Router2:

interface Tunnel0

ip address 100.100.100.10 255.255.255.0

mtu 1476

tunnel source GigabitEthernet0/0

tunnel destination 10.0.2.1

!

Router1:

interface Tunnel0

ip address 100.100.100.20 255.255.255.0

mtu 1476

tunnel source GigabitEthernet0/1

tunnel destination 10.0.1.1

!

Router#ping 100.100.100.10

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 100.100.100.10, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms

Router#ping 100.100.100.20

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 100.100.100.20, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

20 Replies 20

Harold Ritter
Cisco Employee
Cisco Employee

Hi @noforshow92 ,

You attached the same configuration twice, but what we can see from this configuration. You use the loopback0 as the source for the tunnel interface, but you don't advertise loopback0 in ospf. I would recommend you change the following:

interface Loopback0

ip address 10.10.10.254 255.255.255.255 

router ospf 1

network 10.10.10.254 0.0.0.0 area 0

Make sure you do the same on the router.

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

HI harold, thank you very much for the answer.

I added the loopbacks in ospf on both routers

router ospf 1

log-adjacency-changes

network 10.0.1.0 0.0.0.255 area 0

network 192.168.1.1 0.0.0.0 area 0

network 100.100.100.0 0.0.0.3 area 0

network 10.0.5.0 0.0.0.255 area 0

network 10.10.10.0 0.0.0.255 area 0

__________

router ospf 1

log-adjacency-changes

network 10.0.2.0 0.0.0.255 area 0

network 192.168.1.2 0.0.0.0 area 0

network 0.0.0.0 255.255.255.255 area 0

network 100.100.100.0 0.0.0.3 area 0

network 10.0.8.0 0.0.0.255 area 0

network 20.20.20.0 0.0.0.255 area 0

 

I manage to ping between the two loopbacks, but still can't ping between the two ends of the tunnel (I managed to ping between the loopbacks before as well)

 

Hi @noforshow92 ,

Can you attach the following information for both tunnel endpoints:

show ip route

show runn int tu0

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Router 1

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

C 10.0.1.0/24 is directly connected, GigabitEthernet0/0

L 10.0.1.1/32 is directly connected, GigabitEthernet0/0

O 10.0.2.0/24 [110/2] via 10.0.1.2, 02:47:42, GigabitEthernet0/0

C 10.10.10.254/32 is directly connected, Loopback0

20.0.0.0/32 is subnetted, 1 subnets

O 20.20.20.254/32 [110/3] via 10.0.1.2, 02:47:42, GigabitEthernet0/0

100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C 100.100.100.0/24 is directly connected, Tunnel0

L 100.100.100.10/32 is directly connected, Tunnel0

 

Router#show interfaces tunnel 0 | include destination

Tunnel source 10.10.10.254 (Loopback0), destination 20.20.20.254

____________________________

Router 2

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

O 10.0.1.0/24 [110/2] via 10.0.2.2, 02:48:02, GigabitEthernet0/1

C 10.0.2.0/24 is directly connected, GigabitEthernet0/1

L 10.0.2.1/32 is directly connected, GigabitEthernet0/1

O 10.10.10.254/32 [110/3] via 10.0.2.2, 01:30:32, GigabitEthernet0/1

20.0.0.0/32 is subnetted, 1 subnets

C 20.20.20.254/32 is directly connected, Loopback0

100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C 100.100.100.0/24 is directly connected, Tunnel0

L 100.100.100.20/32 is directly connected, Tunnel0

 

Router#show interfaces tunnel 0 | include destination

Tunnel source 20.20.20.254 (Loopback0), destination 10.10.10.254

Never Never 

Make tunnel source and tunnel IP in same IGP

Remove the tunnel IP subnet from ospf 

And ypu can ping tunnel IP directly no need ospf (or any IGP)

Just do 

Ping < tunnel IP peer2 > source < tunnel IP peer1>

Note in ping I use tunnel IP not tunnel source or destination 

MHM

HI,

I removed the IP of the tunnel from the ospf list, but I still can't ping the IP of the tunnel at the other end

_______________________________

router ospf 1

log-adjacency-changes

network 10.0.1.0 0.0.0.255 area 0

network 192.168.1.1 0.0.0.0 area 0

network 10.0.5.0 0.0.0.255 area 0

network 10.10.10.0 0.0.0.255 area 0

network 10.10.10.254 0.0.0.0 area 0

show ip interface brief 

and share how you ping (I need to see command you use)

MHM

Here:

Router 1

Router#show ip interface brief

Interface IP-Address OK? Method Status Protocol

GigabitEthernet0/0 10.0.1.1 YES manual up up

GigabitEthernet0/1 10.0.5.1 YES manual up down

GigabitEthernet0/2 unassigned YES unset administratively down down

Loopback0 10.10.10.254 YES manual up up

Tunnel0 100.100.100.10 YES manual up up

Vlan1 unassigned YES unset administratively down down

_______________________

Router 2

Router#show ip interface brief

Interface IP-Address OK? Method Status Protocol

GigabitEthernet0/0 10.0.8.1 YES manual up down

GigabitEthernet0/1 10.0.2.1 YES manual up up

Loopback0 20.20.20.254 YES manual up up

Tunnel0 100.100.100.20 YES manual up up

Vlan1 unassigned YES unset administratively down down

_____________________

ping

 

Router#ping 100.100.100.20

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 100.100.100.20, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

ping 100.100.100.20 source 100.100.100.10

do this 

MHM

I'm sorry, what do you mean source 100.100.100.10?

I'm pinging from router 2 (the one with the loopback 10.10.10.254) to 100.100.100.20

Hi @noforshow92 ,

I believe the tunnel not working when using the loopback interface is some kind of Packet Tracer limitation. Try using the physical interface addresses as the tunnel source and destination and it should work.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

HI Harold,

I changed the source from the loopbacks to one of the physical ports, but still can't send a ping to the address of the tunnel

 

 

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

O 10.0.1.0/24 [110/2] via 10.0.2.2, 00:58:57, GigabitEthernet0/1

C 10.0.2.0/24 is directly connected, GigabitEthernet0/1

L 10.0.2.1/32 is directly connected, GigabitEthernet0/1

O 10.0.5.0/24 [110/3] via 10.0.2.2, 00:16:58, GigabitEthernet0/1

20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C 20.0.6.0/24 is directly connected, GigabitEthernet0/2

L 20.0.6.1/32 is directly connected, GigabitEthernet0/2

100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C 100.100.100.0/24 is directly connected, Tunnel0

L 100.100.100.20/32 is directly connected, Tunnel0

 

Router#show interfaces tunnel 0 | include destination

Tunnel source 20.0.6.1 (GigabitEthernet0/2), destination 10.0.5.1

___________________________________

 

10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks

C 10.0.1.0/24 is directly connected, GigabitEthernet0/0

L 10.0.1.1/32 is directly connected, GigabitEthernet0/0

O 10.0.2.0/24 [110/2] via 10.0.1.2, 01:06:06, GigabitEthernet0/0

C 10.0.5.0/24 is directly connected, GigabitEthernet0/1

L 10.0.5.1/32 is directly connected, GigabitEthernet0/1

C 10.10.10.0/24 is directly connected, Loopback0

L 10.10.10.254/32 is directly connected, Loopback0

20.0.0.0/24 is subnetted, 1 subnets

O 20.0.6.0/24 [110/3] via 10.0.1.2, 01:04:52, GigabitEthernet0/0

100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C 100.100.100.0/24 is directly connected, Tunnel0

L 100.100.100.10/32 is directly connected, Tunnel0

 

Router#show interfaces tunnel 0 | include destination

Tunnel source 10.0.5.1 (GigabitEthernet0/1), destination 20.0.6.1

Hi @noforshow92 ,

Could you please zip the packet trace file and upload so we can check it.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Review Cisco Networking products for a $25 gift card