7 Replies Latest reply: Apr 16, 2010 10:04 AM by niversen@xangati.com RSS

Can't remove DVS configuration


My VEM has become completely disconnected from reality.  It is connected to the VSM, but that is all that is correct about it.  It will not sychronize with the VSM without errors.  One one resynch, it moved all the uplink ports into the "Unused and Qurantine" port group. 


I removed all vmnics from the DVS and have tried to delete the DVS using the "no vmware dvs" command.  This returns the error:


"VMware vCenter Server 4.0.0 build-208111 DVS operation failed on host 10.x.x.x, The object or item referred to could not be found.  got (vim.fault.NotFound) exception.  Cannot complete a Distributed Virtual Switch operation for one or more host members."


This is the same error that is pushed no matter what I try to do with the DVS. If I "no connect" and then "connect" I get this.


I looked in the FAQ:  https://communities.cisco.com/docs/DOC-14464#stale-vem to try to remove the config manually.


The VEM is on an ESXi, so I can only use VMA - there is no service console to execute the shell commands listed in the FAQ like "net-dvs". 


How can I get rid of the corrupted DVS?  I need to cut my losses and re-build this DVS to get on with what I need to do.