5 Replies Latest reply: Aug 1, 2013 10:49 AM by gstreete RSS

Cisco Network Access Manager install failing

mmistrettammistretta@nahospital.org

When i try to install NAM, i get an error that it ended prematurely.  It also breaks my wireless networking to where i can no longer connect to, nor see, any network. Uninstalling does not fix it. I have installed it fine on other machines, its only this one, and of course the one i need it to work on, that fails.

In order to get my wireless working again, i have to attempt the install several times again, and watch it fail everytime, but alas i will get lucky and my wireless will start working again.

Has anyone seen this before?

  • 1. Re: Cisco Network Access Manager install failing
    gstreete

    Do you have the Cisco IPSec client also installed on your computer?  What version of Anyconnect NAM and Windows OS?  Has the DART logs given any clues?

     

    I see about three TAC cases on that very issue but in each ticket the customer resolved it on their own so there was no good information. But the one ticket seemed to point to the registry fix per this Tech Zone Article here below.

     

    Could this be what you may be experiencing?

    https://techzone.cisco.com/t5/802-1x/Solution-Unable-to-install-Anyconnect-NAM-3-0-on-Windows/ta-p/85286

     

    We have also seen in the Anyconnect 3.0 NAM module alone randomly fails to install when the AC package is installed using the Microsoft SCCM tool. All other AC modules(VPN, Web security, DART) install without any failures but the NAM randomly fails to install on different machines. A manual install of the NAM module is successful on that machine though.

     

    But in this instance the failed install does not produce any error messages and just hangs at installation thus providing no way of determining if the installation is successful or not.  So that seems different to what you are seeing.

     

    In that case some success has been seen when uninstalling cisco vpn client (not always ) and trend FW ( again not always) but we have no root cause as the results are varied.

     

    I would suggest calling TAC if the above article does not fix the issue ( which is my best guess) and looking at uninstalling all Cisco VPN clients reboot and start over.

     

    Hope this helps.

     

    Glenn

  • 2. Re: Cisco Network Access Manager install failing
    mmistrettammistretta@nahospital.org

    Hi Glenn,

     

    I do have the IPSec client installed as well, i have many customer that still use this...

    I receive the error "Installation success or error status: 1603." in the DART logs.

    All it tells me is the install failed, nothing more.

    I tried using the setup extracted from the anyconnect iso, and tried to install it from the exe itself, and both fail.

    You are correct about what i am seeing.  It does tell me that it is rolling back, and that the install ended prematurely, so i do receive a failure notification, but the DART, nor windows logs, tell me much more as to why.

    I have also tried uninstalling the anyconnect and then reinstalling the whole package to no avail, i will try it while uninstalling the IPSec.

     

    As for the article, i do not have access to the techzone so i am not able to retrieve that article.

     

    I will let you know how things go after uninstalling the IPSec client.

     

    thanks for your response

     

    Mike

  • 3. Re: Cisco Network Access Manager install failing
    gstreete

    Solution: Unable to install Anyconnect NAM 3.0 on Windows

     

    Symptoms

    Anyconnect NAM fails installation.

    The install attempt appears to be progressing, errors out and then rolls back.

    Seen typically on Windows machines.

    Cause / Problem Description

    This is due to reaching the max number of filters.

    Inspection of the anyconnect-nam-win3.1.xxx logs taken from the DART bundle off the affected machine reveal the following:

    INFO   : (0x0) ENTER:  DriverPackageInstallA
    INFO   : (0x0) ENTER:  DriverPackageInstallW
    INFO   : (0x0) Copied 'acnamfd.inf' to driver store...
    INFO   : (0x0) Copied 'acnamfd.cat' to driver store...
    INFO   : (0x0) Commiting queue...
    INFO   : (0x0) Copied file: 'C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\drv\acnamfdbctl.dll' -> 'C:\Windows\system32\DRVSTORE\acnamfd_66BFB5ABA45AE2C231FD41ADBD2117ECBE4CA524\acnamfdbctl.dll'.
    INFO   : (0x0) Copied file: 'C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\drv\acnamfd.sys' -> 'C:\Windows\system32\DRVSTORE\acnamfd_66BFB5ABA45AE2C231FD41ADBD2117ECBE4CA524\acnamfd.sys'.
    INFO   : (0x0) installing network driver 'C:\Windows\system32\DRVSTORE\acnamfd_66BFB5ABA45AE2C231FD41ADBD2117ECBE4CA524\acnamfd.inf'
    ERROR  : (0x0) Error 0x8004A029 encountered while installing the inf 'C:\Windows\system32\DRVSTORE\acnamfd_66BFB5ABA45AE2C231FD41ADBD2117ECBE4CA524\acnamfd.inf'. Unable to install network component 'CSCO_acnamfd'
    ERROR  : (0x0) Failed to install the network driver INF C:\Windows\system32\DRVSTORE\acnamfd_66BFB5ABA45AE2C231FD41ADBD2117ECBE4CA524\acnamfd.inf. Error code 0x643
    ERROR  : (0x643) The driver installation failed. Attempting to undo system changes ...
    INFO   : (0x0) Successfully removed '{2E3F1E2E-AB24-42A1-AE26-5D8EAF83AF94}' from reference list of driver store entry ''
    INFO   : (0x0) Driver Store entry '' removed.
    INFO   : (0x0) RETURN: DriverPackageInstallW  (0x643)
    INFO   : (0x0) RETURN: DriverPackageInstallA  (0x643)
    Install failed with status 0x643 -- ERROR_INSTALL_FAILURE(643)

    Conditions / Environment

    May be seen on windows machines that have been in production for a while as opposed to a new/clean windows machine.

     

     

    Resolution

    Increase the "MaxNumFilters" to 14

    It can be increased by editing the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network

     

    Perform the Anyconnect NAM install after making this change.

  • 4. Re: Cisco Network Access Manager install failing
    mmistrettammistretta@nahospital.org

    Hi Glenn,

     

    I went ahead and made the registry change, and uninstalled the IPSec client. After doing this, NAM installed!.

     

    Thanks much for your response, i greatly appreciate your help.