cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1331
Views
4
Helpful
8
Replies

Record Element Delay

Joe Gilbert
Level 1
Level 1

I have a standard record element that works normally most of the time. In about 2/40 instances, the record element does not start recording until DTMF is pressed. I didn't think this was necessary. Is there something I have misconfigured?

record.png

First case (the initial audio group didn't play until 16 minutes later)

08/24/2016 23:45:22.873,wsLookup,exit,Success

08/24/2016 23:45:22.873,Record_Prompt,enter,

08/25/2016 00:01:44.578,Record_Prompt,interaction,audio_group,initial_audio_group

08/25/2016 00:02:03.441,Record_Prompt,data,duration,14670

08/25/2016 00:02:03.441,Record_Prompt,data,size,116720

08/25/2016 00:02:03.441,Record_Prompt,data,termchar,1

08/25/2016 00:02:03.441,Record_Prompt,data,maxtime,false

08/25/2016 00:02:03.441,Record_Prompt,data,filename,2016824-2345.wav

08/25/2016 00:02:03.441,Record_Prompt,data,filepath,C:\2016824-2345.wav

08/25/2016 00:02:03.441,Record_Prompt,exit,done

08/25/2016 00:02:03.441,smb_copy,enter,

Second case (the initital audio group plays twice with 18 minutes of silence in between)

09/02/2016 10:01:37.098,wsLookup,exit,Success

09/02/2016 10:01:37.098,Record_Prompt,enter,

09/02/2016 10:01:37.098,Record_Prompt,interaction,audio_group,initial_audio_group

09/02/2016 10:19:38.702,Record_Prompt,interaction,audio_group,initial_audio_group

09/02/2016 10:19:45.229,Record_Prompt,data,duration,2180

09/02/2016 10:19:45.229,Record_Prompt,data,size,16800

09/02/2016 10:19:45.229,Record_Prompt,data,termchar,1

09/02/2016 10:19:45.229,Record_Prompt,data,maxtime,false

09/02/2016 10:19:45.229,Record_Prompt,data,filename,201692-101.wav

09/02/2016 10:19:45.229,Record_Prompt,data,filepath,C:\201692-101.wav

09/02/2016 10:19:45.229,Record_Prompt,exit,done

09/02/2016 10:19:45.229,smb_copy,enter,

8 Replies 8

janinegraves
Spotlight
Spotlight

1. Pressing a dtmf should not be required to start the recording. Are

you sure you're not preceding this element with something that's waiting

for input?

2. Can you post the Settings and Audio tab of the Voice element just

prior to the WS element?

How long is the audio that is played in the Voice Element just prior to

the WS element?

And have you configured the VXML Property Name: fetchtimeout Value: 10s

(or some amount of time for the WS to complete)?

3. These might be relevant because Audio elements are non-blocking (they

play asynchronously) - so the gateway ALWAYS returns immediately (15ms)

and the app moves forward. However, once you're waiting for caller input

(like Record or Digits elements) the gateway MUST wait for all the

queued up audio to finish playing. That might be what you're experiencing...

3. The only times I've ever seen the Initial Audio Group play twice

without being marked as a NoInput or NoMatch is when it's in a

confirmation element and you've allowed the Reply:true option under

Settings and the caller either presses 3 (to trigger replay) or says the

word 'replay'.

Thank you for the reply, Janine.

1. The record element is preceded by a web service lookup which I would normally be suspicious of but in both cases it seems to finish successfully.

2. The voice element before the web service is a digits with confirmation. The various audio prompts played are between 5-10 seconds long. I do have the fecthtimeout set for 10 seconds in the project settings.

image1.png

image2.png

image3.png

image4.png

image5.png

image6.png

Are you aware that the FinalSilence setting doesn't work? The gateway doesn't detect silence when the caller finishes their recording. So the caller MUST press a DTMF tone to complete their recording. The only other way the system will stop recording, is when the allotted MaxTimeout or recording memory space configured on the gateway is full (ivr record memory session #kb). And in that case, the system assumes the recording was successful.

This may not sounds like your issue, but it might be worth ensuring that the Initial Prompt in your Record element SPECIFICALLY tells the caller to press a key to complete their recording.

Also, you've configured the Record element to allow up to 1800s of recording. Another customer recently found a gateway bug where the gateway can NOT take recordings longer than 17 minutes. That sounds awfully close to your 16 minute issue. I suspect it's the same issue.

Hope this helps.

I don't think I've explained the issue correctly. The issue is not that the recording is ending prematurely but the recording is not starting. I'll use my 2nd example from above.

09/02/2016 10:01:37.098,wsLookup,exit,Success

09/02/2016 10:01:37.098,Record_Prompt,enter,

09/02/2016 10:01:37.098,Record_Prompt,interaction,audio_group,initial_audio_group

09/02/2016 10:19:38.702,Record_Prompt,interaction,audio_group,initial_audio_group

09/02/2016 10:19:45.229,Record_Prompt,data,duration,2180

09/02/2016 10:19:45.229,Record_Prompt,data,size,16800

09/02/2016 10:19:45.229,Record_Prompt,data,termchar,1

09/02/2016 10:19:45.229,Record_Prompt,data,maxtime,false

09/02/2016 10:19:45.229,Record_Prompt,data,filename,201692-101.wav

09/02/2016 10:19:45.229,Record_Prompt,data,filepath,C:\201692-101.wav

09/02/2016 10:19:45.229,Record_Prompt,exit,done

09/02/2016 10:19:45.229,smb_copy,enter,

At 10:01:37.098, the web service exits successfully and the initial audio plays to the caller. This audio says something like press 1 when the recording is complete. The caller is talking for the next 18 minutes and when he is done he presses 1 on the keypad. For some reason the initial audio is played again at 10:19:38.702. You can see the duration of the recording is only 2180ms. I pasted the record element's audio settings below.

image7.png

can you post your gateway configuration - including space allotted for

ivr record...

VXML#sh run   

Building configuration...

Current configuration : 10034 bytes

!

version 15.1

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname VXML

!

boot-start-marker

boot system flash c3900-universalk9-mz.SPA.151-4.M9.bin

boot-end-marker

!

logging buffered 16000

enable secret <omitted>

!

aaa new-model

!

aaa authentication login default group tacacs+ local enable

aaa authentication login no_tacacs enable

aaa authorization exec default group tacacs+ local if-authenticated

aaa authorization network default group tacacs+ local

aaa accounting exec default

action-type start-stop

group tacacs+

!

aaa accounting commands 15 default

action-type start-stop

group tacacs+

!

aaa accounting network default

action-type start-stop

group tacacs+

!

aaa accounting connection default

action-type start-stop

group tacacs+

!

aaa accounting system default

action-type start-stop

group tacacs+

!

aaa session-id common

clock timezone EST -5 0

clock summer-time EST recurring

!

no ipv6 cef

no ip source-route

ip cef

!

no ip domain lookup

ip domain name erieinsurance.com

ip host mediaserver-backup <omitted>

ip host mediaserver <omitted>

multilink bundle-name authenticated

!

crypto pki token default removal timeout 0

!

voice-card 0

!

voice service voip

no ip address trusted authenticate

sip

  rel1xx disable

  min-se 360 session-expires 360

  header-passing

!

voice translation-rule 1

rule 1 /<omitted>/ //

!

!

voice translation-profile block

translate called 1

!

!

http client cache memory pool 100000

http client cache memory file 600

http client connection timeout 60

http client response timeout 30

ivr prompt memory 15000

ivr record memory system 61440

ivr record memory session 15360

!

application

service new-call flash:bootstrap.vxml

  paramspace english index 0

  paramspace english language en

  paramspace english location flash

  paramspace english prefix en

!

service ringtone flash:ringtone.tcl

  paramspace english language en

  paramspace english index 0

  paramspace english location flash

  paramspace english prefix en

!

service cvperror flash:cvperror.tcl

  paramspace english index 0

  paramspace english language en

  paramspace english location flash

  paramspace english prefix en

!

service handoff flash:handoff.tcl

  paramspace english language en

  paramspace english index 0

  paramspace english location flash

  paramspace english prefix en

!

service bootstrap flash:bootstrap.tcl

  paramspace english index 0

  paramspace english language en

  paramspace english location flash

  paramspace english prefix en

  param sigdigits 7

!

!

vxml tree memory 1000

license udi pid C3900-SPE150/K9 sn <omitted>

license boot module c3900 technology-package uck9

!

!

!

redundancy

!

!

ip ssh time-out 60

ip ssh version 2

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address <omitted>

no ip proxy-arp

duplex full

speed 1000

!

interface GigabitEthernet0/1

no ip address

no ip proxy-arp

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

no ip proxy-arp

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 <omitted>

!

logging facility local2

logging <omitted>

access-list 11 permit <omitted>

!

nls resp-timeout 1

cpd cr-id 1

!

tacacs-server host <omitted>

tacacs-server directed-request

tacacs-server key 7 <omitted>

!

!

!

control-plane

!

!

!

!

mgcp profile default

!

!

dial-peer voice <omitted> voip

description Required for CVP PM microapp

translation-profile incoming block

incoming called-number <omitted>

!

dial-peer voice <omitted> voip

description CVP SIP ringtone

translation-profile incoming block

service ringtone

incoming called-number <omitted>

voice-class sip rel1xx disable

dtmf-relay rtp-nte h245-signal h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice <omitted> voip

description CVP SIP error message

translation-profile incoming block

service cvperror

incoming called-number <omitted>

voice-class sip rel1xx disable

dtmf-relay rtp-nte h245-signal h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice <omitted> voip

description CVP VRU label

translation-profile incoming block

service bootstrap

incoming called-number <omitted>

dtmf-relay rtp-nte h245-signal h245-alphanumeric

codec g711ulaw

no vad

!

!

!

!

gatekeeper

shutdown

!

!

privilege exec level 15 configure

banner motd

!

line con 0

exec-timeout 5 0

password 7 <omitted>

login authentication no_tacacs

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

access-class 14 in

exec-timeout 3 0

password 7 <omitted>

transport input ssh

line vty 5 858

password 7 <omitted>

transport input ssh

!

scheduler allocate 20000 1000

ntp access-group peer 11

ntp server <omitted>

end

Hi Janine, I confirmed that I was running into bug CSCuw29082. I upgraded my VXML gateway to ios version 15.5(3)M3 and I no longer experience this issue. Thank you for your help on this one!

Thanks for letting me know. So can you now take recordings longer than

17min?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: