4 Replies Latest reply: Dec 6, 2017 9:01 AM by hecserra RSS

Router Unable to Use Backup LSP in MPLS FRR

ans298@pitt.edu

I have configured my MPLS enabled (OSPF overlayed, and using LDP for label distribution) R2 router's primary protected LSP as R2-R3-R4 and the backup LSP as R2-R4, which it should switch over to in case of any kind of node or link failure in the protected path.

Without a link failure, my packets are traversing the R2-R3-R4 path. But the link failure (which i triggered by doing a wire pull) is not switching the packets onto the backup link. I have tried to follow all instructions as per the documentation available at MPLS Traffic Engineering (TE)--Fast Reroute (FRR) Link and Node Protection - Cisco But am unable to figure out my mistake(s). Any insight would be appreciated. Thanks in advance.

Attached below are the configurations of R2 and R4, and the topology diagram.

Capture.JPG

R2 show run:

R1WB4#show run

Building configuration...

 

Current configuration : 2613 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1WB4

!

boot-start-marker

boot system flash:c2800nm-adventerprisek9-mz.124-24.T8.bin

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

!

!

!

dot11 syslog

ip source-route

!

!        

ip cef   

!        

!        

no ip domain lookup

no ipv6 cef

!        

multilink bundle-name authenticated

!        

!        

!        

!        

mpls traffic-eng tunnels

mpls label protocol ldp

!        

!        

!        

!        

!        

!        

!        

!        

!        

!        

!        

!        

!        

!        

!        

!        

!        

!        

!        

voice-card 0

!        

!        

!        

!        

!        

!        

archive  

log config

  hidekeys

!        

!        

!        

class-map match-any Test

class-map match-any WEB

match access-group 101

match  dscp ef

match access-group 102

!        

!        

policy-map QoS

class WEB

  set ip dscp ef

!        

!        

!        

!        

!        

interface Loopback0

ip address 192.168.41.1 255.255.255.0

!        

interface Tunnel1

ip unnumbered Loopback0

tunnel destination 192.168.42.1

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng autoroute announce

tunnel mpls traffic-eng path-option 1 explicit identifier 1

tunnel mpls traffic-eng fast-reroute bw-protect node-protect

no routing dynamic

!        

interface Tunnel2

ip unnumbered Loopback0

tunnel destination 192.168.42.1

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 2 explicit name avoid-protected-link

no routing dynamic

!        

interface FastEthernet0/0

ip address 192.168.20.1 255.255.255.0

ip virtual-reassembly

duplex auto

speed auto

service-policy output QoS

!        

interface FastEthernet0/1

ip address 192.168.30.2 255.255.255.0

ip virtual-reassembly

duplex auto

speed auto

mpls traffic-eng tunnels

mpls traffic-eng backup-path Tunnel2

mpls ip 

service-policy output QoS

ip rsvp bandwidth 16

!        

interface FastEthernet0/0/0

ip address 192.168.60.1 255.255.255.0

ip virtual-reassembly

duplex auto

speed auto

mpls traffic-eng tunnels

mpls ip 

ip rsvp bandwidth 16

!        

router ospf 1

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

log-adjacency-changes

network 172.20.1.0 0.0.0.3 area 0

network 192.168.1.1 0.0.0.0 area 0

network 192.168.20.0 0.0.0.255 area 0

network 192.168.30.0 0.0.0.255 area 0

network 192.168.41.0 0.0.0.255 area 0

network 192.168.60.0 0.0.0.255 area 0

!        

ip forward-protocol nd

ip http server

no ip http secure-server

!        

!        

!        

ip explicit-path identifier 1 enable

next-address 10.99.99.2

next-address 192.168.42.1

!        

ip explicit-path name avoid-protected-link enable

next-address 192.168.42.1

!        

!        

!        

!        

!        

!        

mpls ldp router-id Loopback0 force

!        

control-plane

!        

!        

!        

!        

!        

!        

!        

!        

!        

!        

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

login   

!        

scheduler allocate 20000 1000

end      

       

R1WB4#

 

R4 show run:

R2WB4#show run
Building configuration...


Current configuration : 1991 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2WB4
!
boot-start-marker
boot system flash:c2800nm-adventerprisek9-mz.124-24.T8.bin
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
!
!
dot11 syslog
ip source-route
!
!        
ip cef   
!        
!        
no ip domain lookup
no ipv6 cef
!        
multilink bundle-name authenticated
!        
!        
!        
!        
mpls traffic-eng tunnels
mpls label protocol ldp
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
voice-card 0
!        
!        
!        
!        
!        
!        
archive  
log config
hidekeys
!        
!        
!        
class-map match-any Test
class-map match-any WEB
match access-group 101
match dscp ef
match access-group 102
!        
!        
policy-map QoS
class WEB
set ip dscp ef
!        
!        
!        
!        
!        
interface Loopback0
ip address 192.168.42.1 255.255.255.0
!        
interface FastEthernet0/0
ip address 192.168.50.1 255.255.255.0
ip virtual-reassembly
duplex auto
speed auto
mpls traffic-eng tunnels
service-policy output QoS
ip rsvp bandwidth 16
!        
interface FastEthernet0/1
ip address 192.168.40.1 255.255.255.0
ip virtual-reassembly
duplex auto
speed auto
mpls traffic-eng tunnels
mpls ip
service-policy output QoS
ip rsvp bandwidth 16
!        
interface FastEthernet0/0/0
ip address 192.168.60.2 255.255.255.0
ip virtual-reassembly
duplex auto
speed auto
mpls traffic-eng tunnels
mpls ip
!        
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 172.20.1.0 0.0.0.3 area 0
network 172.20.1.4 0.0.0.3 area 0
network 192.168.1.2 0.0.0.0 area 0
network 192.168.40.0 0.0.0.255 area 0
network 192.168.42.0 0.0.0.255 area 0
network 192.168.50.0 0.0.0.255 area 0
network 192.168.60.0 0.0.0.255 area 0
!        
router isis 1
!        
no ip forward-protocol nd
no ip http server
no ip http secure-server
!        
!        
!        
!        
!        
!        
!        
!        
mpls ldp router-id Loopback0 force
!        
control-plane
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!        
scheduler allocate 20000 1000
end      

R2WB4#