cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
836
Views
1
Helpful
5
Replies

MVPN configuration

sachin30720041
Level 1
Level 1

Hello All,

ios4----(g1)CSR1(g2)---------(g2)CSR2(g1)--------------(gi0/0/0/1)XRv3(gi0/0/0/2)----------(gii0/0/0/2)XRV4(gi0/0/0/0)-----ios5

ios4 and ios5 are CE routers.

CSR1 and XRV4 are PE routers. CSR3 and XRV3 are P routers.

I have done MVPN configuration on PE and P router. VPNV4 routes are exchanged between ios4 and ios5. SSM(231.231.0.0/16) is configured on PE and P routers. On IOS5, 'show ip pim rp mapping' command show empty results. I am not sure what configuration am I missing ?

ios4
----------------
ip multicast-routing

ip pim bsr-candidate lo0

ip pim rp-candidate lo0

int gi0/1
ip address 100.10.40.4 255.255.255.0
ip pim sparse-mode
ip ospf 1 area 0
no sh

int lo0
ip address 4.4.4.4 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
exit

router ospf 1
exit


CSR1
----------------
ip multicast-routing distributed
ip multicast-routing vrf vrf1 distributed

vrf def vrf1
rd 1:1
address-family ipv4 unicast
route-target import 4:4
route-target export 1:1
mdt default 231.231.0.10
mdt data 231.231.10.0 0.0.0.255
mdt auto-discovery pim
exit

ip access-list standard SSM
permit 231.231.0.0 0.0.255.255
exit

ip pim ssm range SSM

router ospf 1 vrf vrf1
redistribute bgp 14
exit

int gi1
vrf forwarding vrf1
ip address 100.10.40.1 255.255.255.0
ip pim sparse-mode
ip ospf 1 area 0
no sh

int gi2
ip address 100.10.20.1 255.255.255.0
ip pim sparse-mode
ip router isis 1
isis network point-to-point
no sh


int lo0
ip address 1.1.1.1 255.255.255.255
ip router isis 1
ip pim sparse-mode
exit

router isis 1
passive-interface lo0
advertise passive-only
net 49.0001.1111.1111.1111.00
is-type level-2
metric-style wide
mpls ldp autoconfig
exit


router bgp 14
neighbor 4.4.4.4 remote-as 14
neighbor 4.4.4.4 update-source lo0
address-family ipv4 mvpn
neighbor 4.4.4.4 activate
exit
address-family vpnv4 unicast
neighbor 4.4.4.4 activate
exit
address-family ipv4 vrf vrf1
redistribute ospf 1
exit
exit


CSR2
---------------
ip multicast-routing distributed

ip access-list standard SSM
permit 231.231.0.0 0.0.255.255
exit

ip pim ssm range SSM

int gi2
ip address 100.10.20.2 255.255.255.0
ip router isis 1
ip pim sparse-mode
isis network point-to-point
no sh

int gi1
ip address 100.20.30.2 255.255.255.0
ip router isis 1
ip pim sparse-mode
isis network point-to-point
exit

int lo0
ip address 2.2.2.2 255.255.255.255
ip router isis 1
ip pim sparse-mode
exit

router isis 1
passive-interface lo0
advertise passive-only
net 49.0001.2222.2222.2222.00
is-type level-2
metric-style wide
mpls ldp autoconfig
exit


XRV3
----------------------------------
mpls ldp
exit

int gi0/0/0/1
ipv4 address 100.20.30.3 255.255.255.0
no sh

int gi0/0/0/2
ipv4 address 100.30.40.3 255.255.255.0
no sh

int lo0
ipv4 address 3.3.3.3 255.255.255.255
exit

ipv4 access-list SSM
permit ipv4 231.231.0.0 0.0.255.255 any
exit

router pim
address-family ipv4
ssm range SSM
int gi0/0/0/1
enable
int gi0/0/0/2
enable
int lo0
enable
exit
root

multicast-routing
address-family ipv4
int gi0/0/0/1
enable
int gi0/0/0/2
enable
int lo0
enable
exit
root

router isis 1
net 49.0001.3333.3333.3333.00
is-type level-2
address-family ipv4 unicast
metric-style wide
mpls ldp auto-config
exit
int gi0/0/0/1
point-to-point
address-family ipv4 unicast
exit
int gi0/0/0/2
point-to-point
address-family ipv4 unicast
exit
int lo0
passive
address-family ipv4 unicast
exit
root


XRV4
--------------------
mpls ldp
exit

vrf vrf1
address-family ipv4 unicast
import route-target 1:1
export route-target 4:4
exit
root

int gi0/0/0/0
vrf vrf1
ipv4 address 100.40.50.4 255.255.255.0
no sh

int gi0/0/0/2
ipv4 address 100.30.40.4 255.255.255.0
no sh

int lo0
ipv4 address 4.4.4.4 255.255.255.255
exit

ipv4 access-list SSM
permit ipv4 231.231.0.0 0.0.255.255 any
exit

route-policy pol1
set core-tree pim-default
exit

router pim
address-family ipv4
ssm range SSM
int gi0/0/0/2
enable
int lo0
enable
vrf vrf1
address-family ipv4
rpf topology route-policy pol1
int gi0/0/0/0
enable
exit
root

multicast-routing
address-family ipv4
int gi0/0/0/2
enable
int lo0
enable
exit
vrf vrf1
address-family ipv4
int gi0/0/0/0
enable
mdt default ipv4 231.231.0.10
mdt data 231.231.10.0/24
mdt source lo0
bgp auto-discovery pim
root

router isis 1
net 49.0001.4444.4444.4444.00
is-type level-2
address-family ipv4 unicast
metric-style wide
mpls ldp auto-config
exit
int gi0/0/0/2
point-to-point
address-family ipv4 unicast
exit
int lo0
passive
address-family ipv4 unicast
exit
root


router ospf 1
vrf vrf1
redistribute bgp 14
area 0
int gi0/0/0/0
exit
root

router bgp 14
mvpn
address-family ipv4 mvpn
exit
address-family ipv4 unicast
exit
address-family vpnv4 unicast
exit
neighbor 1.1.1.1
remote-as 14
update-source lo0
address-family vpnv4 unicast
exit
address-family ipv4 mvpn
exit
vrf vrf1
rd 4:4
address-family ipv4 unicast
redistribute ospf 1
exit
address-family ipv4 mvpn
exit
root

ios5
----------------
ip multicast-routing

int gi0/0
ip address 100.40.50.5 255.255.255.0
ip ospf 1 area 0
ip pim sparse-mode
no sh

int lo0
ip address 5.5.5.5 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
exit

router ospf 1
exit

Thanks,

Sachin

1 Accepted Solution

Accepted Solutions

Harold Ritter
Cisco Employee
Cisco Employee

Hi @sachin30720041 ,

I think the fact that you are using the loopback address 4.4.4.4 on the BSR candidate RP (ios4) and on XRV4 might create a conflict. To validate that, could you run a "debug pim bsr" on XRV4. Don't forget to configure "logging console debugging" and commit for debug to work.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

5 Replies 5

diefierr
Cisco Employee
Cisco Employee

Hi @sachin30720041 
Is my understanding that this is a lab, and you learning how MVPN Profile 0 works.

you asking why "show ip pim rp mapping"  is empty, but i dont see any PIM RP configure anywhere.

i think you should go step by step.

1.- in CE <--> PEs, do we have pim neighbor? show ip pim vrf <vrf> interface / show ip pim vrf <vrf> neighbor
2.- in PE <--> P, do we have pim neighbor? show pim interface / show pim neighbor
3.- in PEs do you see PIM Neighbor the other PE via default MDT? show pim bgp / show bgp ipv4 mvpn summary / show pim vrf <vrf> neigbhro

you need to be sure all interface in the CORE are running PIM
you need to be sure all interface in the VRF are running PIM
look for BGP AFI to be up and advertising / learning mvpn routes
look for default MDT to be up.

Diego

Hi @diefierr ,

> you asking why "show ip pim rp mapping"  is empty, but i dont see any PIM RP configure anywhere.

This is because SSM is configured in the core and BSR is used in the VRF. Either technique does not require explicit RP configuration.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

My friend @Harold Ritter  if the underlay default MDT is not properly build no way IOS5 can see a thing.
So looking for pim rp before been sure if the CORE is working, if PIM Neigh are seen at VRF level between PEs is useless.

Always great to see you around.
Diego

Hi @diefierr ,

The default MDT should be just fine. It uses PIM SSM. There is absolutely no need for an RP in the core. The issue is not with the MDT here. The reason that ios5 does not receive the BSR messages is probably just that XRV4 is dropping them, as it sees a conflict with its own ip address. I am waiting for @sachin30720041 to confirm with the "debug pim bsr" output.

Good to hear from you too.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Harold Ritter
Cisco Employee
Cisco Employee

Hi @sachin30720041 ,

I think the fact that you are using the loopback address 4.4.4.4 on the BSR candidate RP (ios4) and on XRV4 might create a conflict. To validate that, could you run a "debug pim bsr" on XRV4. Don't forget to configure "logging console debugging" and commit for debug to work.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México